Unable to see TV Shows

plex-for-kodi

#1

Hi guys,

From what i can hear here the plugin is almost non developed. However, i'm using it and having an issue when trying to see all of my tv shows.

It throws:

20:41:31.424 T:3326079744 WARNING: CSkinInfo: failed to load skin settings
20:41:32.173 T:3326079744 WARNING: Previous line repeats 2 times.
20:41:32.173 T:3326079744 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
- NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
Error Type:
Error Contents: (500) internal_server_error
Traceback (most recent call last):
File "/home/osmc/.kodi/addons/script.plex/lib/windows/kodigui.py", line 99, in onInit
self.onFirstInit()
File "/home/osmc/.kodi/addons/script.plex/lib/windows/kodigui.py", line 747, in onFirstInit
self.onFirstInit()
File "/home/osmc/.kodi/addons/script.plex/lib/windows/library.py", line 480, in onFirstInit
self.fill()
File "/home/osmc/.kodi/addons/script.plex/lib/windows/library.py", line 1227, in fill
self.fillShows()
File "/home/osmc/.kodi/addons/script.plex/lib/windows/busy.py", line 19, in inner
return func(*args, **kwargs)
File "/home/osmc/.kodi/addons/script.plex/lib/windows/library.py", line 1274, in fillShows
jumpList = self.section.jumpList(filter
=self.getFilterOpts(), sort=self.getSortOpts(), unwatched=self.filterUnwatched, type_=type_)
File "/home/osmc/.kodi/addons/script.plex/lib/_included_packages/plexnet/plexlibrary.py", line 182, in jumpList
return plexobjects.listItems(self.server, path, bytag=True)
File "/home/osmc/.kodi/addons/script.plex/lib/_included_packages/plexnet/plexobjects.py", line 516, in listItems
data = data if data is not None else server.query(path)
File "/home/osmc/.kodi/addons/script.plex/lib/_included_packages/plexnet/plexserver.py", line 175, in query
raise exceptions.BadRequest('({0}) {1}'.format(response.status_code, codename))
BadRequest: (500) internal_server_error
-->End of Python script error report<--

Works in other clients just fine, comptability issue with latest server perhaps?


#2

Installed the plugin and Kodi on my laptop.

Worked fine so it’s a local problem contained to my Vero 4K/OSMC installation. Tried re-installing but it kept settings etc - is there a way to “reset” the plugin/db?


#3

Further analysis, here is the Plex Media Server log, when it happens:

Apr 30, 2018 20:00:01.387 [0x7fb012111700] ERROR - SQLITE3:0x10, 1, near “,”: syntax error
Apr 30, 2018 20:00:01.388 [0x7fb012111700] ERROR - Soci Exception handled: sqlite3_statement_backend::prepare: near “,”: syntax error for SQL: select upper(substr((select, 1, 1)) as c,count(distinct metadata_items.id) from metadata_items left join metadata_item_settings on metadata_item_settings.guid=metadata_items.guid and metadata_item_settings.account_id= 1 where metadata_items.library_section_id=? and metadata_items.library_section_id in (4) and ((select count(*) from metadata_items as leaves join metadata_items as parents on leaves.parent_id=parents.id left join metadata_item_settings on metadata_item_settings.guid = leaves.guid and metadata_item_settings.account_id=1 where (parents.parent_id=metadata_items.id or parents.id=metadata_items.id) and (metadata_item_settings.view_count=0 or metadata_item_settings.view_count is null) and leaves.metadata_type in (1, 4, 10))>=1 and metadata_items.metadata_type=2) group by c order by c

Appears to be some sort of SQLITE error?


#4

Found the problem and a temporary work-around. I’m going to add this to github hoping that someday someone from Plex will fix the problem.

Delete settings.xml in your userdata folder of Kodi. This will re-set the plugin to defaults. Now i can access my TV Shows database.

If i choose unwatched shows only, it shows my unwatched shows. I do like it to show me in descending number how many episodes i have missed, so choosing unwatched shows, sort by unwatched - this will crash the plugin and produce the error above with SQLITE problem.

Running latest 0.1.4 plugin version on Kodi 17.6, OSMC March level patch - Vero 4k. Plex server version 1.13


#5

This has been fixed in 0.1.5: https://github.com/plexinc/plex-for-kodi/releases/tag/v0.1.5