Unclaimed after reboot ubuntu

server-linux

#1

I have just installed plex on a fresh install of ubuntu 16.04 lts. I plan on moving my media from another box to this one once it is working. But everytime I restart the pc plex is back to unclamied.
It remembers my login but doesn't sign in untill I manually click sign in or claim server.

Any idea how to fix this. I am also using it as a steam streaming pc.


#2

Go to Settings - Server - General and set it manually there. This will sign it into your Plex account. Provided you don’t delete “Preferences.xml”, it will remember it belongs to you at next restart.


#3

Already done that. Then I just restart the pc and its back to unclaimed.


#4

how can that be? When you sign in, Preferences.xml is updated with your information.

May I have your log files? (Settings - Server - Help - Download logs)


#5

If your change preferences for the unclaimed server are they kept after a reboot?

My thinking is a permission problem with with the file or library folder.

What’s the owner and permissions for the preferences.xml file and library folder?


#6

The file /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml is what’s in question.

If there were a permissions problem, then it likely is going to impact a whole lot more than just Preferences and should be crashing Plex (no database access)

When in doubt sudo chown -R plex:plex /var/lib/plexmediaserver/Library to force it all. Next ls -la "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml" and see what the file permissions are.


#7

Well, I got exactly the same issue.
Server is working nicely (fresh debian install, instead of Ubuntu).
All my medias are here, tagged etc.
But every time I reboot the server, and go on my account, the server is unclaimed.

plex@SynchroPouic:$ ls -la "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml"
-rw------- 1 plex plex 934 déc.  30 18:06 /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Preferences.xml

Looks like permissions are the right ones.


#8

Log files please?


#9

OK, so here we go ! Logs and capture (seen that asked in another thread)


#10

Hi there, any news ?
Happy new year all !


#11

Yes, I have finally had time to go through your log files.

Your server has DNS failures at initial startup.

Dec 30, 2016 18:45:12.811 [0x7f9d7a3ff700] DEBUG - HTTP requesting GET https://plex.tv/servers/57f44f353d46818c55f994cdc24d8fe3f95dd1eb/access_tokens.xml?includeProfiles=1&includeProviders=1&auth_token=xxxxxxxxxxxxxxxxxxxx
Dec 30, 2016 18:45:12.811 [0x7f9d7a3ff700] ERROR - Error issuing curl_easy_perform(handle): 6
Dec 30, 2016 18:45:12.811 [0x7f9d7a3ff700] WARN - HTTP error requesting GET https://plex.tv/servers/57f44f353d46818c55f994cdc24d8fe3f95dd1eb/access_tokens.xml?includeProfiles=1&includeProviders=1&auth_token=xxxxxxxxxxxxxxxxxxxx (0, No error) (Couldn't resolve host 'plex.tv')
Dec 30, 2016 18:45:12.811 [0x7f9d7a3ff700] DEBUG - MyPlex: using cached data for request for https://plex.tv/servers/57f44f353d46818c55f994cdc24d8fe3f95dd1eb/access_tokens.xml?includeProfiles=1&includeProviders=1&auth_token=xxxxxxxxxxxxxxxxxxxx

Apparently at some point, your host or networking ‘resolve’ and all is well again.

Dec 30, 2016 18:47:27.423 [0x7f9d6dff8700] DEBUG - MyPlex: Requesting reachability check.
Dec 30, 2016 18:47:27.423 [0x7f9d6dff8700] DEBUG - HTTP requesting PUT https://plex.tv/api/servers/57f44f353d46818c55f994cdc24d8fe3f95dd1eb/connectivity?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx&asyncIdentifier=f63d6723-e8e4-4e97-afae-387b64d9dd4d
Dec 30, 2016 18:47:27.444 [0x7f9d78bfe700] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
Dec 30, 2016 18:47:27.444 [0x7f9d78bfe700] DEBUG - Auth: authenticated user 1 as LordK1
Dec 30, 2016 18:47:27.444 [0x7f9d78bfe700] DEBUG - Auth: Came in with a super-token, authorization succeeded.

#12

Ok. So the server is unclaimed cause it doesn’t manage to contact an url to verify something, right ?
What can I do, then ? Cause I’m pretty sure of my internet connexion.
Can it be a problem on my server, like a lack of internet connexion for short time after reboot ? I’m ready to do every test you want to get it working :slight_smile:


#13

You’re correct. When PMS starts to come up, it has started declaring itself as available on the local lan but not yet completed communicating with plex.tv so it can complete initialization of the underlying services (metadata, etc). Another part of this initialization is ‘signing in’ (settings - server - general)

Your browser sees the server locally, but doesn’t see a corresponding timestamp at Plex.tv in your account.

This can happen, and matches with your assumption, when sometimes, depending on the host OS and any other software involved, the internet adapter’s configuration isn’t fully ‘UP’ (external gateway & routing) when PMS needs it. One such example of this is if you have a VPN which starts after PMS does, when it engages and switches the routing to tunnel through the VPN, there is that window of vulnerability. Adapter is ‘UP’ but ‘not really’. PMS will have sent out requests / notifications through the old route (your real ISP) but now is listening for them to come from the VPN. That won’t happen. Some time later (15 minutes typically) PMS tries again. Communication is stable and request+reply are as expected… Begin “Life is Good” operation.

Is there anything else you have there?

As example here: 1) No VPN or 2) no secondary routers or security/provisioning devices . The adapter is started with a static IP when the host starts and does not wait for DHCP to issue an IP address (also possible latency and potentially incorrect gateway information if the DHCP information isn’t correct)… might this be an issue?


#14

Ok. There is a DHCP adressing a static IP to the server. I’ll try fixing it static on the server itself, instead.
Thank you !


#15

Ok, I’ve tried some things, but nothing seems to work. And an annoying thing is that all the server related settings are resetted after a reboot (transcoder directory, saves directory, etc.). I didn’t noticed that before, cause I didn’t make so much modifications, but now, I’m some kind of disapointed.

When I go back to the server, librarys are here, but the server looks like a fresh install, proposing me the first setup guide.

And still the server needed to be claimed.


#16

/ partition full… Dunno why, investigating. But it surely is related.


#17

If the root partition is full, I am quite surprised the machine runs at all. There should be errors screaming from everywhere.

A number of distributions seem to be very hung up on making the root only as big as they think will ever be needed. With PMS using /var this can, and has, been problematic for some.

Relating the Library, through various means is easy and 100% effective. The easiest is to use the systemd override mechanism. The other method, bind mounting to another file system (e.g. /home needs a couple extra steps but equally effective.


#18

I tried to move the Library, but plex won’t start anymore. I may have ■■■■ something up.
I was waiting for a new SSD, so I will reinstall the all server on it tomorrow, and won’t let the auto partition put only 12Gb for the root… :smiley: Making mistakes is the best way to learn.


#19

I appear to have the same issue as LordK1. I parsed through my log file and found the same error. My root partition has plenty of space though. I’m running a Dual Xeon 2670 on an Intel S2600CP2J motherboard running Mint 18.1 64-bit.

I don’t have a VPN setup and I have never set anything to a static IP. Anyone have some thoughts on where I should start?


#20

Please look at this: This is at the root of the problems. DNS name lookup failures.

Line 17.
Jan 20, 2017 15:43:30.593 [0x7fb60cffd700] WARN - HTTP error requesting GET https://plex.tv/servers/fc97a68dbb272aa97eb520bb3e95cf1b79e7c118/access_tokens.xml?includeProfiles=1&includeProviders=1&auth_token=xxxxxxxxxxxxxxxxxxxx (0, No error) (Couldn't resolve host 'plex.tv')