# unexpected error loading the dashboard

**URL:** https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008
**Category:** Plex Pass Betas
**Created:** [August 26, 2017, 11:16pm UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008 "2017-08-26T23:16:27Z")
**Posts on this page:** 17
**Page:** 1

<div class="post-metadata">

### Author: ![Skinns](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@Skinns](https://forums.plex.tv/u/Skinns)
#### Post date: [August 26, 2017, 11:16pm UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/1 "2017-08-26T23:16:27Z")

</div>

I have read multiple suggestions to fix this error that just showed up today but nothing has helped. everything else works other than viewing the dashboard.

I am running server version: 1.8.1.4139  
OS: Ubuntu 14.04  
So far this is what I have tried:

- optimize db using UI and also curl commands
- check db for errors (non reported)
- ran db repair process stated in the plex support docs
- Downgrading to different plex server versions.
- restarted plex media server and the computer

None of these have worked, is there anything else i can try? Am I going to have to do a fresh install and if I do that will I loose all of my settings? I dont mind rebuilding the libraries but it would be nice to keep my watched/unwatched progress if I have to do this.

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [August 27, 2017, 12:05am UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/2 "2017-08-27T00:05:00Z")

</div>

Logs please … for first load on 1.8.1.4139 after upgrade

[https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server](https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server)  
[https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files](https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files)

---

<div class="post-metadata">

### Author: ![Skinns](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@Skinns](https://forums.plex.tv/u/Skinns)
#### Post date: [August 27, 2017, 12:17am UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/3 "2017-08-27T00:17:09Z")

</div>

I got impatient and decided to remove my largest library. Once I removed it the dashboard started working again instantly. I am now adding the library back hoping the dashboard will still work after.

EDIT: while loading the library back the dashboard stopped working again.  
Should I let the library load then give logs?

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [August 27, 2017, 1:05am UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/4 "2017-08-27T01:05:06Z")

</div>

If adding lots of items then the database may need to be optimised - this should happen periodically anyway

No harm in collecting logs now and save them to upload later after completing the task and running. Database optimize and errors persist

---

<div class="post-metadata">

### Author: ![Skinns](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@Skinns](https://forums.plex.tv/u/Skinns)
#### Post date: [August 28, 2017, 7:50pm UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/5 "2017-08-28T19:50:56Z")

</div>

So after removing all of my libraries then taking 2 days to add all of my libraries again the dashboard was working. I went to bed and when I woke up the dashboard is not loading again. Logs are attached. this is also a fresh upgrade to 1.8.1.4139 and I have tried to optimize the database several times.

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [August 29, 2017, 2:04am UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/6 "2017-08-29T02:04:16Z")

</div>

> @Skinns said:  
> So after removing all of my libraries then taking 2 days to add all of my libraries again the dashboard was working. I went to bed and when I woke up the dashboard is not loading again. Logs are attached. this is also a fresh upgrade to 1.8.1.4139 and I have tried to optimize the database several times.

Thanks for the logs.

I can see that the database optimization completed at 15:16:06 whilst on release 1.5.2.  
Following that the server came up on 1.8.1 at 15:43:17  
There were a couple of dashboard hubs requests that took a long time.  
There appears to be what looks like a misbehaving plex client app bombarding the server with repeated requests and adding to the server load.

We had two requests that took a long time - this was one of them

```auto
Aug 28, 2017 15:45:22.834 [0x760a7238a700] DEBUG - Request: [173.244.48.67:56651 (WAN)] GET /hubs?excludeFields=summary&count=12&includeEmpty=1&includeFeaturedTags=1&excludePlaylists=1 (19 live) TLS GZIP Signed-in Token (Skinns)

Aug 28, 2017 15:45:57.613 [0x760a8c2c6700] DEBUG - Completed: [173.244.48.67:56651] 200 GET /hubs?excludeFields=summary&count=12&includeEmpty=1&includeFeaturedTags=1&excludePlaylists=1 (27 live) TLS GZIP 34779ms 10240 bytes (pipelined: 1)

```

During this period between 15:45:22 and 15:45:57, we had repeated requests from a device for remote user `sgc0875`  
Please try to find out what device it was and what plex app and version. This shows the requests during the period

```auto
Aug 28, 2017 15:45:27.050 [0x760a73391700] DEBUG - Request: [174.0.39.14:57887 (WAN)] GET /hubs/sections/15 (23 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:28.038 [0x760a79f6b700] DEBUG - Request: [174.0.39.14:57891 (WAN)] GET /hubs/sections/15 (23 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:28.094 [0x760a6efd0700] DEBUG - Request: [174.0.39.14:57888 (WAN)] GET /hubs/sections/15 (22 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:28.332 [0x760a74715700] DEBUG - Request: [174.0.39.14:57885 (WAN)] GET /hubs/sections/15 (22 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:28.357 [0x760a77f0f700] DEBUG - Request: [174.0.39.14:57886 (WAN)] GET /hubs/sections/15 (22 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:28.496 [0x760a7af9f700] DEBUG - Request: [174.0.39.14:57890 (WAN)] GET /hubs/sections/15 (22 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:28.577 [0x760a7bf1a700] DEBUG - Request: [174.0.39.14:57889 (WAN)] GET /hubs/sections/15 (22 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:33.508 [0x760a78f81700] DEBUG - Request: [174.0.39.14:57892 (WAN)] GET /hubs/sections/15 (23 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:35.288 [0x760a7af9f700] DEBUG - Request: [174.0.39.14:57886 (WAN)] GET /hubs/sections/15 (26 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:35.358 [0x760a7bf1a700] DEBUG - Request: [174.0.39.14:57887 (WAN)] GET /hubs/sections/15 (26 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:35.441 [0x760a6d786700] DEBUG - Request: [174.0.39.14:57889 (WAN)] GET /hubs/sections/15 (24 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:35.442 [0x760a74fe0700] DEBUG - Request: [174.0.39.14:57888 (WAN)] GET /hubs/sections/15 (24 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:35.626 [0x760a7df60700] DEBUG - Request: [174.0.39.14:57891 (WAN)] GET /hubs/sections/15 (23 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:35.770 [0x760a6f7f4700] DEBUG - Request: [174.0.39.14:57885 (WAN)] GET /hubs/sections/15 (22 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:35.781 [0x760a76fd2700] DEBUG - Request: [174.0.39.14:57890 (WAN)] GET /hubs/sections/15 (21 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:36.849 [0x760a73391700] DEBUG - Request: [174.0.39.14:57892 (WAN)] GET /hubs/sections/15 (22 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:39.834 [0x760a77f0f700] DEBUG - Request: [174.0.39.14:57886 (WAN)] GET /hubs/sections/15 (20 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:41.823 [0x760a74fe0700] DEBUG - Request: [174.0.39.14:57890 (WAN)] GET /hubs/sections/15 (25 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:41.978 [0x760a6efd0700] DEBUG - Request: [174.0.39.14:57892 (WAN)] GET /hubs/sections/15 (25 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:42.208 [0x760a75f4a700] DEBUG - Request: [174.0.39.14:57891 (WAN)] GET /hubs/sections/15 (26 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:42.244 [0x760a7cf7e700] DEBUG - Request: [174.0.39.14:57889 (WAN)] GET /hubs/sections/15 (25 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:42.474 [0x760a73391700] DEBUG - Request: [174.0.39.14:57886 (WAN)] GET /hubs/sections/15 (25 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:42.555 [0x760a7af9f700] DEBUG - Request: [174.0.39.14:57887 (WAN)] GET /hubs/sections/15 (24 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:42.758 [0x760a76fd2700] DEBUG - Request: [174.0.39.14:57888 (WAN)] GET /hubs/sections/15 (24 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:42.776 [0x760a77f0f700] DEBUG - Request: [174.0.39.14:57885 (WAN)] GET /hubs/sections/15 (24 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:46.317 [0x760a74fe0700] DEBUG - Request: [174.0.39.14:57892 (WAN)] GET /hubs/sections/15 (24 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:46.544 [0x760a6efd0700] DEBUG - Request: [174.0.39.14:57886 (WAN)] GET /hubs/sections/15 (25 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:47.162 [0x760a73391700] DEBUG - Request: [174.0.39.14:57888 (WAN)] GET /hubs/sections/15 (27 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:47.643 [0x760a76fd2700] DEBUG - Request: [174.0.39.14:57887 (WAN)] GET /hubs/sections/15 (27 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:47.731 [0x760a75f4a700] DEBUG - Request: [174.0.39.14:57885 (WAN)] GET /hubs/sections/15 (28 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:47.837 [0x760a7df60700] DEBUG - Request: [174.0.39.14:57889 (WAN)] GET /hubs/sections/15 (26 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:47.872 [0x760a79f6b700] DEBUG - Request: [174.0.39.14:57891 (WAN)] GET /hubs/sections/15 (24 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:47.887 [0x760a6f7f4700] DEBUG - Request: [174.0.39.14:57890 (WAN)] GET /hubs/sections/15 (23 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:50.838 [0x760a7af9f700] DEBUG - Request: [174.0.39.14:57892 (WAN)] GET /hubs/sections/15 (27 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:51.352 [0x760a74715700] DEBUG - Request: [174.0.39.14:57886 (WAN)] GET /hubs/sections/15 (26 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:52.175 [0x760a6d786700] DEBUG - Request: [174.0.39.14:57888 (WAN)] GET /hubs/sections/15 (27 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:53.196 [0x760a6efd0700] DEBUG - Request: [174.0.39.14:57890 (WAN)] GET /hubs/sections/15 (29 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:53.804 [0x760a73391700] DEBUG - Request: [174.0.39.14:57891 (WAN)] GET /hubs/sections/15 (30 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:53.851 [0x760a6f7f4700] DEBUG - Request: [174.0.39.14:57889 (WAN)] GET /hubs/sections/15 (30 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:53.927 [0x760a74fe0700] DEBUG - Request: [174.0.39.14:57887 (WAN)] GET /hubs/sections/15 (30 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:53.953 [0x760a75f4a700] DEBUG - Request: [174.0.39.14:57885 (WAN)] GET /hubs/sections/15 (30 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:55.579 [0x760a77f0f700] DEBUG - Request: [174.0.39.14:57886 (WAN)] GET /hubs/sections/15 (29 live) TLS GZIP Signed-in Token (sgc0875)
Aug 28, 2017 15:45:55.929 [0x760a7cf7e700] DEBUG - Request: [174.0.39.14:57892 (WAN)] GET /hubs/sections/15 (28 live) TLS GZIP Signed-in Token (sgc0875)

```

I am sure these were contributing to the problem.

The logs also showed some possible areas where the requests that are taking too long could be fine tuned further. This is being raised with the development team

---

<div class="post-metadata">

### Author: ![Skinns](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@Skinns](https://forums.plex.tv/u/Skinns)
#### Post date: [August 29, 2017, 3:41am UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/7 "2017-08-29T03:41:29Z")

</div>

thanks for the information, so at this point do you think the best course of action is to just do a complete fresh server install?

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [August 29, 2017, 7:46am UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/8 "2017-08-29T07:46:42Z")

</div>

> @Skinns said:  
> thanks for the information, so at this point do you think the best course of action is to just do a complete fresh server install?

The action now is to find out what device / app was bombarding the server with the same hubs request continuously and suspend its use for a while and then capture logs if the problem does not go away

And to have the plex client app investigated and that behaviour changed

---

<div class="post-metadata">

### Author: ![Skinns](https://avatars.discourse-cdn.com/v4/letter/s/c77e96/32.png) [@Skinns](https://forums.plex.tv/u/Skinns)
#### Post date: [August 29, 2017, 9:28am UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/9 "2017-08-29T09:28:57Z")

</div>

I sort of jumped the gun and started a fresh install, I have disabled any client access to the server from my friends and family once its all setup and working I will only allow people/devices to connect one at a time to see if I can single out the source of the issue. Thanks for your help I appreciate it.

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [January 26, 2018, 10:10am UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/10 "2018-01-26T10:10:32Z")

</div>

> @sa2000 said:

> The logs also showed some possible areas where the requests that are taking too long could be fine tuned further. This is being raised with the development team

Just an update to say that thus has now been addressed and released in Plex Media Server beta release 1.11.1.

See Release Notice  
[http://forums.plex.tv/discussion/comment/1602026/#Comment\_1602026](http://forums.plex.tv/discussion/comment/1602026/#Comment_1602026)

- (Hubs) Improved the performance of the Recently Added TV hub (#7656)

---

<div class="post-metadata">

### Author: ![grav\_cyber](https://avatars.discourse-cdn.com/v4/letter/g/59ef9b/32.png) [@grav\_cyber](https://forums.plex.tv/u/grav_cyber)
#### Post date: [January 27, 2018, 11:06pm UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/11 "2018-01-27T23:06:54Z")

</div>

Since i updated to 1.11.1.4730 all managed users have this bug on startpage, as an admin user all works for me

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [January 27, 2018, 11:13pm UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/12 "2018-01-27T23:13:12Z")

</div>

> @grav_cyber said:  
> Since i updated to 1.11.1.4730 all managed users have this bug on startpage, as an admin user all works for me

could you provide logs / screenshot and time of the error?

Please ensure [debug logging](https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/#toc-1) enabled on the server - see [https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/](https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/)

Please Restart the server before reproducing the error

When the error is displayed, take a screenshot and note the time of the error  
Then wait 1 minute to make sure any requests do complete and switch to the admin account and download the logs and attach the logs zip and screenshot and details about what user and what time the error was retuned

See [https://support.plex.tv/articles/200250417-plex-media-server-log-files/](https://support.plex.tv/articles/200250417-plex-media-server-log-files/)

---

<div class="post-metadata">

### Author: ![imajes](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/imajes/32/332465_2.png) [@imajes](https://forums.plex.tv/u/imajes)
#### Post date: [January 28, 2018, 5:22pm UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/13 "2018-01-28T17:22:46Z")

</div>

as mentioned elsewhere, looks like this issue is to do with a malformed SQL exception. This happens when the dash is loaded as a managed user…

`Jan 28, 2018 12:16:56.061 [0x7f276fbff700] ERROR - QueryParser: Invalid field 'onlyTransient' found, ignoring. Jan 28, 2018 12:16:56.061 [0x7f276fbff700] ERROR - SQLITE3:0x10, 1, near ")": syntax error Jan 28, 2018 12:16:56.061 [0x7f276fbff700] ERROR - Soci Exception handled: sqlite3_statement_backend::prepare: near ")": syntax error for SQL: select distinct metadata_items.id as 'id', parents.id as 'parent_id', grandparents.id as 'grandparent_id', metadata_items.added_at as 'added_at', metadata_items.library_section_id as 'library_section_id', grandparents.extra_data as 'extra_data' from metadata_items join metadata_items as parents on metadata_items.parent_id = parents.id join metadata_items as grandparents on parents.parent_id = grandparents.id where metadata_items.library_section_id in (2) and ((metadata_items.metadata_type=4 or metadata_items.metadata_type=10) and ) order by metadata_items.added_at desc limit 400`

note the missing final `WHERE` clause before the `ORDER BY`…

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [January 28, 2018, 5:59pm UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/14 "2018-01-28T17:59:54Z")

</div>

yes commented on your other post

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [January 28, 2018, 6:01pm UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/15 "2018-01-28T18:01:00Z")

</div>

The issue is with the development team and relates to limitations / restrictions / labels for managed users. No further logs are needed

---

<div class="post-metadata">

### Author: ![sa2000](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/sa2000/32/6922_2.png) [@sa2000](https://forums.plex.tv/u/sa2000)
#### Post date: [February 7, 2018, 2:11pm UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/16 "2018-02-07T14:11:40Z")

</div>

A beta hot fix version of Plex Media Server has just been released - Plex Media Server 1.11.1.4768

See Release Notice

> **[Plex Media Server](http://forums.plex.tv/discussion/comment/1610465/#Comment_1610465)**
>
> Plex Media Server 1.11.1.4768 is now available to Plex Pass users in the Beta update channel FIXES: (Hubs) Recently Added TV hub failed to load for managed users with content restrictions. (#8123)

- (Hubs) Recently Added TV hub failed to load for managed users with content restrictions. (#8123)

---

<div class="post-metadata">

### Author: ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)
#### Post date: [January 8, 2020, 1:32am UTC](https://forums.plex.tv/t/unexpected-error-loading-the-dashboard/204008/17 "2020-01-08T01:32:49Z")

</div>


