# Updated DSM, Having Some Issues

**URL:** <https://forums.plex.tv/t/updated-dsm-having-some-issues/886934>\
**Category:** Plex Media Server\
**Tags:** server-synology\
**Created:** [August 31, 2024, 10:06pm UTC](https://forums.plex.tv/t/updated-dsm-having-some-issues/886934 "2024-08-31T22:06:41Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![ericalexander4](https://avatars.discourse-cdn.com/v4/letter/e/97f17d/32.png) [@ericalexander4](https://forums.plex.tv/u/ericalexander4)\
**Post date:** [August 31, 2024, 10:06pm UTC](https://forums.plex.tv/t/updated-dsm-having-some-issues/886934/1 "2024-08-31T22:06:41Z")

</div>

Plex Server Version#:1.29.2.6364-7000  
Synology Version#:7.1.1-42962

So, I updated my Synology to DSM 7, then updated Plex to the latest version, but now I have two listings of “SERVER” on my menu. One works, but I had to reinstall the libraries and lost all customizations, and the other one says “SERVER is currently unavailable”

I’d love to be able to repair the working installation so I have all the posters, collections, etc that I spent so much time personalizing.

I do see the option to simply REMOVE the non-working version.

I’ve attached my log files.  
[Plex Media Server Logs\_2024-08-31\_15-04-22.zip](https://forums.plex.tv/uploads/short-url/qzlUWPjhnlmgvhm1IEU07EpSzOs.zip) (5.0 MB)

---

<div class="post-metadata">

**Author:** ![tom80H](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/tom80h/32/19753_2.png) [@tom80H](https://forums.plex.tv/u/tom80H)\
**Post date:** [September 1, 2024, 12:45am UTC](https://forums.plex.tv/t/updated-dsm-having-some-issues/886934/2 "2024-09-01T00:45:35Z")

</div>

The upgrade to DSM 7 includes a number of severe changes to the platform by Synology. There’s a dedicated guide on how to upgrade/migrate an existing Plex Media Server setup after upgrading to DSM 7.

> [@Synology FAQ - Questions, Answers, and How-To's](https://forums.plex.tv/t/synology-faq-questions-answers-and-how-tos/490215/34):
>
> FAQ 27 - Migrating an existing PMS from DSM 6 to DSM 7 NOTICE: DSM 5 → [DSM 6] → DSM 7 First Step If you first started using Plex with DSM 5, then upgraded to DSM 6, because of a change internal to DSM 6, you will need to perform this step before you start the DSM 7 upgrade. If you never used DSM 5, or deleted the Plex share sometime during DSM 6, you can skip this step and continue with the normal upgrade steps Rename the existing Plex shared folder to Plex.old Create a new Pl…

---

<div class="post-metadata">

**Author:** ![FordGuy61](https://avatars.discourse-cdn.com/v4/letter/f/22d042/32.png) [@FordGuy61](https://forums.plex.tv/u/FordGuy61)\
**Post date:** [September 1, 2024, 1:27am UTC](https://forums.plex.tv/t/updated-dsm-having-some-issues/886934/3 "2024-09-01T01:27:09Z")

</div>

You updated from DSM 6 to DSM 7, correct?

Do you still have the `/Plex` shared folder?

Are the database files still in `/Plex/Library/Application Support/Plex Media Server/Plug-in Support/Databases`?

If yes to all three, see [Struggling with migration from DSM 6 to DSM7 - #2 by FordGuy61](https://forums.plex.tv/t/struggling-with-migration-from-dsm-6-to-dsm7/877423/2)

---

<div class="post-metadata">

**Author:** ![ericalexander4](https://avatars.discourse-cdn.com/v4/letter/e/97f17d/32.png) [@ericalexander4](https://forums.plex.tv/u/ericalexander4)\
**Post date:** [September 1, 2024, 4:43am UTC](https://forums.plex.tv/t/updated-dsm-having-some-issues/886934/4 "2024-09-01T04:43:21Z")

</div>

There are 13 .DB files in the databases files. 2 with todays date, and the rest with various dates from the past

---

<div class="post-metadata">

**Author:** ![FordGuy61](https://avatars.discourse-cdn.com/v4/letter/f/22d042/32.png) [@FordGuy61](https://forums.plex.tv/u/FordGuy61)\
**Post date:** [September 1, 2024, 5:14am UTC](https://forums.plex.tv/t/updated-dsm-having-some-issues/886934/5 "2024-09-01T05:14:03Z")

</div>

Completely read the post I linked.

After reading, follow the steps.

Pay attention to each step, especially when setting permissions is required.

Write back if you’ve any questions or something goes amiss.

---

<div class="post-metadata">

**Author:** ![ericalexander4](https://avatars.discourse-cdn.com/v4/letter/e/97f17d/32.png) [@ericalexander4](https://forums.plex.tv/u/ericalexander4)\
**Post date:** [September 1, 2024, 7:20pm UTC](https://forums.plex.tv/t/updated-dsm-having-some-issues/886934/6 "2024-09-01T19:20:50Z")

</div>

Hi, thanks for that detailed tutorial. I went through it and everything seemingly went exactly as you described. It did take awhile, but it finally finished and Plex is indeed installed. And there is only a migration file in the Plex folder. But…

When I run Plex, it only runs for about 20-25 seconds before stopping on it’s own. During that time, I can hear the server really churning away. Also, during that time, Plex won’t load in a browser using the IP address.

I zipped the logs and include them here.  
[Plex Media Server.1.zip](https://forums.plex.tv/uploads/short-url/gjBwUcvvv3zQzxYLrVOmKeYcvE1.zip) (148.4 KB)

---

<div class="post-metadata">

**Author:** ![FordGuy61](https://avatars.discourse-cdn.com/v4/letter/f/22d042/32.png) [@FordGuy61](https://forums.plex.tv/u/FordGuy61)\
**Post date:** [September 1, 2024, 8:07pm UTC](https://forums.plex.tv/t/updated-dsm-having-some-issues/886934/7 "2024-09-01T20:07:51Z")

</div>

Good: The migration worked.  
Bad: Synology won’t update the PMS version in Package Center and I did not ask which version you were running when on DSM 6.

Download and install the current public (1.40.5) or beta release (1.41.0) of Plex Media Server.

Based on the error messages in the log files, it looks like you were running a 1.40+ release prior to updating to DSM 7. Due to Plex database changes, it is not possible to go from 1.40 to releases earlier than 1.31.2.

PMS 1.29.2 sees the db changes as errors and then shuts down.

Installing a current release should resolve the problem.

You may see a “503 maintenance” message in Plex Web when PMS first start. If so, that is PMS performing database maintenance. Check back every 5 - 10 minutes to see if it has finished. You’ll need to refresh the web browser, the page does not auto-update. If the maintenance process is still running, do not interrupt it. It will just start over the next time you start PMS.

  

```auto
Sep 01, 2024 12:16:40.899 [0x7f12dd42f0d0] ERROR - SQLITE3:0x80000001, 1, near ">>": syntax error in "UPDATE tags SET extra_data = extra_data ->> 'url' WHERE extra_data IS NOT NULL and json_valid(extra_data)"
Sep 01, 2024 12:16:40.899 [0x7f12dd42f0d0] ERROR - Exception inside transaction (inside=1) (/data/jenkins/server/3537899744/Library/DatabaseMigrations.cpp:289): sqlite3_statement_backend::prepare: near ">>": syntax error for SQL: UPDATE tags SET extra_data = extra_data ->> 'url' WHERE extra_data IS NOT NULL and json_valid(extra_data)
Sep 01, 2024 12:16:40.903 [0x7f12dd42f0d0] ERROR - Exception thrown during migrations, aborting: sqlite3_statement_backend::prepare: near ">>": syntax error for SQL: UPDATE tags SET extra_data = extra_data ->> 'url' WHERE extra_data IS NOT NULL and json_valid(extra_data)

```

---

<div class="post-metadata">

**Author:** ![ericalexander4](https://avatars.discourse-cdn.com/v4/letter/e/97f17d/32.png) [@ericalexander4](https://forums.plex.tv/u/ericalexander4)\
**Post date:** [September 1, 2024, 8:41pm UTC](https://forums.plex.tv/t/updated-dsm-having-some-issues/886934/8 "2024-09-01T20:41:39Z")

</div>

You’re right about my Plex version. In fact, I had just upgraded it a few days before this and did see that 503 Maintenance error for a little while.

After a bit of a struggling determining which package to download, I have the new one installed and it’s all there! Thanks so much!

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [November 30, 2024, 8:42pm UTC](https://forums.plex.tv/t/updated-dsm-having-some-issues/886934/9 "2024-11-30T20:42:38Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
