v1.2.3 Will not exit full screen.

plex-media-player

#1

Bit of an odd issue here and only since I updated to 1.2.3 today...

When first I loaded PMP it loaded just like my previous version, windowed on my first monitor. I wanted to change some PMP settings so clicked the TV Full Screen button to get the TV interface with access to all the settings (still annoying these are not exposed in the windowed view). Changed the settings I wanted to, but now when I click the Exit Full Screen button I get the WebUI full screen on my monitor. Still showing the Exit full screen button so I click it again. Flicker but nothing changes except the button changing to Enter TV Full Screen.

I cannot get back to my original windowed view with the ability to move it around the screens wherever I want.

Have I broken something or is everyone else also seeing this?

Windows 10 fully updated (latest updates installed during bootup). AMD Radeon R7 200 graphics card with one monitor connected to DisplayPort and one to HDMI.

If you want further details please ask.


#2

It's a bug, we have an issue to track and remedy it.

In your case are you seeing it only on one monitor or both (if you've tried both).


#3

Can we get a PMP log while this is happening?


#4

@markus101 said:
It's a bug, we have an issue to track and remedy it.

In your case are you seeing it only on one monitor or both (if you've tried both).

I am only seeing PMP on one monitor.


#5

@vlang said:
Can we get a PMP log while this is happening?

Attached. Today I loaded PMP, clicked the button a few times then closed PMP. Hopefully that is enough for you.

If you need more please ask.


#6

@markus101 said:
It's a bug, we have an issue to track and remedy it.

In your case are you seeing it only on one monitor or both (if you've tried both).

Sorry to pester but there have been a few updates released for PMP since this bug was reported but none have fixed the issue. Are we giong to get back windowed mode any time soon?


#7

Sorry for not getting back to you earlier. I probably overlooked the thread on a busy day.

Is suspect the window position and size we load/store is somehow out of bounds, or causes Windows to place it in a way that covers the whole screen. This triggers one of our fullscreen hacks, that switch it back to fullscreen. That's what I can take from the log, I don't know how accurate it is.

Can you try deleting storage.json from the PMP config dir? (Delete or rename it while PMP is not running.) I'm fairly sure this should start PMP in windowed mode, but switching to fullscreen, restarting PMP etc. could trigger it again. If it happens again, reproduction steps and new logs would be appreciated.


#8

Thank you for the response. storage.json removed. PMP started. Starts in full screen mode. cycling through options does not move into windowed mode.
Logfile attached.

Is this possibly related to me having 2 monitors which are not the same size (and PMP running on the slightly smaller monitor? 1920x1200 and 1920x1080.

PS. don't worry about the slow response, I am sure you are also helping many other people! :)

PPS. Sorry also forgot to mention I am now on PMP 1.3.1


#9

Try deleting plexmediaplayer.conf too. This contains the fullscreen flag. I'd expect it to start windowed then, although going fullscreen and back is probably still broken for whatever reasons. I'm not able to reproduce any problems currently, btw.


#10

Thank you

Removing that file has solved the problem. PMP started windowed and now switching between the windowed and fullscreen modes works.

Having done a side by side of the config file I removed vs. the new one I notice that the setting "forceFSScreen": "\\\\.\\DISPLAY4", is in the old one. I assume this became set when I had moved to full screen but wanted PMP on the smaller monitor. That may be the cause of my issues?


#11

Yes, that definitely seems like a potential cause.