"Video Unavailable: Please check that this file exists and the necessary drive is mounted"



There are a few shows I have that Plex simply hates now. I just got a new laptop (I attached the specs) as my old one died of old age, so I was forced to download a new version of Plex. Things seem to be different. Bad different. I have been in the process of converting all of my shows to MP4 because suddenly, Plex won't play MKV files on the desktop. All of the shows I am going to mention are in MP4 format. Here's what's going on, I have all of the seasons of Married With Children. Most of the episodes of it that I try to play immediately give me a "Video Unavailable" message immediately after trying to play. Sometimes I can get the first episode of the first season to play, but most of the time it just thinks for a few minutes then says unavailable again. What's more, it Plex on the desktop won't attach any metadata to it anymore for some reason. I also have Batman: The Animated Series and none of the episodes of that show play at all. They immediately give me an unavailable message again. I even went as far as to download the entire series again from a different source, converted each episode to MP4, and still the same problem. And this one will only download about half of the metadata, even when I remove it from Plex, clear the trash, clear the bundles, and put it back in. One season has metadata for the first 10 episodes, including episode names, but after that it just goes "episode 11, episode 12" and so forth. What's more strange is that the last time I removed Batman: The Animated Series from my drive and moved it elsewhere, it wouldn't disappear from my library, it just got a tag saying "unavailable." I had to delete my entire TV show library and re-add it again to get rid of it. Trying to play from my :d drive instead of an external device makes no difference. Both of these play on Plex desktop, no problem since I converted them to MP4. These are the only 2 series' that I have been trying to fix as all the others I have that I have tried to play seem to work normally, and both of the shows I mentioned worked just fine when I was playing them from my old laptop which was a much older, more inferior laptop. This is very frustrating and I don't know what's wrong. Please help! I have attached the specs of everything I am using.


Sorry, forgot to attach pics. I should also mention I am currently running a 65mbps internet connection. This should not be a problem.