Virtual Machine Windows Host, Ubuntu Guest can't access windows shares in Plex Media Server ONLY

server-linux

#1

So I created a virtual machine using virtual box for plex and a few other media applications I use because I prefer them on linux. The shares seem to automount just fine from Virtual box and they mount to /media. I am able to terminal into that location and see all of the files in the share just fine. But when I add the share to the Plex media library, nothing shows up. It shows the folder but none of the contents are shown. The windows share is shared to everyone with full access and I have even chmod 777 the folder from within linux but still can't see the files in plex. Any ideas on what I am missing here?


#2

Sounds like you are doing everything right...

Can you save a file in Linux to the /media location and have it show up on the windows side?

Outside if Plex!


#3

@nicksmediaserver said:
The windows share is shared to everyone with full access and I have even chmod 777 the folder from within linux but still can't see the files in plex.

Please check the permissions of the individual files, not only of the directory. I bet, user "plex" is not allowed to read your media files at the moment.


#4

On Ubuntu, directory /media is reserved to the username signed in. It is possible to override this with explicit mounts in /etc/fstab but default linux security is invoked as well as Nautilus mounts with exclusive=username thereby precluding user plex from seeing anything.

If you mount your windows share anywhere else, setting directory permissions to 755 and files to 644, you will see it.


#5

@nicksmediaserver said:
So I created a virtual machine using virtual box for plex and a few other media applications I use because I prefer them on linux.

I’m thinking about doing the same may I ask how did this go for you? does plex run good, in regards to load times, transcoding, concurrent streams. I have a modest intel nuc 8gb ram i5 250gb ssd I figure I’ll split my resources 50/50 between windows and the Ubuntu vm. I’m trying to figure out if it will all run smoothly right now I run plex media server on my Windows pc and apps like couch potato and sickbeard on and old nas, the goal is to get rid of the nas cloud store my media and run pms, cp, and sb all on the virtual machine


#6

A common, and more efficient implementation architecture:

  1. Linux host
  2. Native PMS
  3. Other 'containerized' apps (SB / CP) in docker on the Linux host.

Think like a NAS, without the disks being attached. Same implementation strategy


#7

So I’ve gone with windows host and Linux as guest and I’ve chosen bridged network settings how ever for some reason it isn’t assigning my virtual pc a different IP address from host it’s giving it the same one. Can anyone tell me what to do to fix this I’d like to ssh into the vm but it won’t work until this ip issue is fixed

Edit : solved changed it in my router dhcp settings using the vms Mac address


#8

depending on how 'automount' is setup, they will be mounted with exclusive access to your username. /media is where Gnome/Nautilus uses and it always does this to everyone. This said, Linux won't let user plex see them.

If you make the mounts manually (out of Gnome/Nautilus control), PMS will be able to see them

A couple links for you from the Linux Tips section.

https://forums.plex.tv/discussion/278381/how-to-mount-media-from-your-nas-shares-on-linux-using-cifs-smb#latest
https://forums.plex.tv/discussion/278371/how-to-mount-media-from-your-nas-shares-on-linux-using-nfs#latest
https://forums.plex.tv/discussion/279063/using-ext-or-ntfs-drives-internal-or-external-on-linux#latest


#9

What ended up fixing this for me was editing /etc/fstab with the following.

name_of_share /path/to/mountpoint vboxsf 0 0

Where name_of_share is whatever share you named your windows shared folder.

This will automatically mount the share on the VM start up