VIZIO now not connecting to Plex- unsuccessfully followed other threads suggestions

smart-tv

#1

Plex server only connects with my Vizio tv app remotely. It shows thumbnails, but times out starting a movie. FireTv and Chromeweb remote and local all work well, its just the VIZIO.

in the vizio app, when i select the server name at top, it says "Remote". If i Disable remote, it cant find the server, which i believe means its not finding the local server on the same subnet.

VIZIO was working until i got a new router from my ISP. There is no DNS rebinding on the router. I swapped between their default DNS (the WAN/LAN gateway) and the google dns. When I use the link with my token I see 2 local addresses for my PMS, one current, and one with the old IP address from the previous router. My NAS/PMS are on the same subnet as the Vizio; plugged into the new router,

I have a synology DS515+NAS with only 1 ip interface, no virtual interfaces. It is on the same subnet as the router. The server is plugged directly into the router, as is the tv.

I have followed the common instructions in the forums, such as reinstalling (Intel32), logging in and out, removing the devices. I followed the instructions for looking up the connections via URL with token. I have 2 local devices, including the old (non existant) subnet. The forum said Vizio is opera, which has a problem with 2 local devices. I followed the guide to try and force a new network setup to the .tv server (with the tv powered off). I deleted the devices from the .tv server, but when the media server came back up, the old ip address was right there as local next to the legit new IP address. Something is keeping it. I followed instructions to completely wipe plex from my server. Telnetted in and rm-r 'd the plex directories and did a fresh install. Still the old "local" entry persists with the new token.

All these attempts explicitly following the instructions in the forums and FAQ (linked in their signature!)

Finally i wiped plex off the NAS again, including telnet & rm -r of the directories, logged out of plex.tv. I reinstalled and opened a new plex.tv account on a diff email. Connected them, and the OLD LOCAL ADDRESS CAME BACK! I used telnet and Netstat -a to watch the port open as soon as the package installed (before using the web client or linking the accounts, the 110 came back immediately on plex package install).

Please help, I don't know how its remembering. the old router isn't even here.


#2

I have a second local address, what has been a known issue with VIZIOs. will post token tool results
verified with ISP again, no Subnet segmenting, no DNS rebinding


#3

I have 2 local IPs in my media container, see commented excerpt below. This was a known issue with Vizio TVs. I have tried the methods in the forums of reinstalling servers, wiping data/USER from NAS, etc. but the 2nd old address keeps coming back.

How do i get rid of the second local address?

Device name=“Myname” product=“Plex Media Server” productVersion=“1.10.0.4523-648bc61d4” platform=“Linux” platformVersion=“3.10.102 (#15217 SMP Wed Dec 20 18:18:56 CST 2017)” device=“DiskStation” clientIdentifier="************************************" createdAt=“1515597667” lastSeenAt=“1515597668” provides=“server” owned=“1” accessToken=“xxxxxdeletedxxxxxx” publicAddress="*correct address^" httpsRequired=“0” synced=“0” relay=“0” publicAddressMatches=“1” presence=“1”>
***correct
****OLD, no longer used
/Device


#4

Synology saw the old interface still showing up, despite upgrading the OS. ifconfig revealed a second ip address that shouldnt have existed. They recommended a network reset (sticking a pin in a hole 4 secs). This fixed it. The vizio sees the plex server and remote access works (on the beta DSM OS 6.2.23511)
Its fixed! thanks for the help.
you’re welcome!