Vizio Plex App and DTS passthrough - any update?

smart-tv

#1

Vizio P702ui-B3 w/ Denon AVR-991
Vizio Sigma V1.3.34-UHD
Plex App 2.12.1
Plex Server 1.3.3.3148
running on
Synology DS1815+ (DSM 6.0.2-8451 Update 7)

Since forever, when playing a file with a DTS track, transcoding would kick off, a few minutes of the file would play, and then it would keep skipping and pausing, eventually with the message "The file failed to start" or similar. Turning off Direct Play and/or Direct Stream would sometimes help it play longer (~20 minutes before freezing, then stop/resume would re-start the playable time), but other times not help at all.

I noticed a recently added checkbox for DTS( DCA) in the audio section of the Vizio Plex App settings. Exciting! What I've gathered is that it's there to inform the server that the device is capable to passthrough (or process) DTS audio. With this selected now, if a DTS track is the ONLY audio track, no audio will play. If there is a secondary (commentary) audio track, it will pass that in whatever (non-DTS) format it is in, incorrectly identifying the playing track as the DTS audio. But transcoding is disabled, and it plays (without DTS audio) without any skipping or CPU overhead.

I take this to mean there's some progress, that the option is now enabled to inform the server? It's been a while since any activity in the old threads. I remain hopeful to find a DTS solution. Like others, I am able to connect a computer via HDMI, and using MPC, passthrough DTS to the TV, and through to the receiver via optical cable (ARC only passes DD5.1). But if I want to make sure a movie is wife-accessible, I must pre-transcode using the optimize function, since transcoding on the fly results in far too many freezes to be usable (it's not a transcoding hardware or network bottleneck, I'm informed that it's a combination of transcoder efficiency and vizio memory buffering that results in the massive failure).


#2

Same issue. Really frustrating that I see great comments all over the forums discussing these (obviously consistent) problems with absolutely no support.

I guess this settles the "plex pass" question for me


#3

Doesn't work on newer Vizio's with Smartcast. Other apps can cast DTS... come on Plex, seriously.


#4

Can play DTS audio from other apps just fine, but Plex is still no go. It does exactly as Burrit described. So many of my movies are DTS encoded (BluRay) and it's beyond frustrating that I can't direct play the source audio unless I plug my computer into the TV via HDMI.


#5

Yes Tree0wl, unfortunately even after months (years!) this has not been fixed. Like you, I have to plug my computer directly into the TV for any DTS/BluRay movies. Basically defeats the whole purpose of even using Plex.


#6

Same issue here on a Vizio M60-C3. Does Plex Support know about this? Is there somewhere we can report this as a bug other than in the forums?


#7

having the same exact issue. on the M60-C3. I do not have any other device that would play DTS audio, but is it just over the optical cable? Will it passthrough DTS over HDMI?


#8

Same issue still here. Vizio P75-C1, Vudu passes through ARC to my Denon AVR just fine, but Plex will not. I have my setup 90% there, 4K HDR works via smartcast PLEX, but now I am just missing Atmos/DTS-X pass through.


#9

@MI95SHO said:
Same issue still here. Vizio P75-C1, Vudu passes through ARC to my Denon AVR just fine, but Plex will not. I have my setup 90% there, 4K HDR works via smartcast PLEX, but now I am just missing Atmos/DTS-X pass through.

How'd you get 4k HDR working through smartcast??