# WARN - \[CERT\] TLS connection

**URL:** <https://forums.plex.tv/t/warn-cert-tls-connection/915433>\
**Category:** Plex Media Server\
**Tags:** server-linux\
**Created:** [April 29, 2025, 5:18pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433 "2025-04-29T17:18:59Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![NCBluesman](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ncbluesman/32/334897_2.png) [@NCBluesman](https://forums.plex.tv/u/NCBluesman)\
**Post date:** [April 29, 2025, 5:18pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/1 "2025-04-29T17:18:59Z")

</div>

Server Version#: 1.41.6.9685  
Player Version#: 4.145.1

Apr 29, 2025 14:38:10.814 [137554877238072] WARN - [CERT] TLS connection from 192.168.86.22:42678 came in with unrecognized plex.direct SNI name ‘172-18-0-1.82197d95bb6b4ee79f7bcabf247b1aad.plex.direct’; using installed plex.direct cert  
Apr 29, 2025 14:38:10.819 [137554879347512] DEBUG - CERT: incomplete TLS handshake from 192.168.86.22:46474: sslv3 alert bad certificate (SSL routines)  
Apr 29, 2025 14:38:10.820 [137554877238072] DEBUG - CERT: incomplete TLS handshake from 192.168.86.22:42678: sslv3 alert bad certificate (SSL routines)  
Apr 29, 2025 14:38:10.823 [137554877238072] WARN - [CERT] TLS connection from 192.168.86.22:34224 came in with unrecognized plex.direct SNI name ‘172-17-0-1.82197d95bb6b4ee79f7bcabf247b1aad.plex.direct’; using installed plex.direct cert

I’m running Plex in a docker container on Ubuntu 24.04.2 LTS. Remote access reports that it’s accessible but none of my friends are able to access my server. @ChuckPa, it seems you’ve reset certs for other users. Would you please reset mine? Please let me know if you need any additional information from me.

Thank you!

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 29, 2025, 7:37pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/2 "2025-04-29T19:37:01Z")

</div>

Unrecognized SNI name is an indication the player (client) is still using the old certificate or no certificate.

Looking at your account, I see three server names:

1. Ph\*\*\*\*\*\*\*\*\* – had its certicate updated yesterday
2. Z\*\*\*\*\*\*\*\* - hasn’t been seen in about 5 years
3. Kra\*\*\*\*\* - was created 2 days ago but has no certificate

Which are you referring to?

---

<div class="post-metadata">

**Author:** ![NCBluesman](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ncbluesman/32/334897_2.png) [@NCBluesman](https://forums.plex.tv/u/NCBluesman)\
**Post date:** [April 29, 2025, 8:01pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/3 "2025-04-29T20:01:30Z")

</div>

The server beginning with Kra, please.

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 29, 2025, 8:32pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/4 "2025-04-29T20:32:39Z")

</div>

Different server images have different internal structures.

Using the `plexinc/docker` image structure as my reference,

Can you get to the underlying filesystem where `/config/Library/Application Support/Plex Media Server/Cache` is?

If so, in there, you will find `cert-v2.p12`

If you see it then do the following:

1. Delete `cert-v2.p12`
2. Restart the container
3. After the server restarts, watch for a new certificate to be installed there.

If you don’t have or get a certificate, please let me know

---

<div class="post-metadata">

**Author:** ![NCBluesman](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ncbluesman/32/334897_2.png) [@NCBluesman](https://forums.plex.tv/u/NCBluesman)\
**Post date:** [April 29, 2025, 8:42pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/5 "2025-04-29T20:42:00Z")

</div>

That did it! Thank you so much!

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 29, 2025, 8:43pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/6 "2025-04-29T20:43:11Z")

</div>

Now go back to the players and restart them so they can also update the certificate for your server.

---

<div class="post-metadata">

**Author:** ![NCBluesman](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ncbluesman/32/334897_2.png) [@NCBluesman](https://forums.plex.tv/u/NCBluesman)\
**Post date:** [May 29, 2025, 3:43pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/7 "2025-05-29T15:43:06Z")

</div>

Hey ChuckPa,  
Sorry to trouble you with this yet again, but my server cannot be seen by any devices. It says the server cannot be connected securely. I did an update and now see there are two “kraken” servers. Not sure how this happened. I updated ubuntu, then updated the nvidia drivers and updated the docker container.

Please advise. Thank you.  
Philip

---

<div class="post-metadata">

**Author:** ![NCBluesman](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ncbluesman/32/334897_2.png) [@NCBluesman](https://forums.plex.tv/u/NCBluesman)\
**Post date:** [May 29, 2025, 3:59pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/8 "2025-05-29T15:59:41Z")

</div>

Actually, it looks like I somehow created a new kraken server. When I open up on Plex Web, I can go to “More -\>” at the bottom of the navigation panel and see my “new” kraken server.

Unfortunately, all devices are pointing to the OLD kraken server.

How do I fix this?  
What should I read to avoid causing this problem again?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [May 29, 2025, 4:06pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/9 "2025-05-29T16:06:35Z")

</div>

@NCBluesman

Ummmmmmm. 🤦‍♂️

You have `Kraken` and `kraken`.

Both server instances look live

Oops ?

---

<div class="post-metadata">

**Author:** ![NCBluesman](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/ncbluesman/32/334897_2.png) [@NCBluesman](https://forums.plex.tv/u/NCBluesman)\
**Post date:** [May 29, 2025, 4:16pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/10 "2025-05-29T16:16:42Z")

</div>

Yep, Oops! I figured it out. Thank you so much!

---

<div class="post-metadata">

**Author:** ![jber790](https://avatars.discourse-cdn.com/v4/letter/j/e36b37/32.png) [@jber790](https://forums.plex.tv/u/jber790)\
**Post date:** [July 24, 2025, 3:58pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/11 "2025-07-24T15:58:17Z")

</div>

@ChuckPa - I am experiencing the same error on my Plex Media Server (Ubuntu) with the following showing in the Plex Media Server.log:

Server Version#: 1.41.9.9961-46083195d

Error during startup:  
Jul 24, 2025 08:37:57.519 [281473437065440] DEBUG - CERT: incomplete TLS handshake from [::ffff:192.168.5.99]:56928: no suitable signature algorithm (SSL routines)

192.168.5.99 is the media server IP

I am running Plex on a Ubuntu LTS server (raspberry Pi) and am using a custom domain certificate for the server domain name. I tried removing the  
/Library/Application Support/Plex Media Server/Cache  
cert-v2.p12 file and restarting but it was not downloaded after restart.

Thank you!  
J

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [July 24, 2025, 4:52pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/12 "2025-07-24T16:52:45Z")

</div>

@jber790

I am looking at Plex.tv.

I see two Pi server instances (same machine).

One is deleted and one is active.

Would you be adverse to me removing both servers,  
your removing Preferences.xml,  
Reclaiming the machine again (where it will get a new cert) ?

If so, all we need do is coordinate our steps.

Let me know what you’d like to do.  
I’ll do it, then you can take over and reclaim the server (which will find all your existing media & libraries).

---

<div class="post-metadata">

**Author:** ![jber790](https://avatars.discourse-cdn.com/v4/letter/j/e36b37/32.png) [@jber790](https://forums.plex.tv/u/jber790)\
**Post date:** [July 24, 2025, 7:10pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/13 "2025-07-24T19:10:08Z")

</div>

Hi @ChuckPa - that sounds good, please proceed with removing both servers. Can I keep the same named server once you remove them and I delete my Preferences.xml? Any idea why the cert. failed to download - is there an issue with my domain cert. I am referencing in Preferences.xml?

Thank you - please let me know when I can delete/move out Preferences.xml.

J

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [July 24, 2025, 7:53pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/14 "2025-07-24T19:53:10Z")

</div>

@jber790

Both servers are removed from all lists.

Delete Preferences.xml and claim as if new.

It will run you through the startup wizard.

It will also show you the existing media sections it finds in the DB (accept as is)  
Look at and set other prefs as you go through the wizard.

When you finish, arriving at the Dashboard, Open Settings - Server and make the rermaining tweaks you previously had.

---

<div class="post-metadata">

**Author:** ![jber790](https://avatars.discourse-cdn.com/v4/letter/j/e36b37/32.png) [@jber790](https://forums.plex.tv/u/jber790)\
**Post date:** [July 24, 2025, 8:05pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/15 "2025-07-24T20:05:41Z")

</div>

Hi @ChuckPa - thank you, that process worked and I have restored my original PlexMedia server setup with my libraries etc. Any idea what would have caused the original cert-v2.p12 to not download and or the reason for the error message I posted earlier observed in the Plex Media [Server log](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) file on startup?

Thanks!  
JB

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [July 24, 2025, 8:08pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/16 "2025-07-24T20:08:30Z")

</div>

Your internet connection was tired? on lunch break perhaps? 🤷‍♂️

It does happen but so extremely rarely.

The only time I’ve seen it happen is when permissions get corrupted and, even though the certificate downloads, PMS can’t write the cert to the disk (perms error).

This usually happens on Linux and Synology boxes where PMS runs with no elevated privs

---

<div class="post-metadata">

**Author:** ![jber790](https://avatars.discourse-cdn.com/v4/letter/j/e36b37/32.png) [@jber790](https://forums.plex.tv/u/jber790)\
**Post date:** [July 24, 2025, 8:52pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/17 "2025-07-24T20:52:47Z")

</div>

Hi ChuckPa - there appears to be something else going on as when I try to configure Remote Access (enabling it and also specifying the port I am forwarding to PMS), I am getting the following error:  
Jul 24, 2025 13:45:10.445 [281473203138784] INFO - Completed: [192.168.5.1:53132] 200 PUT /:/prefs?PublishServerOnPlexOnlineKey=true (4 live) #9e GZIP 8ms 322 bytes (pipelined: 4)  
Jul 24, 2025 13:45:10.457 [281473176506592] WARN - [HttpClient/HCl#49] HTTP error requesting GET [https://v4.plex.tv/pms/:/ip](https://v4.plex.tv/pms/:/ip) (6, Couldn’t resolve host name) (Could not resolve host: v4.plex.tv)  
Jul 24, 2025 13:45:10.457 [281473145876704] ERROR - [Req#9e] PublicAddressManager: Unable to get public IP adddress from myPlex (httpCode=-6):  
Jul 24, 2025 13:45:10.459 [281473145876704] DEBUG - [Req#9e] MyPlex: Updating device connections (from timer: 0)  
Jul 24, 2025 13:45:10.459 [281473145876704] ERROR - [Req#9e] [HttpHeader] invalid ‘X-Plex-Device’ header value (Raspberry Pi 4 Model B Rev 1.4)  
Jul 24, 2025 13:45:10.459 [281473145876704] DEBUG - [Req#9e/HCl#4a] HTTP requesting PUT [https://plex.tv/devices/fa2efd6534b13fe1d986a1925c205b9fafb846fb?Connection[][uri]=http://192.168.5.99:32400&httpsEnabled=1&httpsRequired=0&dnsRebindingProtection=1&natLoopbackSupported=0&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx](https://plex.tv/devices/fa2efd6534b13fe1d986a1925c205b9fafb846fb?Connection%5B%5D%5Buri%5D=http://192.168.5.99:32400&httpsEnabled=1&httpsRequired=0&dnsRebindingProtection=1&natLoopbackSupported=0&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx)  
Jul 24, 2025 13:45:10.469 [281473176506592] WARN - [HttpClient/HCl#4a] HTTP error requesting PUT [https://plex.tv/devices/fa2efd6534b13fe1d986a1925c205b9fafb846fb?Connection[][uri]=http://192.168.5.99:32400&httpsEnabled=1&httpsRequired=0&dnsRebindingProtection=1&natLoopbackSupported=0&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx](https://plex.tv/devices/fa2efd6534b13fe1d986a1925c205b9fafb846fb?Connection%5B%5D%5Buri%5D=http://192.168.5.99:32400&httpsEnabled=1&httpsRequired=0&dnsRebindingProtection=1&natLoopbackSupported=0&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx) (6, Couldn’t resolve host name) (Could not resolve host: plex.tv)  
Jul 24, 2025 13:45:10.469 [281473145876704] WARN - [Req#9e] MyPlex: Updating device connections failed, retrying in 10 seconds.

The Remote Access screen in the Admin. is just “spinning” unable to save any changes (enabling remote access and the port to access).

NOTE: All other actions via the PMS web server are still accessible and media server is still found.  
Thank you.

J

---

<div class="post-metadata">

**Author:** ![jber790](https://avatars.discourse-cdn.com/v4/letter/j/e36b37/32.png) [@jber790](https://forums.plex.tv/u/jber790)\
**Post date:** [July 24, 2025, 9:32pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/18 "2025-07-24T21:32:03Z")

</div>

> [@jber790](#):
>
> Jul 24, 2025 13:45:10.457 [281473176506592] WARN - [HttpClient/HCl#49] HTTP error requesting GET [https://v4.plex.tv/pms/:/ip](https://v4.plex.tv/pms/:/ip)

I also confirmed that my Plex Media Server is able to resolve [https://v4.plex.tv/pms/:/ip](https://v4.plex.tv/pms/:/ip) from the command line (using curl which returned my WAN IP) so not sure why this error is occurring and or if this is the reason I am unable to configure Remote Access.

J

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [July 24, 2025, 10:23pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/19 "2025-07-24T22:23:01Z")

</div>

On the PMs host, you can type:

> curl [https://v4.plex.tv/pms/:/ip](https://v4.plex.tv/pms/:/ip)

and it will return your IP

I just saw some silliness with Plex.tv (HTTP 502). It’s resolved now.  
Can you try again and let me know the above ?

---

<div class="post-metadata">

**Author:** ![jber790](https://avatars.discourse-cdn.com/v4/letter/j/e36b37/32.png) [@jber790](https://forums.plex.tv/u/jber790)\
**Post date:** [July 24, 2025, 11:07pm UTC](https://forums.plex.tv/t/warn-cert-tls-connection/915433/20 "2025-07-24T23:07:13Z")

</div>

> [@ChuckPa](#):
>
> curl [https://v4.plex.tv/pms/:/ip](https://v4.plex.tv/pms/:/ip)

Hi - I tried that command again from the PMS:

> >

sudo curl -v [https://v4.plex.tv/pms/:/ip](https://v4.plex.tv/pms/:/ip)

- Host v4.plex.tv:443 was resolved.
- IPv6: (none)
- IPv4: 54.72.14.50, 52.16.248.152
- Trying 54.72.14.50:443…

> >

Just hangs.

Thanks!

J

[Next page](https://forums.plex.tv/t/warn-cert-tls-connection/915433.md?page=2)
