Watch Later Not Working on Any Platform

watch-later

#1

Server Version 1.9.7.4460

I typically add items to my watch later list by sharing it from YouTube on my phone to the Plex app, which adds it to watch later, but the Plex It! bookmarklet/chrome add on is also not working.

When accessing from Android app via watch later it says "The file associated with this item is not accessible by the server."

When accessing via web player watch later it says "An error occurred trying to play VIDEO TITLE HERE".

Using latest PMP program on Windows machine on the network also shows an error.

Nothing is working via watch later, this is a feature I use daily and have come to rely on - so having it not work is extremely troublesome.
I've searched and looked at other threads but am seeing very mixed results and links to very old threads saying 1.9.3 fixed this issue, but clearly not. I was on latest stable release where it was broken and upgraded to the latest beta as well where it's still not working.

Is any work being done to fix this, or any fixes we can apply?


#2

Same issue here.

Watch Later is the most precarious feature I’ve seen lately in tech. Sometimes it works. . .most times it does not.


#3

I use the Plex It in fireforx for watch it later youtube and it works for me:

Works on Web Android Mobile and on Samsung TV client.

Same version as you


#4

Can you check to see if you’re on a recent server version? I’m wondering if
something happened with a recent update.

It’s been not working for me for about a week now. I can still use the
unofficial “YouTube TV” channel and that works, but the I specially add
watch later items to things im not subscribed to. And the watch later
playlist takes forever to update in the YouTube TV app.

Sent from my phone.


#5

I am on FF 56.0.2 (64-bit) and PMS 1.9.7.4460 which I think is same version as you mentioned.
Ive used this for a while mainly kids junk on youtube and its been working for months.


#6

Sorry nokdim, I was replying from mobile via email so I didn’t see your images at first.

I can add items just fine to watch later, that part works ok, but when I go into watch later they just straight up don’t play for some reason.


#7

PMS Version 1.9.7.4460 fixed it for me.


#8

@markwilliams said:
PMS Version 1.9.7.4460 fixed it for me.

Weird, that’s what I’m on too but no luck on my side.


#9

So I ran all available Windows Updates and rebooted and now it’s working correctly.

This was the set of updates available for anyone wondering if they stumble on thi in the future.


#10

Welp. 1.10.0.4523 broke it again for me.


#11

@markwilliams said:
Welp. 1.10.0.4523 broke it again for me.

YouTube Watch Later still working fine for me on PMS 1.10.1.4602 (Mac OSX and Ubuntu Linux).


#12

Is something else going on again?

None of my Watch it Later videos are working (including ones that worked in the past). This is trying directly from plex on my desktop.
All of the videos are from youtube if that means anything.
But overall, lately the feature has been very flakey both with adding video using Plex IT bookmarklet and playing the videos later.

Plexweb 3.3.1 (windows7)
PlexServer 1.11.0.4666


#13

I find watch later added several months ago play. Thosed added in the last two or three months do not.


#14

Watch later works for me but it keeps asking me to sign in every time I restart my browser. It only remembers the current browsing session(chrome). My browser is set to remember and not delete cookies at exit, but only plex it seems to forget it. Every other site remembers log in information except plex it.