Watch Later still not working ...

watch-later

#1

Ever since your last update, Watch Later does not work on my Rokus. When I try to play one of the videos (mostly YouTube) it will load to about 13%, go blank for a second, and then return to the 13% loading spinner. It works fine through my PC (server). Is this going to be fixed?


#2

tell me about it, it's like they do not care about that feature anymore


#3

I'm glad to hear I'm not the only one. This is a major problem for me. I hope this is fixed soon.


#4

Yep its been a problem for about a month now. Sleeping at the wheel.


#5

@rckmnr said:
Ever since your last update, Watch Later does not work on my Rokus. When I try to play one of the videos (mostly YouTube) it will load to about 13%, go blank for a second, and then return to the 13% loading spinner. It works fine through my PC (server). Is this going to be fixed?

If it works on your PC but not on Roku, please report it in the Roku forum section, there's not much we can do about this from the Watch Later service side.


#6

This answer is absurd. The Rokus worked fine until your last update. The problem resides in PMS. I see plenty of people who have this exact same problem.


#7

@rckmnr said:
This answer is absurd. The Rokus worked fine until your last update. The problem resides in PMS. I see plenty of people who have this exact same problem.

Perhaps changes were made in Plex Server, and the Roku client needs to be updated. It might not be a flaw in the server causing the issue.


#8

@kegobeer-plex said:
Perhaps changes were made in Plex Server, and the Roku client needs to be updated. It might not be a flaw in the server causing the issue.

This is true but until someone says what they changed (I didnt see anything in the patch notes) then its a server side regression.


#9

Plex responded to me on facebook saying they are aware of the issue and looking at it. But its been over a month of this playback issue.


#10

The Roku must transcode some YouTube videos due to changes the YouTube website made a while back. This is a Roku software issue that has been reported to them.

I was having issues with PMS v1.5 for Windows properly transcoding YouTube videos, but I can say that the transcoding issues are resolved for me with PMS v1.5.6 for Windows. ~~I have not tried the later Plex Pass versions.~~

EDIT:

The transcoding issue that was occurring with YouTube Watch Later videos on PMS for Windows is fixed in PMS v1.5.6 for Windows and later. I know this because these videos now work on the Plex app for Roku which must transcode some YouTube videos. I can also confirm this is the case with PMS v1.6.1.

But the Plex Web app (tried v3.2.1, v3.4.1 and 3.6) is still unable to play YouTube videos. Plex Web does not fail it just sits there loading forever.


#11

Since this appears to be a Plex Web app issue (at least for me), I have started a thread in the Plex Web app section of the forum at forums.plex.tv/discussion/272005/unable-to-play-watch-later-youtube-videos-on-plex-web


#12

I am getting the same issue with Watch later not working in Chrome. I have tried IE and that works but not Chrome. So far I have tested the following:

  • Chrome (Doesn't work)
  • Internet Explorer (Works)
  • Plex Windows App (Works)
  • Android (Works)
  • iOS (Works)

Not sure where the issue is with Chrome but it is for sure the browser that won't play the videos in the Watch Later playlist.

Question

Does anyone know if there is a way to send an email to Plex and have their development team take a look at the issue? I know it is a small thing but it would be nice to have this working.


#13

Same here with the latest version of Chrome on a Chromebook - playing videos from Youtube via Watch Later just sit with a spinning circle like it's trying to buffer them.


#14

Not working in plexweb for me. I have android tv(nexus player) and it works there. This issue was reported I think back in march and now its nearing july with no answer. Its like the plex devs don't use this feature at all.


#15

@donyzz said:
Not working in plexweb for me. I have android tv(nexus player) and it works there. This issue was reported I think back in march and now its nearing july with no answer. Its like the plex devs don't use this feature at all.

As you see it working on some clients, this is an indication that it's not the "Watch Later" part of the service that is broken, but that there is something broken in specific Plex clients. I'm aware of the issue, but I can't fix this on my end (I'm not a client dev). Please post about this issue in the part of the forums for that specific client and let's all hope that the devs over there will finally have a look at the issue.


#16

@sander1 said:

@donyzz said:
Not working in plexweb for me. I have android tv(nexus player) and it works there. This issue was reported I think back in march and now its nearing july with no answer. Its like the plex devs don't use this feature at all.

As you see it working on some clients, this is an indication that it's not the "Watch Later" part of the service that is broken, but that there is something broken in specific Plex clients. I'm aware of the issue, but I can't fix this on my end (I'm not a client dev). Please post about this issue in the part of the forums for that specific client and let's all hope that the devs over there will finally have a look at the issue.

Its been reported already and even a Plex employee has acknowledge it. The problem is two months have gone by without a solution.

https://forums.plex.tv/discussion/272683/unable-to-play-watch-later-youtube-videos-on-plex-web-in-chrome


#17

@sander1 Can you please direct us to the part of the forum that deals with the WebClient running on Chrome?

I had a thread in "General Discussions (Plex Pass)"...
https://forums.plex.tv/discussion/265683/watch-later-queue-broken#latest

This was closed by @shopgirl284 and re opened in "Plex Web App"
https://forums.plex.tv/discussion/272005/unable-to-play-watch-later-youtube-videos-on-plex-web
In this thread @shopgirl284 said that "It appears there is an issue with the Plex Web app sending the POST request necessary to get the video stream."
@chrishoage replied to this saying "We are aware of the issue, I have opened a ticket on the Plex Media Server repo a while ago as there is no reason client side this shouldn't work."

Which lead to the creation of a thread in the "Windows" forum that gets no official response...
https://forums.plex.tv/discussion/272683/unable-to-play-watch-later-youtube-videos-on-plex-web-in-chrome#latest

Thanks

Lee


#18

-Same problem as some others. I cannot view plexit videos from youtube on my desktop web server. However, I can view them from my android. Please fix. Thank you :smiley:


#19

As stated in the other post about this issue, this issue is posted in the Plex Web app section of the forum since it is an issue that only affects the Plex Web app.

The latest updates on the issue are at forums.plex.tv/discussion/272005/unable-to-play-watch-later-youtube-videos-on-plex-web


#20

This issue is still around (the roku one in the original post).