Why all of a sudden, do I have to sign in, to add to MyPlex, with Plex It?

watch-later

#1

I've been using Plex and MyPlex, for a couple years now, on my Roku 2 XS, and it worked well. But suddenly a few days ago, clicking on Plex It on the toolbar, brings up this message: 

You need to sign in first Try again

Sign in first? WHERE? You click on 'sign in', a page asking you to verify your ID, comes up, and after you do, it brings you to your MyPlex page of listings. I have signed in, in several different locations, not knowing just WHERE the stupid error message wants me to sign in. I thought maybe I needed to see if I could update Plex Media Server, but it shows 0.9.7.28, is the newest version and I have it. Is this to get me to BUY a Plex Pass? If so, why not simply say that? I'm confused over this, and hope someone can help me.


#2

I am getting the same issue after trying the new plexit bookmark.  Keep asking me to sign in even though I have already signed in numerous times previously


#3

Thanks for your reply. I figured it had something to do with the software of Plex, that something in it, now causes this error to show itself. At least your reply tells me it's NOT JUST ME, but I hope a fix arrives soon. hanks again.


#4

do you guys have cookies enabled in whatever browser you're using?


#5

Yes. I do, because cookies ID who we are to sites we want to use.


#6

I'm having the same problem! I've just about STOPPED using MyPlex because of it. I have stopped recommending Plex, MyPlex, etc. because of it. The only way I can get it to work is to go to the MyPlex page and physically sign in and then I have to leave that tab open! It won't work if I am signed into my page but the page isn't physically open. BIG PITA! Way too much hassle. Just when I was trying to figure out how to come up with money for a lifetime subscription too. Now? Forget about it. I'm not paying for crap service that's for sure.


#7

I am having the same issue in chrome on my mac.   The bookmarklet works fine in Safari, but I don't normally use Safari.   I tried clearing my cache and deleting all of my plex cookies.


#8

made some progress.   If you have block third party cookies enabled in chrome it breaks the plugin and does the request for sign in.  If you uncheck the block third party cookies, you can log in and it works great.      Is there an exception that can be added to allow a specific third party cookie?


#9

To the member who suggested unblocking third-party cookies in our Chrome settings, resolved this irritation, by simply unchecking that option. My PLEX IT, now adds what I want, to MyPlex, so I can start using it again. I never had this trouble before, but it seems to be caused by an update to my Plex Media Server, that caused this to start up. If so, it would benefit Plex, to make a patch, and correct it. I too, nearly dumped all the Plex content, off my pc. I just could not find an answer to it, and I certainly signed in as many places as I could find, for Plex. Now, I thank the member who suggested removing the block on third-party cookies, in Chrome. It also caused the same trouble for me, inside Firefox, but I didn't try it in Safari, so that may have worked. Anyway, this removes one pest, in my every day life. Thank you again, four solving my problem.


#10

in response to the newly released Plexit bookmarklet. 

The new "fling" feature to ROKU that would be most useful to me I can't get to work. "unable to play video". I it's new so I can wait on bug fixes. The add to queue seems to work fine however. 

So I tried the email link feature. It appears that the video links that I send are showing up in https://my.plexapp.com/queue yet nothing in my PMS GUI or the ROKU. Seems weird to me. 

Ideas? Thanks!!


#11

Blast.  I've been having this problem for about a week too with the Plex It not working.  

Says "sign in", but I am signed in.  

I don't want to allow third party cookies!  Is there a way to fix it by adding an exception?  


#12

I don't want to allow third party cookies!  Is there a way to fix it by adding an exception?  

Yes, in Chrome you can add an exception for my.plexapp.com and it'll work fine.


#13

Yes, in Chrome you can add an exception for my.plexapp.com and it'll work fine.

Thank you very much.  I knew you could do it, I didn't know what to add specifically.  Works great!  


#14

I have this issue across Safari, Chrome on two Macs.  I also have it recurrently on multiple iOS devices with bookmarklet. I've made zero changes (in my browser or otherwise) between when things worked great (it retained login and never asked me) and when it started asking me across all my devices.

Did Plex change the amount of cookies/sessions that can be open at once? I use the bookmarklet from two iPads, iPhone and multiple Macs. That was my suspicion initially anyway.

Any data I can give you guys to help troubleshoot this? 


#15

I followed recommendations above for both Firefox and Chrome.  It still blocks me from using "Plex it" with the "sign in first" (even though I'm signed in) error.

In my case it having thrid party cookies allowed and adding an exception etc. simply does not make any difference.  It's just broken!

I tried to use Plex It in Chrome; same problem, won't work no matter what I do to settings.

I installed Safari browser and Plex It worked immediately with no fuss.

I uninstalled the latest version of Plex Media Server, went back two version to when it was working.  That did not work either.  Old versions no longer Plex It either.

This is strange!


#16

Yes, in Chrome you can add an exception for my.plexapp.com and it'll work fine.

I did this several month ago when I had the same problem and it worked. 

However a couple of weeks ago I started to get the same old "you must sign in" error.  Only I am signed in.

And I still have the my.plexapp.com exception in Chrome, but it still doesn't work unless I unblock third party cookies!  

I have done this a few times, just quickly to get an important video into my queue, and it works like always if I have block cookies unchecked, but I definitely don't want to leave third party cookies unblocked all the time.  

Is this going to be fixed?  Is there another work around?  


#17

Try adding an exception for plex.tv. my.plexapp.com has transitioned to plex.tv, so that's where the exception will need to be now.


#18

Thanks so much. I was losing my mind going in and turning cookies off and on.  

Now all is right with the world again!  :)


#19

Tried adding plex.tv to the exception list and it did nothing. If I sign in during a browsing session it remembers, but when I exit the browser(chrome) its asking me to sign in again. I want to sign in once and not worry about it until I clear my cookies. I've used plex it for years and never ran into this problem of having to sign in every time.


#20

@donyzz said:
If I sign in during a browsing session it remembers, but when I exit the browser(chrome) its asking me to sign in again.

Sounds more like a browser issue (maybe a setting, a privacy addon that deletes cookies when closing your browser or third party software) than a PlexIt! issue.