Why are all my plugins crashing when trying to get "hosted resource hashes"?


I noticed that my previously installed Plugins were not showing up in the Plex gui. Since I want those working, I went and tried to look into it. I tried removing the .bundle folders, and readding them, but that didn't seem to work. I even went so far as reinstalling PMS after clearing the Appdata folder and cleaning my register (the cleanest uninstall I know of). None of the .bundle files seem to work, even after that.

Any one seen this? Solved this? Thought on what I can try?

Server Version:
Plugins: WebTools, Trakt, Sub-Zero

2018-05-16 06:21:23,703 (850) : DEBUG (networking:166) - Requesting ''
2018-05-16 06:21:33,704 (850) : CRITICAL (core:574) - Exception getting hosted resource hashes (most recent call last):
File "D:\ProgramFiles\Plex\Resources\Plug-ins-b4605f76e\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\runtime.py", line 1293, in get_resource_hashes
json = self._core.networking.http_request("", timeout=10).content
File "D:\ProgramFiles\Plex\Resources\Plug-ins-b4605f76e\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components
etworking.py", line 265, in content
return self.__str__()
File "D:\ProgramFiles\Plex\Resources\Plug-ins-b4605f76e\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components
etworking.py", line 243, in __str__
File "D:\ProgramFiles\Plex\Resources\Plug-ins-b4605f76e\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components
etworking.py", line 181, in load
f = self._opener.open(req, timeout=self._timeout)
File "D:\ProgramFiles\Plex\python27.zip\urllib2.py", line 429, in open
response = self._open(req, data)
File "D:\ProgramFiles\Plex\python27.zip\urllib2.py", line 447, in _open
'_open', req)
File "D:\ProgramFiles\Plex\python27.zip\urllib2.py", line 407, in _call_chain
result = func(*args)
File "D:\ProgramFiles\Plex\python27.zip\urllib2.py", line 1228, in http_open
return self.do_open(httplib.HTTPConnection, req)
File "D:\ProgramFiles\Plex\python27.zip\urllib2.py", line 1201, in do_open
r = h.getresponse(buffering=True)
File "D:\ProgramFiles\Plex\python27.zip\httplib.py", line 1136, in getresponse
File "D:\ProgramFiles\Plex\python27.zip\httplib.py", line 453, in begin
version, status, reason = self._read_status()
File "D:\ProgramFiles\Plex\python27.zip\httplib.py", line 409, in _read_status
line = self.fp.readline(_MAXLINE + 1)
File "D:\ProgramFiles\Plex\python27.zip\socket.py", line 480, in readline
data = self._sock.recv(self._rbufsize)
timeout: timed out


This is not a plugin issue, but a server issue.

Suggest you post in the relevant PMS forum, and add logs in debug mode
Also, since this is a timeout issue, before posting, optimize your database, and reproduce


Sadly it seems far beyond a simple database optimize at this point. PMS isn’t even able to run anymore. No idea what’s happened