Why can I create a Plex basic music library, but can't create a premium music library?

server-synology

#1

I moved my iTune music library over to my Synology NAS, where various computers on my network now connect with iTunes. However, I also tried to set up a Plex premium music library (I'm a lifetime Plex Pass member), but wasn't able to. I then tried to set up the basic library and that worked fine. I've tried creating the library off of the iTunes folder, the iTunes Media folder and the music folder within iTunes media (the basic library was created off the "music folder"). In all cases, the Plex client shows "Libraries are currently being updated - Hang tight while we look for your content", the icon by the new library spins, but nothing happens. I have no idea what I'm doing wrong. I've been searching the Plex support forums and FAQs, as well general "googling" and can't find a solution. I'm no techy by any means, so before giving up, I thought I'd give the forum a try. Any help would be greatly appreciated.


#2

If there is any DRM (copyright protection) in the files, Plex will ignore it. However, before going down that path, The first thing you, as owner/administrator account on the Synology must do is give user Plex permission to read your music share. I could do it the other way and give Plex free-run of your NAS but I don’t like that. I want you, the user, to be in control of permissions (what has read, write, and delete access) to your stuff.

To check permissions:

Control Panel - Shared Folders - Highlight the share with your music in it - Edit button - Permissions Tab
You’ll see user plex listed. Add as appropriate.


#3

Firstly, thanks for the response. I’ve spent two solid days on this, so it’s greatly appreciated.

I have gone into DSM and added “read/write” permission for Plex on the folder where the iTunes library is. There was no permission granted and there is no “read only” option.

Again, my tech skills are a bit limited, but why would this be a possible issue when creating the premium library, but wasn’t for the basic library?


#4

Do you see under ‘Custom’ ?

If you’re the administrator account, you will have all 4 columns, custom being the right-most.

Click it on Plex’s line

Now take away Write permission. It looks like this


#5

To create your Premium music library, the server must recognize you have a PlexPass. If you’re not seeing it right now, just restart PMS (Package Center - Stop - Start) This will update your subscription status.

Now when you add a music library, it will give you the option


#6

I don’t seem to have access to “custom” or “read-only”. I thought I was logged in as the admin, but apparently not. My son helped set this up and I believe we created an “admin-type” profile under a different name, which we use to make changes on synology. However, I see that there is an “admin” user, but I need to try to find out what the password is or reset it.

Is it a problem if I leave read/write for the moment?

Thanks


#7

I get it… Wish I had found something on this earlier, since it absolutely makes sense.

I have now started the creation of a new Premium Music Library and it seems to be working, with about 30% of my music accounted for and growing (I don’t want to jinx this though!).

Thanks so much for the help and quick response.


#8

Synology lets you create a 'Secondary Admin" account easily. He can keep the master admin if you like and give you admin-like privs which include ownership of your media shares (important point). Then you can do what you need regarding Plex.


#9

I located the admin password and logged in as admin, but, again, the read-only and custom permissions are grayed out and I can’t do anything with those even signed in as the administrator.

Premium music still seems to be creating. However, the number of artists and tracks haven’t changed in awhile. There is an indication of metadata and processing happening, but a little worried we’re not adding (you’re initial DRM comment perhaps?).


#10

Sorry, I’m responding on the forum and to the emails. Not sure what the best protocol is.

Regarding the “admin” password, I found it and logged as the administrator. However, the read-only and custom columns are grayed out and not accessible. Is it a problem if Plex has read/write access?


#11

If he set it up like I did mine, the FIRST account created is the admin.

This is going to be tough and i’m not equipped to do this but I’ll show you what I have

A. I just started to create a share named “Music”. I’m still in the wizard. Notice nothing is checked and all columns are visible. You should try to create some dumy-test share and replicate my results so you can get a feel of it. It’s really easy to learn.

B. I am about to give the admin and myself full R/W permission and give Plex read-only. When I click Apply, it will be created and visible in FileStation for me to use with the permissions just as I set them


#12

It strange that it’s grayed on my existing shared music folder. I’ll try to create a dummy shared folder. In the meantime, is it a problem if Plex has read/write access???

** Also, it appears that the premium music library has stopped adding anything at about 1/3 of my library. The icon’s still spinning, but nothing’s happening. Should I restart Synology and/or Plex, since I was playing around with permissions? **


#13

It’s not a problem that Plex has R/W. Plex doesn’t write to your media. The ONLY time plex will write to your library is if you setup to Optimize media or setup a DVR library. In those cases, it will write to whichever share/folder you point it at. Everything else is always sacred.