Why do all files containing EAC3 audio force Plex to transcode video+audio?



I'm having problems direct streaming any files that use EAC3 5.1 audio on my Roku Streaming Stick 3600 (2016 model).

I have read that this audio format isn't directly supported, and that Plex should be transcoding only the audio portion and direct streaming the video. However, that's not what happens: Plex is transcoding everything during playback, which causes huge load on my Plex server.

I have confirmed that the Roku natively supports the video stream by trying to set Direct Stream to force. With this setting, the Roku plays the video perfectly -- but of course with no audio. I have also tested what happens when I use the Plex Web interface to playback the videos on a computer. In this setup, everything happens as expected: Plex reports that it's direct streaming the video and transcoding the audio. I can also see that the load on the Plex server is far lower.

Is there some way I can force Plex to direct stream the video to my Roku and transcode only the audio?

Thank you very much for any tips on this. I'd be happy to provide any more information.

Please find below a sample of my server log when trying playback an affected file on the Roku:

Aug 24, 2017 14:07:54.223 [6272] DEBUG - Calculated media file path for item 3402: C:\Users\ajgatlin\AppData\Local\Plex Media Server\Metadata\TV Shows\f\a215bff4391343518c5395c44283513bfd17cea.bundle\Contents\_combined/themes/com.plexapp.agents.plexthememusic_ab7fe84c48c68137b27a0808f91e4e7e44c1810a
Aug 24, 2017 14:07:54.226 [6272] DEBUG - MDE: analyzing media item 3867
Aug 24, 2017 14:07:54.226 [6272] DEBUG - MDE: com.plexapp.agents: Direct Play is disabled
Aug 24, 2017 14:07:54.226 [6272] DEBUG - MDE: com.plexapp.agents: Audio Direct Streaming is disabled, so video's audio stream will be transcoded
Aug 24, 2017 14:07:54.226 [6272] DEBUG - Codecs: testing mp3_mf (encoder)
Aug 24, 2017 14:07:54.226 [6272] WARN - Failed to find encoder 'mp3_mf'
Aug 24, 2017 14:07:54.226 [6272] DEBUG - MDE: com.plexapp.agents: selected media 0 / 3867
Aug 24, 2017 14:07:54.226 [6272] DEBUG - Streaming Resource: Added session 09B91C68:0b56855e2c916c851d08f8fe170cf1b4
Aug 24, 2017 14:07:54.227 [6272] DEBUG - Streaming Resource: Reached Decision id=3438 codes=(General=1001,Direct play not available; Conversion OK. Direct Play=3000,App cannot direct play this item. Direct play is disabled. Transcode=1001,Direct play not available; Conversion OK.) media=(id=3867 part=(id=4175 decision=transcode protocol=http streams=(Audio=(id=10284 decision=transcode bitrate=320 encoder=libmp3lame channels=2 rate=44100))))
Aug 24, 2017 14:07:54.228 [4036] DEBUG - Completed: [::ffff:] 200 GET /music/:/transcode/universal/decision (17 live) TLS GZIP 7ms 857 bytes (pipelined: 1)


What does your Plex Roku Profile look like?

In windows: C:\Program Files (x86)\Plex\Plex Media Server\Resources\Profiles\


Thanks very much for the offer to help.

I'm not sure which profile is in use, but I'm pasting below the contents of Roku-5000X-6.0.xml, as I assume that's used with the most recent devices.

I haven't modified this file, and the creation date is 4 April 2017. I should also mention that I've tried uninstalling and reinstalling Plex a couple of times.

<?xml version="1.0" encoding="utf-8"?>
<Client name="Roku-5000X-6.0">
  <!-- Roku TV -->
  <!-- Author: Dale Luck, Roku, Inc. -->
  <!-- Version: 2014/8/21 YMD -->
    <Header name="User-Agent" substring="Roku/5000X" />
    <VideoProfile container="mpegts" audioCodec="aac" codec="h264" context="streaming" />
    <MusicProfile container="mp3" codec="mp3" />
    <PhotoProfile container="jpeg" />
    <VideoProfile container="mpegts" codec="mpeg1video,mpeg2video,h264,mpeg4" audioCodec="ac3,aac,mp3,mp2" />
    <VideoProfile container="mp4" codec="mpeg1video,mpeg2video,h264,mpeg4" audioCodec="ac3,aac,mp3,mp2" />
    <VideoProfile container="mov" codec="mpeg1video,mpeg2video,h264,mpeg4" audioCodec="ac3,aac,mp3,mp2" />
    <VideoProfile container="mpeg" codec="h264,mpeg4" audioCodec="ac3,aac,mp3,mp2"  />
    <VideoProfile container="mkv" codec="mpeg1video,mpeg2video,h264,mpeg4" audioCodec="ac3,aac,mp3,mp2,pcm,flac" />
    <VideoProfile container="flv" codec="mpeg1video,mpeg2video,h264,mpeg4" audioCodec="ac3,aac,mp3,mp2,pcm,flac" />
    <VideoProfile container="asf" codec="mpeg1video,mpeg2video,h264,mpeg4" audioCodec="ac3,aac,mp3,mp2,pcm,flac,wmav2,wmapro,wmavoice" />
    <MusicProfile container="mp3" codec="mp2,mp3" />
    <MusicProfile container="ac3" codec="ac3" />
    <MusicProfile container="mp4" codec="aac" />
    <MusicProfile container="flac" codec="flac" />
    <MusicProfile container="asf" codec="wmav2,wmapro,wmavoice,ac3" />
    <MusicProfile container="wav" codec="pcm" />
    <PhotoProfile container="jpeg,png,gif" />
    <VideoCodec name="*">
    <VideoAudioCodec name="*">
        <UpperBound name="audio.channels" value="6" />
    <MusicCodec name="*">
        <UpperBound name="audio.channels" value="6" />
    <PhotoContainer name="*">
        <UpperBound name="media.width" value="1280" isRequired="true" />
        <UpperBound name="media.height" value="720" isRequired="true" />
    <DlnaMusicProfile container="wav" mimeType="audio/wav" />


Hmm, if that's the correct profile it's using, and assuming these are h264 video codecs in a .mkv or .mp4 container, that should be doing it correctly then. The profile looks correct, so that should be happening. I think this may be a bug in Plex.


Yes, these are h264 codec .mkv files.

Is this the same profile that you (and everyone else with a recent Roku) are using? It seems to be correct to me. I just don't know why it would act differently when streaming over the browser vs. with the Roku.


You may want to look at "Settings, Video, Transcode Format" Make sure it is set to Automatic. Also that Direct Play is enabled.


I’m not sure exactly to which settings section you are referring. However, I am using Automatic for the transcoding quality. After several updates to Plex, I’m still having issues with it transcoding both video and audio portions of the video stream – even when it reports that only audio should be transcoded.

Would a different Roku device possibly help, or do they all have the same Plex profile?

Thanks for any help.


Main Roku Settings Menu - Audio
Audio Mode - Auto (Dolby D)

Roku Plex App Settings:
Direct Play - Auto
Direct Stream - Enable (checked)
Burn Subtitles - Automatic

If you are using image based subtitles the video stream will need to be transcoded. If you are using UTF-8 (text based) subtitles Direct Play of the Video is possible. If you are not using subtitles Direct Play should occur and the audio stream should be transcoded.

Play the item
hit OK
arrow left to the first icon (the graphic equalizer thingy)
hit OK
arrow down to Stream Info
You should see
Direct Play and the container info or Transcoding - there won’t be a lot details about the transcode, but you may be able to see why the video is being transcoded if it is.