Why does PMS v1.12.0.4829 redirect me to login when trying to go to my server's Settings page?

server-linux

#1

I'm currently running PMS v1.11.3.4803 on Ubuntu 16.04.4 LTS and I can navigate without issue to the server settings in Plex Web without any problem. I never sign-in to the server to connect to the Plex cloud, etc. and like to keep it that way. However, after I tried upgrading to v1.12.0.4829 it consistently redirected me to sign-in with my Plex account and there didn't appear to be any way around it which led me to rolling back to the previous release. Guess I have a few questions here....is anyone else being redirected when trying to access their server setting while not signed in? Now a question for any devs that may see this, was this intentional to quietly push users to always sign in to their server?


#2

@dpremier89 said:
However, after I tried upgrading to v1.12.0.4829 it consistently redirected me to sign-in with my Plex account and there didn't appear to be any way around it which led me to rolling back to the previous release.

Please check the setting "List of IP addresses and networks that are allowed without auth" for syntax error, whitespaces, ... If you cannot access the server settings anymore just edit the Preferences.xml file directly.

https://support.plex.tv/articles/201105343-advanced-hidden-server-settings/


#3

@uglymagoo said:

@dpremier89 said:
However, after I tried upgrading to v1.12.0.4829 it consistently redirected me to sign-in with my Plex account and there didn't appear to be any way around it which led me to rolling back to the previous release.

Please check the setting "List of IP addresses and networks that are allowed without auth" for syntax error, whitespaces, ... If you cannot access the server settings anymore just edit the Preferences.xml file directly.

https://support.plex.tv/articles/201105343-advanced-hidden-server-settings/

I've always had the networks filled out and it has been working correctly since even before PMS v1.0. Everything was fine up until the current release and I even rolled back (without changing any of my settings/preferences) to v1.11 and I don't get redirected. There had to have been a change between PMS v1.11 and v1.12 that is causing this issue.


#4

@dpremier89 said:
I've always had the networks filled out and it has been working correctly since even before PMS v1.0. Everything was fine up until the current release and I even rolled back (without changing any of my settings/preferences) to v1.11 and I don't get redirected. There had to have been a change between PMS v1.11 and v1.12 that is causing this issue.

Sure. But please check the syntax once more. We had a user several days ago with a whitespace at the start of this setting. He also did not have any problems till 1.12.0 and removing the whitespace fixed his issue with 1.12.0. If you believe your entry is OK please post your server logs.

https://support.plex.tv/articles/200250417-plex-media-server-log-files/


#5

I'll try your suggestion later when I'm home again but in the meantime I did find others who seem to be having the same issues here. They were being redirected with a clean install on Windows even after adding the network interfaces.


#6

@dpremier89 said:
I'll try your suggestion later when I'm home again but in the meantime I did find others who seem to be having the same issues here. They were being redirected with a clean install on Windows even after adding the network interfaces.

OK. I will reach out to the devs. But please also try my suggestion and provide the logs so the team can take a closer look :)


#7

I definitely will, thanks! Now should the logs be verbose? I don't want to make them too cumbersome to read through


#8

Please disable "Verbose" logging :) We will ask you to turn on "Verbose" logging, if it's necessary .


#9

To all here:

I found some time to devote to this and jump ahead. PMS 1.12.0.4829 (public)

  1. I have reproduced the issue in a controlled (fresh) VM using Linux
  2. I can recreate on 127.0.0.1 as well as accessing the server from a machine on the LAN where "allowedNetworks" is valid.
  3. I can see where part of PMS is respecting "allowedNetworks" and part is not.
  4. The issue/bug report has been filed

#10

In the meantime, is there a way to access Server Settings in PMS 1.12.0.4829 (public)?


#11

@gjaltemba said:
In the meantime, is there a way to access Server Settings in PMS 1.12.0.4829 (public)?

Context please? If your web browser and your server are signed into your account, Settings is visible. If one of them is not, Settings are hidden.

PS: It's considered bad netiquette to hijack (jump in on) someone else's thread