Why is the server transcoding this on Roku 3?

roku

#1

Can anybody see a reason why a Roku 3 would have this transcoded from Plex? When the plex client is on Auto, the video is transcoded (even though bitrate limit is set to 20 in Roku Client) and audio is transcoded to 5.1 Dolby Digital. Forcing direct play plays the file with no issues and full 6.1 sound.

Is there a change I can make in the Roku profile xml to get this to not transcode by default?

Codec H264
Bitrate 13972 kbps
Language English
Bit Depth 8
Chroma Subsampling 4:2:0
Color Range tv
Color Space bt709
Frame Rate 23.976 fps
Height 818
Level 4.1
Profile high
Ref Frames 5
Scan Type progressive
Width 1920

Codec DCA
Channels 6.1
Bitrate 1536 kbps
Language English
Audio Channel Layout 6.1
Profile es
Sampling Rate 48000 Hz
Title DTS-ES 6.1 @ 1509 kbps

Codec AC3
Channels Stereo
Bitrate 224 kbps
Language English
Audio Channel Layout stereo
Sampling Rate 48000 Hz

Codec AC3
Channels Stereo
Bitrate 224 kbps
Language English
Audio Channel Layout stereo
Sampling Rate 48000 Hz


#2

Roku has said that videos should be limited to 12000 kbs bitrates. The Roku xml may be forcing transcoding of videos that exceed that rate.

I do not know for sure but that seems possible. There is some evidence that Rokus can actually handle higher bitrates but I find it hard to believe that bitrates that high result in any improvement in the playback but I would not know for sure because nothing in my library even comes close.

You might be better off getting the videos to a lower bitrate.


#3

Level 4.1
The plex app on your roku may be set to level 4.0, try changing it to 4.1 if that's the case.


#4

Something weird going on...

I play the movie and it transcoded due to unsupported audio. I pick track 2 which is ac3 2 channel and the 6.1 track plays with no transcoding! I pick track 3 and the 2 channel track 2 plays!

Something is up with the audio track selection in the new Roku player.

To add to this...this is the audio track selection from within the Plex pass app. If I play with the default track selected and hit the option button I get the Roku dialog and no audio tracks are available for selection. Only when I pick "track 2" using the Plex app options do I get the option to select other tracks with the Roku option button.

UPDATE 2: This only happens on a Roku hooked to a home theater receiver with DD+ / DTS capability. On my TV upstairs which is stereo only the audio track selection works as expected.

UPDATE 3: Edited the original post to include the info on the 2 other audio tracks.


#5

This appears to be happening with any MKV that has a DTS-ES 6.1 audio track as primary. I have to select the second track (Stereo 2.0 in my cases) which will then play the FIRST DTS-EX 6.1 track streamed and also give me access to the audio/subtitle options using the * key on the Roku remote. If I let Roku just pick the first track, it comes down as DD 5.1 and the * button doesn't let me change subtitles or audio.


#6

lately Plex has been killing me with how it handles audio... more annoyingly it wants to transcode everything to AAC. Today I noticed similar issues as you have posted but I've noticed them on the Roku 3 not My Roku Stick, I'll have to check on the Roku 2 & 4.

They should allow Audio PassThrough


#7

Still happening for me. Only happens with DTS-ES 6.1 mkv files.


#8

It is a known issue. You can modify the headers to show less than 7 channels, and it will not affect playback. Otherwise, you can force direct play and it should play fine.


#9

It is a known issue. You can modify the headers to show less than 7 channels, and it will not affect playback. Otherwise, you can force direct play and it should play fine.


#10

@drinehart said:
It is a known issue. You can modify the headers to show less than 7 channels, and it will not affect playback. Otherwise, you can force direct play and it should play fine.

Modifying the header didn't work. 6.1 DTS-ES gets changed to 5.1 Dolby. If I pick the second audio track which is a 2.0 commentary track the full 6.1 track plays instead. Then I have to use the Roku * button and change audio tracks that way.


#11

It could be the ES tag then, I typically just use DTS-MA, and the fix I described usually works (though I normally just force direct play instead of direct stream). What you describe does sound a littly buggy. @ljunkie might be able to offer some assistance.


#12

@drinehart said:
It could be the ES tag then, I typically just use DTS-MA, and the fix I described usually works (though I normally just force direct play instead of direct stream). What you describe does sound a littly buggy. @ljunkie might be able to offer some assistance.

Forcing direct play does work so it must be a bug in the Roku Client that sees DTS-ES as Dolby Digital somehow when it tries to auto stream it.


#13

I am told there is no official Roku support for DTS-ES6.1, some models completely fail while others use the DTS core, and there is no way to know which models will play the core since ES is not officially supported. therefore we convert DTS variants unless one forces direct play