why plex convert

samsung-smart-hub

#1

Hello all

I have a TV Samsung UE55JS9000 and use PLEX server under Windows.

Why plex launch a conversion even when my TV can play the directly the stream.?

Example for 4K flux:
- if launch a movie with playback mode auto, plex transcode video and audio( HEVC -> H264 and TRUEHD -> AC3) but if launch a movie with playback mode Direct Play, the TV watch correctly a sound and video.

BR


#2

If the playback mode is set to Auto it will:

  • check if the video and audio codecs are compatible (TRUEHD is not compatible with any TV)
  • check if the selected subtitles need transcoding to be displayed (PGS, VobSub)
  • check if the bandwidth is too high (max 20k or a lower value if the admin has set one for sharing)

With 4K movie the bandwidth is almost always too high, so for those you need to set it to direct play manually.
On the other hand you wouldn’t want a shared user to stream a 4k movie in full bandwidth by default,
since he might not have a 4K capable TV.

If you want more info on the app, you might want to take a look at the manual (link below)


#3

check if the video and audio codecs are compatible (TRUEHD is not compatible with any TV)
-> My audio amplifier that decode correctly and display that truehd when to select directplay.
-> My TV support HEVC and plex transcode !!!

check if the selected subtitles need transcoding to be displayed (PGS, VobSub) -> No subtitle

check if the bandwidth is too high (max 20k or a lower value if the admin has set one for sharing) -> The TV Wifi connect at 500Mb/s, 4K movie request approximately 100Mb/s.

It’s possible to modify a file for avoid Plex to convert ?


#4

My audio amplifier that decode correctly and display that truehd when to select directplay.
The problem is that the TV needs to decode the audio and it cannot do that for TrueHD, only for DTS, Dolby and PCM.
Pass-through only works for HDMI inputs. Plex is however using the network cable not HDMI.

It’s possible to modify a file for avoid Plex to convert ?
There are enough video conversion programs, google for them, but you can set the default playback mode to Direct Play is that’s what you are looking for.
Go to preferences > Player Playback mode. Select it and press enter until you have the correct setting.