Why won't my Sonos Play 5 connect to my Plex server?

sonos

#1

I have posted on here before about the problem I am having with my Sonos Play5 not connecting to my Plex server. I add Plex to the Sonos music service, link it via the Plex code which gives me a green tick to say it is now linked but when I try to open my Plex music folder to play I get the "unable to connect to this server" screen. I have checked that the Plex remote access is on with a green tick but it makes no difference Sonos still won't connect. For a while, it did work if I was on my VPN connection but even that now no longer works. I have had several emails with Sonos support but they have been unable to come up with a fix. The frustrating thing is the Plex easily connects quite happily with other devices just not the Sonos. I am at my wit's end so not knowing how to move forward with this problem I have been reading advice avidly on here and on the Sonos forum and some have talked about port forwarding via the router as a possible solution but I have never done that before and not sure about how to do it. Could I ask if any member or Plex expert if they could advise me if port forwarding could be an answer and how to go about it? I do know how to access my Arris TG2492LG router but then I am lost and I am scared to change anything in case I mess up my internet connection. The Sonos is using my local home wifi. Many thanks


#2

The Plex option in Sonos is Beta which means it’s buggy. There are many things they need to fix.
Try replacing the the queue. Also losses files don’t tend to play. Tap the 3 dots next to an mp3 then

It’s a work around. It may not even work for you.
You will have to repeat the process now and again. If you play a lossless file it will break the queue and you will have to replace it again.


#3

Hi Andy, Thank you so much, I will try this and let you know on here if it worked for me... anything is worth a try!


#4

Hi Andy,
I now tried your workaround on my Sonos app but unfortunately, it did not work I still get the screen message " Unable to connect to Plex" but thanks for your interest it might have worked! Back to the drawing board I am afraid