Windows 10 Buffering Issues

server-windows

#1

I'm curious if there are any specific settings in Windows 10 that can effect Plex negatively?

Here's what's going on. I am having buffering issues. This happens at the same point every time. Some movies it happens at the beginning, some it happens halfway through, some it waits until towards the end. I've yet to have this happen in TV shows. This didn't start until I upgraded my server to Windows 10, clean install.

The issue happens whether it transcodes or uses direct play. The difference being that when it transcodes it happens at a different time, usually later, and it will get stuck buffering at 33% until it just gives up and acts like the movie ended. With direct play it at least will buffer and go back to playing the movie.

I have tried re-encoding multiple times. It does it when it's playing the AAC stereo track, DTS or AC3 Dolby Digital. I've tried changing the order of the audio tracks with no change. I have tried changing every possible setting I can think of in the server app as well as the client app on the Rokus. I encode my files as H264 MP4 and the content is 1080p.

My setup is that I have Plex running on a dedicated server with a Pentium G4600, which replaced the G3850 that used to be in it. I am using two Roku 3's. One is wired and one is wireless. It does it on both regardless of what settings I change. If I play the files over the network (No Plex) from either my laptop, which is wireless or my main system which is wired, they seem to play just fine past the point the buffer on the Rokus and both are running Windows 10. Same goes for playing on the server through Plex Server itself. My local network is gigabit and I usually get around 100 MB/sec sustained. All wired devices go through a switch, NOT the router.

I feel like I'm chasing my tail as the hardware shouldn't have an issue with either transcoding or direct play. I don't know if it's a issue with the encodes (seems unlikely), an issue with the server app, an issue with the Rokus (also unlikely) or an issue with Windowds 10?

Any tips?


#2

This is happening with ALL of your media?
And this is the same media that worked fine with the "old" box?


#3

It seems to be happening with every movie I've tried, including ones that I know did not have the issue before. As of yet the issue does not happen with TV shows. For reference, the TV shows and the movies are sourced from Blu Rays and are encoded to the same settings.


#4

Seems to me happening too. Setup: Plex Server 1.8.4.4249 on Windows 10 Clean install (Intel Xeon 3.8 Ghz, 32Gb RAM, 64-bit). NAS QNAP TS869L. Wired Gigabit and Wireless 300Mb
Several movies - without any problem sofar with direct play on PC. All encoded H264/no compression (hence 20Mbit uncompressed datatraffic). LG television UHD.

Problem on LG television with Plex for LG (webOS 03.60.05) 3.8.0: First loss of subtitle after approx 45 minutes of playing. Then movie stops playing with the message 'An unexpected error occurred'.

Problem on Ipad with Plex for iOS 4.17 - Movie plays ok, until fast forward of about 1h. Then the message appears (translated from Dutch) 'Playing stopped by server. Conversion failed. The transcoder has crashed or could not be started' Same time of swiping 1h forward on the client the CPU usage on the server drops to 2%...

Ok. Doing some troubleshooting here.

Restarted the movie (Interstellar) on Ipad at 43.41 (that's where I was watching).
CPU load on server is about 25% on 3Ghz. Memory usage stable at 3.4GB (out of 31.9).
Going forward 30s. ok.
Going forward 60s. ok.
Going forward 120s. takes a very long time, CPU drops to 0. Bingo: after about 20 secs the error appears.
Press ok on Ipad to clear the error message
On Ipad screen the thumbnail of Interstellar.
Play button does not work.
Using 'v' (left top of screen) to open overview.
Press resume.
CPU of server goes to 60% again and movie resumes....
Memory stable, local disk I/O is 1%
CPU drops back to 30% average.
Ethernet is 20Mbps average.

I'll do some further investigations.


#5

Movie is now at 58:53 - just noted that also on the Ipad the subtitle (external idx/sub) have now disappeared.
This is about the same moment when this happened on the LG television this morning.


#6

Movie is now at 1.11.02, still playing without subtitles. Paused the movie on Ipad. Started the movie again on Ipad. After 20s the message 'Playing stopped by server. Conversion failed. The transcoder has crashed or could not be started' appears.

This is most annoying.


#7

Ok, I have done some investigations on this Transcoder crash. Please check other specs of server, NAS and client in first post.

Started 'Exodus: Gods and Kings' at 11.36 AM GMT on IoS 9.3.5 Ipad Mini with Plex client 4.17.
Movie starts and Dutch subtitle is shown. Subtitle in external IDX/SUB format file, naming according to Plex standard and placed all in one subdirectory on the NAS.

At 11.42 CPU usage is 17% (most of it for the Transcoder), Mem 10%, Network 2% and Disk 2% (highest active).
The CPU graph on the server is regular: sharkfin after sharkfin. Movie shows fine
Around 12.14 - without any change to client or server - Plextranscode process drops to 7% --> the CPU graph changes from 'series of sharkfins' to 'one flat line'.
12.15 - Client reports a buffer error and 'server is not strong enough' and stops playing *AT THE SAME POINT * where the LG television stopped playing (!) the day before yesterday.

I checked the Media Server logfile regurarly and there were no issues UNTIL 11.57 where the last update was written. So after 11.57 until 12.15 there are no updates in the Media Server logfile appended.... Which is pretty strange, since that happens normally about every second.

Next I restarted the playback on the client 12.23. Nothing happens on the client, but the transcoding process goes totally ballistic, pushing CPU to 4.11 Ghz. After a while this stops. Playback is not resumed on the client.

Attaching the logs here. The 'saved' versions are made around 12.15 (after the client stopped).

Would appreciate your help or suggestions.

PS. Plex server spec attached. 70Gb of free internal disk storage. NAS has 2x 9TB.


#8

Yet another update: I opened the movie file (Exodus) with Windows 10 Media player (default called Films and Television). No subtitles of course since VOB/IDX is not supported.

But: the player crashes just a second after the scene Plex crashes with error 0xC00d36cb.

This error relates to profile issues or file system inconsistency.
So I built a complete new profile on Win 10 and did a check on the NAS file system.

Then I started the Win 10 player again - with the same result (crash) in exactly the same frame.

So I copied the media file as-is from the NAS to local storage and started the default Win 10 player again.

Update per 18/09/2017 8.43: Viewing the film from local storage resulted in the same crash in the same frame (but, while copying, network speed tested to 113 MBs, so that is perfectly fine).


#9

Update per 19/09/2017.

Right - the MKV of Exodus is corrupted. :'( - strange that not all players stop at the same frame, but that could have something to do with buffering.

In the mean time I have:
- created a new userprofile on Windows 10 and installed PMS and Plex client fresh
- investigated in all kind of codecs
- tested with VLC Media player as well. All huge (30Gb) MKVs I created from Blueray are now playing. In VLC I have disabled all kind of video hardware acceleration.

But: I still loose the subtitles on the LG television after an hour of watching.

Good news is that the video stream continues though!


#10

In reference to my original post, the issue was with Roku, not Plex or my media files. With the latest Roku update the issue was resolved.