Windows 10 - "Expected X-Plex-Sync-Version: 2" Error

windows-store-app

#1

Getting this error on most of my clients suddenly with this last code update. I can sync like once, but then never again until I completely reset the client by removing it from devices and re-logging in again.

I am also getting this from other servers that people have shared with me. Not sure why though.


#2

Same issue:

Server: Version 1.11.0.4666
APP: Version 3.2.20-25990c77 (5/10/2017)


#3

Good idea. Same here as well.

Server - Version 1.11.0.4666
Windows 10 App - 3.2.20-25990c77 (5/10/2017)

This sucks. I use this weekly on the plane and now it takes much longer to get things synched. If I want to add even one new movie/show I have to redownload everything.


#4

Right so I figured out a workaround for syncing, I think. Once you allow syncing to the device by adding a single sync item. You can them use the plex web interface to sync to your device. I did notice however that the updated windows media player doesn't like aac-lc... so I need to find a workaround for that as the profile doesn't make a difference...


#5

I've tried both from the web interface and the client itself. On the client, it gives me the above error. The web interface allows me to add it, but then I get an unknown error when attempting to sync it.

With the recent server update, I cannot get anything to sync even with the work arounds I used to use. Piss.

Is there really no more support for Plex here? Is there an email address or something I should send this to? I paid for this so I assumed I'd get support.


#6

@theguru0 you need to make sure that the windows client hasn't shown you the error yet. Otherwise my workaround won't work.
I have tried it on mine and I have no issues getting the media onto my sync, as long as I don't try to setup the syncs from the app itself. Sadly I have another issue now where windows media player is unable to play certain codecs I am sure it used to...


#7

Anyone know how to engage official support from Plex? I thought it was these forums, but its been two weeks with no response from them.


#8

@theguru0 it is.... But just check the "show your customers respect" thread and you'll see that support has been missing for almost 18 months on the windows forum... We are all very annoyed at this and you'll be able to see that in that thread.

I wish someone would knock on their door and find out :smile:


#9

Indeed - long standing ISSUE / BUG with no fix. On the plus point, Plex seems to have has focused all it's efforts recently on Plex VR which is...er...something, someone, somewhere _might _have thought was a good idea ??

Surely is better releasing new functionality that 1% (just a guess) of subscribers will use rather than focus on a MAJOR bug that's been in existence for over 18 months.

Just me then....


#10

Yes just you :wink:


#11

Not just him of course. I wish someone would at least post here that could help.


#12

Been having the same problem - quite frustrating seeing as how it makes the Windows 10 app worthless. Also disappointing to see this has been going on for almost 2 months and no improvement has been made yet. What's happening?


#13

This thread fixed it for me https://forums.plex.tv/discussion/301516/unable-to-save-sync-item-expected-x-plex-sync-version-2

Hi,

I just tried it again. This time i deleted the device via plex web, unistalled the app from the device, reboot, installed again and now it works.

Regards,
Patrick


#14

This may be fixed now at the Plex back end - try it again. Sync is now working for me.
https://forums.plex.tv/discussion/301516/unable-to-save-sync-item-expected-x-plex-sync-version-2/p2


#15

I haven't had the problem lately either. I wish we knew. :| Sometime in the future when/if it comes back we'd know if it was "still" broken, or newly broken.


#16

Yes, that fix should have resolved that error.


#17

There seems to be an update that came out that fixed it. I can't find anything in the release notes though.