Windows 10 Store Plex App Crashing When First Attempting to Play Movie?

windows-store-app

#1

Hello --

Sometime in the last few weeks (I'm sorry I can't be more specific), I've noticed the Windows 10 app crashing without warning. Specifically, the app will be closed. I'll open it up, navigate to a movie I'd like to watch, press play, and the app force-closes (without any error message being displayed).

I can then re-open the app, navigate to the same movie, press play, and away it goes.

Has anyone else experienced this?


#2

Yes
I have also posted this and other strange behavior of the Plex Windows App on Win 10 Anniversary Edition.

http://forums.plex.tv/discussion/244221/strangest-thing-just-happened-with-the-windows-plex-app#latest


#3

Same problem! Been happening ever since the last update.


#4

Hi @citizenc , would you mind sending me logs after a crash so we can tell what is going wrong?


#5

Of course, happy to help. How do I do that?


#6

OK! I had found the option to enable logging, and it just did it. The app had been closed for about an hour; opened it up, went to resume watching a movie (under "Continue Watching", right at the top of the home screen) by clicking on the displayed image, and after a moment the app crashed to desktop without an error.

I immediately re-opened the app, replicated my actions, and the film resumed without a hitch.

I have logs!

Where do I send 'em?


#7

2016-11-17 08:12:48:5370 [2] VERBOSE - [PlexMetricsClient] - Clicked play in page home (context 'home.continue')
2016-11-17 08:12:49:2274 [5] DEBUG - [PlexHttpClient] - Received OK from http://127.0.0.1:32400/library/metadata/13610?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx
2016-11-17 08:12:49:2284 [18] VERBOSE - [PlexClient] - Container from http://127.0.0.1:32400/library/metadata/13610?X-Plex-Token=xxxxxxxxxxxxxxxxxxxx has 1 child item(s)
2016-11-17 08:12:49:2314 [18] DEBUG - [PlexHttpClient] - POST http://127.0.0.1:32400/playQueues?type=video&shuffle=0&continuous=0&uri=library%3A%2F%2F5f4d3af5-9350-46cb-971a-d678a5613e9d%2Fdirectory%2F%252Flibrary%252Fmetadata%252F13610&key=%2Flibrary%2Fmetadata%2F13610&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx
2016-11-17 08:12:49:2464 [5] DEBUG - [PlexHttpClient] - Received OK from http://127.0.0.1:32400/playQueues?type=video&shuffle=0&continuous=0&uri=library%3A%2F%2F5f4d3af5-9350-46cb-971a-d678a5613e9d%2Fdirectory%2F%252Flibrary%252Fmetadata%252F13610&key=%2Flibrary%2Fmetadata%2F13610&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx
2016-11-17 08:12:49:2479 [18] VERBOSE - [PlexClient] - Container from http://127.0.0.1:32400/playQueues?type=video&shuffle=0&continuous=0&uri=library%3A%2F%2F5f4d3af5-9350-46cb-971a-d678a5613e9d%2Fdirectory%2F%252Flibrary%252Fmetadata%252F13610&key=%2Flibrary%2Fmetadata%2F13610&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx has 1 child item(s)
2016-11-17 08:12:49:2484 [2] DEBUG - [ApplicationPlayQueueManager] - Setting Video PlayQueue to 616 on server bb6337e03cfeb30a3b176894a7aeadbe68eb51af
2016-11-17 08:12:49:2484 [2] INFO - [MainPage] - Start playing Video PQ (1 items)
2016-11-17 08:12:49:3366 [2] DEBUG - [MainPage] - Navigating from
2016-11-17 08:12:49:3366 [2] DEBUG - [MainPage] - Navigated from
2016-11-17 08:12:49:3366 [2] DEBUG - [VideoPlayerPage] - Navigating to
2016-11-17 08:12:49:3386 [2] DEBUG - [AudioPlayerBackgroundTaskCommunicator] - Sent keys: TestConnectionToBackground to background media player successfully.
2016-11-17 08:12:49:3456 [2] DEBUG - [AudioPlayerBackgroundTaskCommunicator] - Sent keys: MediaControlsClear to background media player successfully.
2016-11-17 08:12:49:4026 [18] DEBUG - [AudioPlayerBackgroundTaskCommunicator] - Ping was not received yet, not retrying.
2016-11-17 08:12:49:4126 [24] ERROR - [WindowsAppCore] - Unhandled NullReferenceException: Arg_NullReferenceException
System.NullReferenceException: Arg_NullReferenceException
at Plex.AutoHideCursorApplicationBehavior.HideCursor()
at Plex.PageBase.SetAutoHideMouseCursorPageOverride(Boolean value)
at Plex!+0x1f29e03
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at SharedLibrary!+0x69993e
at SharedLibrary!+0x497d7c
at Plex!+0x16f6e6c
at Plex!+0x1734186
at Plex!+0x17340b4
at Plex.UwpAppCoreBase.OnCoreApplicationUnhandledErrorDetected(Object sender, ApplicationModel.Core.UnhandledErrorDetectedEventArgs args)
Stack trace:
at Plex.AutoHideCursorApplicationBehavior.HideCursor()
at Plex.PageBase.SetAutoHideMouseCursorPageOverride(Boolean value)
at Plex!+0x1f29e03
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at SharedLibrary!+0x69993e
at SharedLibrary!+0x497d7c
at Plex!+0x16f6e6c
at Plex!+0x1734186
at Plex!+0x17340b4
at Plex.UwpAppCoreBase.OnCoreApplicationUnhandledErrorDetected(Object sender, ApplicationModel.Core.UnhandledErrorDetectedEventArgs args)
2016-11-17 08:12:49:4136 [24] VERBOSE - [StorageFileEventListener] - Flushing log file storage (1 outstanding tasks)
2016-11-17 08:12:49:4226 [5] DEBUG - [PlexMetricsBackingStore] - Sending 7 metrics events
2016-11-17 08:12:49:4226 [4] DEBUG - [PlexHttpClient] - POST https://metrics.plex.tv/collect/event


#8

I had the same problem until I turned off Direct Play in the Windows 10 App. Now they play with no issues at all.


#9

deucer nailed it. I thought the crashing might be related to having my devices on Insider builds, but after turning Direct Play off, no more crashing.


#10

Mine was due to enabling (AMD) crossfire for any applications that have no associated profile, I turned it off and Plex from windows store and PMP worked, located the proof in the Windows Logs > Application logs viewer