Windows specific instructions for creating and installing the SSL cert

plexconnect

#6

Thanks sam

All up & running again ..  :rolleyes:

Cheers..

  Riche

Thank you!
This worked for me as well on both my Apple TV 3's
I appreciate you taking the time to break out the instructions for a Windows environment!!

I'm just happy it works for other people :D

we all have windows panes but that doesn't mean we should suffer..LOL


#7

Worked for me too, thanks a lot. ;)


#8

Work for me also. Great instructions.


#9

I did all the above mentioned things but without luck. 

20:40:35 PlexConnect: started: 20:40:35
20:40:35 PlexConnect: IP_self: 192.168.1.163
20:40:35 DNSServer: started: 20:40:35
20:40:35 DNSServer: ***
20:40:35 DNSServer: DNSServer: Serving DNS on port 53.
20:40:35 DNSServer: intercept: ['trailers.apple.com', 'atv.plexconnect'] => 192.168.1.163
20:40:35 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld.apple.com.edgesuite.net'] => 127.0.0.1
20:40:35 DNSServer: forward other to higher level DNS: 8.8.8.8
20:40:35 DNSServer: ***
20:40:35 WebServer: started: 20:40:35
20:40:35 WebServer: ***
20:40:35 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
20:40:35 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
20:40:35 WebServer: ***
20:40:35 PlexGDM: ***
20:40:35 PlexGDM: looking up Plex Media Server
20:40:35 PlexGDM: ***
20:40:36 PlexGDM: servers discovered: 1
20:40:36 XMLConverter: PlexGDM - PMS: 192.168.1.163:32400
20:42:44 DNSServer: DNS request received!
20:42:44 DNSServer: Source: ('192.168.1.200', 61870)
20:42:44 DNSServer: Domain: iphonesubmissions.apple.com
20:42:44 DNSServer: ***forward request
20:42:44 DNSServer: -> DNS response from higher level
 
 
[PlexConnect]
logpath = .
enable_dnsserver = True
ip_webserver = 0.0.0.0
prevent_atv_update = True
enable_plexconnect_autodetect = True
port_pms = 32400
port_webserver = 80
ip_plexconnect = 0.0.0.0
certfile = ./assets/certificates/trailers.pem
ip_dnsmaster = 8.8.8.8
loglevel = Normal
ip_pms = 192.168.178.10
enable_plexgdm = True
port_ssl = 443
port_dnsserver = 53
 
regards
rob

#10

@ Rob I could be wrong but I think your cert path is off

"certfile = ./assets/certificates/trailers.pem"

I believe the ./ denotes an IOS path whereas these instructions are specific to Windows

Try changing it to certfile = c:/assets/certificates/trailers.pem

But even that might be off. You want to make sure that this path points towards directly to the file. For instance I have Plex Connect installed right in my C:/ drive so my path looks like

certfile = C:PlexConnect/assets/certificates/trailers.pem

Good luck!


#11

thanks Gdowler, 

modified it now to :

[PlexConnect]
logpath = .
enable_dnsserver = True
ip_webserver = 0.0.0.0
prevent_atv_update = True
enable_plexconnect_autodetect = True
port_pms = 32400
port_webserver = 80
ip_plexconnect = 0.0.0.0
certfile = C:/PlexConnect-master/assets/certificates/trailers.pem
ip_dnsmaster = 8.8.8.8
loglevel = Normal
ip_pms = 192.168.178.10
enable_plexgdm = True
port_ssl = 443
port_dnsserver = 53
 
22:45:19 PlexConnect: started: 22:45:19
22:45:19 PlexConnect: IP_self: 192.168.1.163
22:45:19 DNSServer: started: 22:45:19
22:45:19 DNSServer: ***
22:45:19 DNSServer: DNSServer: Serving DNS on port 53.
22:45:19 DNSServer: intercept: ['trailers.apple.com', 'atv.plexconnect'] => 192.168.1.163
22:45:19 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld.apple.com.edgesuite.net'] => 127.0.0.1
22:45:19 DNSServer: forward other to higher level DNS: 8.8.8.8
22:45:19 DNSServer: ***
22:45:19 WebServer: started: 22:45:19
22:45:19 WebServer: ***
22:45:19 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
22:45:19 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
22:45:19 WebServer: ***
22:45:19 PlexGDM: ***
22:45:19 PlexGDM: looking up Plex Media Server
22:45:19 PlexGDM: ***
22:45:20 PlexGDM: servers discovered: 1
22:45:20 XMLConverter: PlexGDM - PMS: 192.168.1.163:32400
 
still without luck, I am using python 2.75,  pms 09.8.5 , windows 7 64 , at3 5.3
 
I don't know what to change anymore, spend 5 hours now to get it working ..... :(

#12

I typo'd my cert path (keep in mind that this is mine as an example, double check yours to make sure it maps correctly)

certfile = C:\PlexConnect-master\assets\certificates railers.pem
 

I forgot that I had to turn the slashes around


#13
22:53:16 PlexConnect: started: 22:53:16
22:53:16 PlexConnect: IP_self: 192.168.1.163
22:53:16 DNSServer: started: 22:53:16
22:53:16 DNSServer: ***
22:53:16 DNSServer: DNSServer: Serving DNS on port 53.
22:53:16 DNSServer: intercept: ['trailers.apple.com', 'atv.plexconnect'] => 192.168.1.163
22:53:16 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld.apple.com.edgesuite.net'] => 127.0.0.1
22:53:16 DNSServer: forward other to higher level DNS: 8.8.8.8
22:53:16 DNSServer: ***
22:53:17 WebServer: started: 22:53:17
22:53:17 WebServer: ***
22:53:17 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
22:53:17 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
22:53:17 WebServer: ***
22:53:17 PlexGDM: ***
22:53:17 PlexGDM: looking up Plex Media Server
22:53:17 PlexGDM: ***
22:53:18 PlexGDM: servers discovered: 1
22:53:18 XMLConverter: PlexGDM - PMS: 192.168.1.163:32400
22:53:49 DNSServer: DNS request received!
22:53:49 DNSServer: Source: ('192.168.1.200', 61638)
22:53:49 DNSServer: Domain: p35-buy.itunes.apple.com.akadns.net
22:53:49 DNSServer: ***forward request
22:53:49 DNSServer: -> DNS response from higher level
22:53:51 DNSServer: DNS request received!
22:53:51 DNSServer: Source: ('192.168.1.200', 63691)
22:53:51 DNSServer: Domain: ax.init-cdn.itunes.apple.com.akadns.net
22:53:51 DNSServer: ***forward request
22:53:51 DNSServer: -> DNS response from higher level
22:53:51 DNSServer: DNS request received!
22:53:51 DNSServer: Source: ('192.168.1.200', 61447)
22:53:51 DNSServer: Domain: itunes-cdn.apple.com.akadns.net
22:53:51 DNSServer: ***forward request
22:53:51 DNSServer: -> DNS response from higher level
22:54:16 DNSServer: DNS request received!
22:54:16 DNSServer: Source: ('192.168.1.200', 51224)
22:54:16 DNSServer: Domain: a771.da1.akamai.net
22:54:16 DNSServer: ***forward request
22:54:16 DNSServer: -> DNS response from higher level
22:54:17 DNSServer: DNS request received!
22:54:17 DNSServer: Source: ('192.168.1.200', 56638)
22:54:17 DNSServer: Domain: trailers.apple.com
22:54:17 DNSServer: ***intercept request
22:54:17 DNSServer: -> DNS response: 192.168.1.163

#14

i'm quite desperated at this stage.... :(


#15

Huiszeeland,

If you browse to your Plexconnect machine on https://192.168.1.163

What happens?  Unless you have installed your certificate on the machine you are browsing from you should get a Certificate warning.

This proves that plexconnect can locate the trailers.pem file.

The next step would be to redo the profile on the apple TV to make sure that the trailers.cer file is correctly installed.


#16

What Drewbie is suggesting is spot on. In my case what ultimately being the culprit was the cert on the Apple TV. And the steps above resolved that although I did stumble at first.


#17

hi Drewbie and Gdowler  i am receiving an error saying that i need a certificate. Strange because i followed steps above to get certicicate on my atv 3. 

I will try again . btw i 've used https : //192.168.163:32400


#18

Hi Drewbie, i have modified my settings now :

[PlexConnect]
logpath = .
enable_dnsserver = True
ip_webserver = 0.0.0.0
prevent_atv_update = True
enable_plexconnect_autodetect = True
port_pms = 32400
port_webserver = 80
ip_plexconnect = 0.0.0.0
certfile = C:\PlexConnect-master\assets\certificates railers.pem
 ip_dnsmaster = 8.8.8.8
loglevel = Normal
ip_pms = 192.168.178.10
enable_plexgdm = True
port_ssl = 443
port_dnsserver = 53

#19

Huiszeeland,

I suggest you stop cross posting everywhere, keep your issue to one thread its a lot eaiser for people to help you and see what has been suggested.  I would actually also suggest you start your own thread rather than jumping on someone else's as again its easier to see what answers are for you.

I have just posted more to one of the other threads you are posting on.  (http://forums.plexapp.com/index.php/topic/79587-stucked-in-accesing-trailers/page-2)


#20

ok drewbie, from now on i will use one post.

sorry


#21

Worked great for me, thanks a lot! :)


#22

worked great ;)

thanks for the perfect documentation!


#23

Hi, i've done everything  you mentionned and I have a little problem   My ATV3 connects goods, but when I select a movie it says trailers unavailable, but it load my whole list of movies  whats wrong ?


#24

11:54:36 PlexConnect: started: 11:54:36
11:54:36 PlexConnect: IP_self: 192.168.1.139
11:54:36 DNSServer: started: 11:54:36
11:54:36 DNSServer: ***
11:54:36 DNSServer: Starting up.
11:54:36 DNSServer: intercept: ['trailers.apple.com', 'atv.plexconnect'] => 192.168.1.139
11:54:36 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld.apple.com.edgesuite.net'] => 127.0.0.1
11:54:37 DNSServer: forward other to higher level DNS: 205.151.67.34
11:54:37 DNSServer: ***
11:54:37 WebServer: started: 11:54:37
11:54:37 WebServer: ***
11:54:37 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
11:54:37 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
11:54:37 WebServer: ***
11:54:37 PlexGDM: ***
11:54:37 PlexGDM: looking up Plex Media Server
11:54:37 PlexGDM: ***
11:54:38 PlexGDM: servers discovered: 1
11:54:38 XMLConverter: PlexGDM - PMS: 192.168.1.139:32400
11:55:10 DNSServer: DNS request received!
11:55:10 DNSServer: Source: ('192.168.1.121', 49246)
11:55:10 DNSServer: Domain: p48-buy.itunes.apple.com.akadns.net
11:55:10 DNSServer: ***forward request
11:55:10 DNSServer: -> DNS response from higher level
11:55:12 DNSServer: DNS request received!
11:55:12 DNSServer: Source: ('192.168.1.121', 62498)
11:55:12 DNSServer: Domain: itunes.apple.com
11:55:12 DNSServer: ***forward request
11:55:12 DNSServer: -> DNS response from higher level
11:55:12 DNSServer: DNS request received!
11:55:12 DNSServer: Source: ('192.168.1.121', 58878)
11:55:12 DNSServer: Domain: ax.init-cdn.itunes.apple.com.akadns.net
11:55:12 DNSServer: ***forward request
11:55:12 DNSServer: -> DNS response from higher level
11:55:13 DNSServer: DNS request received!
11:55:13 DNSServer: Source: ('192.168.1.121', 53515)
11:55:13 DNSServer: Domain: trailers.apple.com
11:55:13 DNSServer: ***intercept request
11:55:13 DNSServer: -> DNS response: 192.168.1.139
11:55:14 WebServer: serving application.js
11:55:15 DNSServer: DNS request received!
11:55:15 DNSServer: Source: ('192.168.1.121', 51241)
11:55:15 DNSServer: Domain: atv.plexconnect
11:55:15 DNSServer: ***intercept request
11:55:15 DNSServer: -> DNS response: 192.168.1.139
11:55:15 WebServer: serving .xml: /PlexConnect.xml
11:55:15 ATVSettings: add section 007
11:55:16 WebServer: serving  C:\Documents and Settings\Jimmy\Bureau\PlexConnect-XML_templates\assets\js\utils.js
11:55:16 ATVLogger: loadItem: Library
11:55:16 WebServer: serving .xml: /library/sections
 


#25

Hi, just got an Apple TV in the post today, trying to get this running without any luck.. the ATV is version 5.3

a couple of quick questions after waiting for the light to go solid on the ATV, I install the fresh cert, do I need the ATV connected to a TV at this point ?

the reason I ask, when I re connect the ATV to my telly, and open trailers, it just opens as normal, (aka just bog standard apple trailers.) I'm not getting unavailable at this time etc as some other are or the plex..

20:37:58 PlexConnect: ***
20:37:58 PlexConnect: PlexConnect
20:37:58 PlexConnect: Press CTRL-C to shut down.
20:37:58 PlexConnect: ***
20:37:58 PlexConnect: started: 20:37:58
20:37:58 PlexConnect: IP_self: 192.168.0.6
20:37:59 DNSServer: started: 20:37:59
20:37:59 DNSServer: ***
20:37:59 DNSServer: DNSServer: Serving DNS on port 53.
20:37:59 DNSServer: intercept: ['trailers.apple.com', 'atv.plexconnect'] => 192.
168.0.6
20:37:59 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld
.apple.com.edgesuite.net'] => 127.0.0.1
20:37:59 DNSServer: forward other to higher level DNS: 8.8.8.8
20:37:59 DNSServer: ***
20:37:59 WebServer: started: 20:37:59
20:37:59 WebServer: ***
20:37:59 WebServer: WebServer: Serving HTTP on 0.0.0.0 port 80.
20:37:59 WebServer: WebServer: Serving HTTPS on 0.0.0.0 port 443.
20:37:59 WebServer: ***
20:37:59 PlexGDM: ***
20:37:59 PlexGDM: looking up Plex Media Server
20:37:59 PlexGDM: ***
20:38:00 PlexGDM: servers discovered: 1
20:38:00 XMLConverter: PlexGDM - PMS: 192.168.0.6:32400

which looks ok ?

DNS on ATV is the same as my router 192.168.0.1 - my pc ip is 192.168.0.6 posts 80 and 443 are open in my firewall

I can see on the ATV that the profile is installed in profiles

Any ideas ? I would love to get this working on my new ATV as I use plex on my ipad and it's great but it would be super nice to have some 5.1 sound