Wondering how to disable ipv6 through configuration files

server-freebsd

#1

I stupidly turned on ipv6 through the web gui not releasing that my isp does not support ipv6. I can no longer get into the web gui to edit server setings. Does anyone know what file I need to edit at the command line to disable ipv6? I'm inside the jail, but have yet to find the file.

I'm running freenas 9.3 with the default plex plugin.

Thank you much.


#2

For anyone that needs an answer in the future, I figured it out. I was looking for .conf file. It's actually in a .xml file.

First shutdown your plugin via freenas
Show your jails: jls
Get inside your jail : jexec /bin/tcsh
Get to the directory: cd /var/db/plexdata/Plex Media Server
Make a backup: cp Preferences.xml Preferences.xml.backup
Edit the file: vi Preferences.xml
(find a vi tutorial if you don't know how to vi or use a different editor)
Change the EnableIPv6="1" to EnableIPv6="0"
Save the file
Start your plugin via the freenas gui