Wrong audio/Commentary tracks playing after new update

plex-classic-for-roku

#1

So we had the issue with the Roku 1 & 2 before with the audio track playing the commentary (both english, so Plex defaulted to commentary for some reason). A trick we found on the forum for fixing this was to play the movie in Plex on our PC and switch through the tracks using the "A" key. Then when we exited and played the movie through the Roku again it would play the correct track (defaulted to PC settings).

 

After the new update, this is no longer the case. We have looked everywhere! Haven't found any setting on the Roku or Plex that will fix this issue. We have a ton of kids movies that we now can't play because the audio track can't be switched off of the commentary. And we haven't seen anyone else post with this issue after the update either, does anyone have any ideas?


#2

I'd be curious to see the media info for the file. (Plex/Web, pull up the video, click Media Info, then View XML, and paste in here.) It should only choose the wrong thing if the streams are in a funky order. Regardless, you can go into the Playback Options for the video on the Roku and select which audio stream you want. If it seems like it's not respecting what you choose, then you *may* get better results by also forcing it to Direct Stream/Transcode.


#3

Here is the XML from the video

MediaContainer size="1" allowSync="1" identifier="com.plexapp.plugins.library" librarySectionID="2" librarySectionUUID="12c5caf8-2123-4f80-8180-9070c28cbd43" mediaTagPrefix="/system/bundle/media/flags/" mediaTagVersion="1365384609">

We have tried switching the audio stream on the roku and it still plays the commentary track.

I just tried your suggestion of changing playback to directstream/transcoding and it worked for this particular movie. Hopefully it will work for any others that have this issue as well!

Thanks for your help-


#4

This is ocurring for me as well.  Only sometimes does the "directstream/transcoding" method allow the correct audio track to play.  I did not have this issue prior to update.

I notice also that, when using the "directstream/transcoding" method, and it works, that the audio quality is lessened.

I implore that the Plex developers correct this issue to allow the correct audio stream to be used.

Best Regards,


#5

We have tried switching the audio stream on the roku and it still plays the commentary track.

I just tried your suggestion of changing playback to directstream/transcoding and it worked for this particular movie. Hopefully it will work for any others that have this issue as well!

Ok, thanks. So it's choosing the wrong stream for Direct Play and working fine for transcoding, which isn't terribly surprising. When we transcode it, we have full control over which stream is sent back. When we Direct Play, it's up to the Roku video player to choose the right stream. But I'm surprised it picked the wrong audio. Is the Roku configured to do surround sound or stereo only? (In the Roku Player Settings, not within the Plex channel.)


#6

Ok, thanks. So it's choosing the wrong stream for Direct Play and working fine for transcoding, which isn't terribly surprising. When we transcode it, we have full control over which stream is sent back. When we Direct Play, it's up to the Roku video player to choose the right stream. But I'm surprised it picked the wrong audio. Is the Roku configured to do surround sound or stereo only? (In the Roku Player Settings, not within the Plex channel.)

The Roku is configured to stereo, as we have it hooked up to our TV. We do not have surround sound in that room so we didn't choose that setting-

Also, I did notice that this issue is only occurring on our Roku 2, the Roku 1 did not have any problems playing correct audio after the update.


#7

Terrific, thanks! That's a bug that we can get fixed in the next update to the Roku channel. It should have noticed that the stereo stream was suspicious (as potentially commentary) and avoided Direct Playing.


#8

I don't know if this is any help or not, but I have been learning my way through converting a lot of Blu-Ray, DVD and other forms of video over the mp4 & MKV's for use on Plex with handbrake and for use on my Roku's.

An I don't know why, but it seems that even when I put several audio tracks on there, they can not be switched even if I do them in Plex/Web as the only thing that will play is what ever is the first audio track.

I'll admit I haven't persured it deap in the settings where I'm messing with the transcodeing choices, kinda thought I was setting things up to not need any transcoding by doing them in handbrake like many recommend. As well am running myPlex off a pretty cheap laptop with 3T USB drive on it, so I am trying to have as little need for transcoding as possble.

But at any rate, basically I'm writing this to tell you that for me I have learned that if there is a certain audio track I want from the various ones something might have that I am converting, I make sure I put it first.

So don't know if that will help you, kinda looks like your putting the 6 ch's first but perhaps those are ones that have that?

Anyway, know it might be a pain, but if you could do this you might try redoing them with checking to be sure which ever track isn't a problem an plays right is used for the first one, and reconverting it with that first.

Btw some of the ways I have been testing my conversions first for all kinds of things is to do a test run of say 120 seconds or something, then put that file in what ever myPlex folder I am going to be using it in first, then see how that works.

Then if all is OK, then I let the many hour conversion run.

Hope that is if some help

.


#9

Should be fixed in [the 2.6.8 update](http://forums.plexapp.com/index.php/topic/27134-plex-for-roku/?p=459952), currently available in the PlexTest channel. Thanks again for the report.


#10

I can confirm that there is still an issue here.  I am using a Roku 3 with the latest PLEX versions on my windows 7 PC and on the Roku.  I played a few files to test this and when I use Direct Play the first audio track is played.  I am using MKV files with streams in this order DTS 5.1, AC3 5.1 and AAC 2.0 in them.  Direct Play picks the DTS track each time.  When I switch to Automatic the audio track that i select is always played.  Not sure what is going on here, but it is not playing the correct track in Direct play.  

Here is the media info for one of the files that has this behavior:

This XML file does not appear to have any style information associated with it. The document tree is shown below.
 size="1" allowSync="1" identifier="com.plexapp.plugins.library" librarySectionID="9" librarySectionUUID="79643e2f-2b0e-4bd6-8652-d93971f150d1" mediaTagPrefix="/system/bundle/media/flags/" mediaTagVersion="1365384173">
 ratingKey="91049" key="/library/metadata/91049" guid="com.plexapp.agents.imdb://tt0162222?lang=en" studio="DreamWorks" type="movie" title="Castaway"contentRating="PG-13" summary="A FedEx executive must transform himself physically and emotionally to survive a crash landing on a deserted island."rating="6.6999998092651403" viewOffset="40000" lastViewedAt="1387424416" year="2000" tagline="At the edge of the world, his journey begins."thumb="/library/metadata/91049/thumb/1387423175" art="/library/metadata/91049/art/1387423175" duration="8627946" originallyAvailableAt="2000-12-22"addedAt="1387423164" updatedAt="1387423175">
 videoResolution="480" id="75757" duration="8627946" bitrate="3223" width="718" height="472" aspectRatio="1.78" audioChannels="6" audioCodec="dca"videoCodec="h264" container="mkv">
 id="89311" key="/library/parts/89311/file.mkv" duration="8627946" file="H:\Videos\Movies (MKV)\Castaway (2000) (480p, DTS 5.1).mkv"size="3476493062" container="mkv">
 id="110487" streamType="1" codec="h264" index="0" bitrate="1829" anamorphic="1" bitDepth="8" cabac="1" chromaSubsampling="4:2:0"codecID="V_MPEG4/ISO/AVC" colorSpace="yuv" frameRateMode="vfr" hasScalingMatrix="0" height="472" level="30" pixelAspectRatio="32:27" profile="high"refFrames="4" scanType="progressive" width="718"/>
 id="110488" streamType="2" selected="1" codec="dca" index="1" channels="6" bitrate="755" language="English" languageCode="eng" bitDepth="24"bitrateMode="cbr" codecID="A_DTS" duration="8627946" profile="es" samplingRate="48000"/>
 id="110489" streamType="2" codec="ac3" index="2" channels="6" bitrate="640" language="English" languageCode="eng" bitDepth="16"bitrateMode="cbr" codecID="A_AC3" dialogNorm="-31" duration="8627946" samplingRate="48000"/>
 id="110490" streamType="2" codec="aac" index="3" channels="2" language="English" languageCode="eng" codecID="A_AAC" duration="8627946"profile="lc" samplingRate="48000"/>
 id="110491" streamType="3" default="1" index="4" language="English" languageCode="eng" codecID="S_VOBSUB" format="vobsub"/>







 id="487" tag="Adventure"/>

 id="8277" tag="William Broyles Jr"/>

 id="1323" tag="Robert Zemeckis"/>

 id="4357" tag="Tom Hanks"/>

 id="4358" tag="Robert Zemeckis"/>

 id="4359" tag="Steve Starkey"/>

 id="4360" tag="Jack Rapke"/>

 id="4361" tag="Cherylanne Martin"/>

 id="4362" tag="Steven J. Boyd"/>

 id="493" tag="USA"/>

 id="513" tag="Tom Hanks" role=""/>

 id="2144" tag="Helen Hunt" role=""/>










#11

I see the thread is shown as "Answered", but I am still experiencing the issue as stated in my last post.  

Plex Team please look into this.


#12

If you force Direct Play, then we just give the file to the Roku's video player. We can't really tell it which stream to play. If you leave it on Automatic, then we decide if the Roku is going to pick the stream you want when we decide whether or not to direct play. We strongly recommend leaving the setting on Automatic, for this and  many other reasons.


#13

Thanks for the reply.  Does the video and audio still direct play if I choose automatic?  If I have compatible H.264 MKVs with DTS audio will it direct play on the Automatic setting?

Could you explain exactly what "Automatic" does?

Thanks!


#14

Automatic does what it thinks is best given all of the information it has. If direct play is supported, it'll direct play. But if you've selected a stream that won't work with direct play, then it won't direct play. In the scenario you described, automatic would almost certainly direct stream (i.e. repackage the streams you want in a new container, without converting them).


#15

@schulyer i know this is an old post and do not know if you are still with the Plex team. I am encountering the same issue w my Plex Player in that it automatically plays the Director Commentary for certain movies that have that track encoded when I select “Direct Play” and turn off “Direct Stream”. Is there a way for Plex to allow the user to select the track through Plex Media Player? At present it does not and the only option I have is to turn on Direct Stream which forces Plex Server to unnecessarily transcode the audio track to aac and the video track to it’s native format.