"Your connection to the server is not fast enough" with every videos

plex-for-kodi

#1

Hi,

I am running libreelec 8 (kodi 17.1) and plexkodiconnect (1.8.1 if I remember well). Internet link is 100Mbps, the plex server is hosted on the internet, on a dedicated server (i3, 100Mbps internet).
Since very recently, I can't read any video, I always have the same error : "Your connection to the server is not fast enough ..."
I tried to reinstall libreelec and kodi but still the same
I also tried the official plex client, under android OS.

It was just working fine before, and it is working with the plex client with phone and chromecast

Any idea ?

thanks


#2

Have you resolved this? I am having a similar problem but only on my 4k content.


#3

I had a similar problem with my Openelec rig for months, it cracked me up and the missus too, turned out i was only feeding it a 10/100 connection, I upgraded my Ethernet switch in the roofspace to push full gigabit down to my Asus Chromebox Openelec.

My setup was at the time;
PlexMediaServer(WAN) > Netgear R7000(10/100/1000) > Ethernet Switch(10/100) > Chromebox(10/100)

After replacing the bottle neck i.e the switch on the connection this seemed to solve all problems I had with streaming…

After upgrading switch;
PlexMediaServer(WAN) > Netgear R7000(10/100/1000) > Ethernet Switch(10/100/1000) > Chromebox(10/100/1000)

One other thing to check is to restrict your stream quality, do a speed check on your LAN (not over wireless!) to see what sort of speeds your getting and make sure your stream quality in your Plex client is set around 70-80% of that speed test, this in theory should cap your stream quality for seem less stream and not totally buck out your bandwidth for other devices.

Hope this helps
W.