After update to latest, movie playback stops after 2-3 minutes and requires reboot of PMS

server-raspberry-pi

#1

I've had Plex running on a Raspberry Pi 3 for a few months without issues and noticed that there was a update available - and of course, now that I've updated it, I'm having issues :'( Not sure what version I came from, but it would have been whatever was latest around the beginning of January, and it now has 1.12.1.4885. Raspbian was updated at the same time, (i.e. I did "sudo apt-get update" & "sudo apt-get upgrade" to update the whole system) and it was previously recent as of the beginning of Jan as well.

The behavior I'm seeing is that regardless of the client (have tried from both Xbox One and via browsers in a couple of different computers), browsing through the movies is fine and any movie I pick plays well for about 2-3 minutes or so. After that time though, the client indicates that's it's buffering but it never comes back from that state. If I quit the movie and try to browse around, all I get are wait indicators. The client is mostly unresponsive, movies are not shown. In a browser I see the chrome around the main area, but no movies or tv shows will show up, and even clicking on settings from the top bar will just end up resulting in a timeout. This happens until I reboot the raspberry pi, then all is good again until I try to play a movie. This happens regardless of the movie I'm playing - HD, SD, different bitrates, etc.

Looking at the syslog on the pi and the "Plex Media Server.log" file, it looks like one of the key processes involved is crashing shortly after sending enough data to the client to play back about 2-3 minutes of the movie.

Are there any known issues like this, or any ideas of what I can do to debug into it further?

syslog:

Apr  2 19:08:08 PlexPi kernel: [  641.583946] Unable to handle kernel NULL pointer dereference at virtual address 00000028
Apr  2 19:08:08 PlexPi kernel: [  641.586528] pgd = b8ea8000
Apr  2 19:08:08 PlexPi kernel: [  641.587774] [00000028] *pgd=36ac3835, *pte=00000000, *ppte=00000000
Apr  2 19:08:08 PlexPi kernel: [  641.589077] Internal error: Oops: 17 [#1] SMP ARM
Apr  2 19:08:08 PlexPi kernel: [  641.590366] Modules linked in: rpcsec_gss_krb5 rfcomm cmac bnep hci_uart bluetooth ecdh_generic evdev joydev brcmfmac brcmutil cfg80211 rfkill snd_bcm2835(C) snd_pcm snd_timer snd fixed uio_pdrv_genirq uio i2c_dev ip_tables x_tables ipv6
Apr  2 19:08:08 PlexPi kernel: [  641.594600] CPU: 1 PID: 534 Comm: Plex Media Serv Tainted: G         C      4.14.30-v7+ #1102
<a bit more info follows, including registry info and a stack dump>

Plex Media Server.log:

Apr 02, 2018 19:08:07.741 [0x6a8ff400] DEBUG - Content-Length of /home/pi/mnt/video/Movies/Jurassic World (2015)/Jurassic World (2015).mp4 is 5494307072.
Apr 02, 2018 19:08:27.198 [0x67dff400] VERBOSE - LongPoll: Sending data...
Apr 02, 2018 19:08:30.937 [0x67dff400] DEBUG - [CompanionProxy] player unvo6q97u36dkwernwa43g7g was last refreshed 10 seconds ago
Apr 02, 2018 19:08:40.937 [0x648ff400] DEBUG - [CompanionProxy] player unvo6q97u36dkwernwa43g7g was last refreshed 20 seconds ago
Apr 02, 2018 19:08:50.938 [0x67dff400] DEBUG - [CompanionProxy] player unvo6q97u36dkwernwa43g7g was last refreshed 30 seconds ago
Apr 02, 2018 19:09:00.938 [0x648ff400] DEBUG - [CompanionProxy] player unvo6q97u36dkwernwa43g7g was last refreshed 40 seconds ago
Apr 02, 2018 19:09:00.938 [0x648ff400] DEBUG - [CompanionProxy] player unvo6q97u36dkwernwa43g7g was not refreshed for over 30 seconds, dropping it.
Apr 02, 2018 19:11:10.934 [0x648ff400] DEBUG - [Now] Removing idle session for device vzthacftehwmluq45hokpa35_Video.
Apr 02, 2018 19:11:10.936 [0x648ff400] DEBUG - Statistics: (unvo6q97u36dkwernwa43g7g) Reporting active playback in state 3 of type 1 (scrobble: 0) for account 1

#2

@geekonice said:
Apr 2 19:08:08 PlexPi kernel: [ 641.583946] Unable to handle kernel NULL pointer dereference at virtual address 00000028

What Linux distribution does PlexPi use? Your problem is caused by a Linux kernel panic. Nothing we can do. Your Linux distribution is broken. Please just use an official Raspberry Pi distribution like Raspbian and install Plex manually.


#3

I have exactly the same issue since yesterday so perhaps an update of raspbian went wrong.
Reinstalled PMS, kernel and boot but to no avail.

If someone figures it out, please let us know :slight_smile:


#4

Don’t use the 4.14 kernel and stay with 4.9 for now. 4.14 is not stable.

https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=197689&start=75


#5

And also disable any CPU overclocking. Apparently, this can also lead to this kernel panic.


#6

I use my Plex only for music so my experience may be different. I started having issues recently as well and this morning I used rpi-update to update to the slightly newer 4.14.30 kernel that is supposed to resolve some kernel issues (https://github.com/raspberrypi/linux/issues/2446). Based on my demesg I may still have a panic but Plex is working now. I ran:

sudo rpi-update 56026b3e625d8180a0d718df3babcc8f63e16e40


#7

@uglymagoo said:
Don’t use the 4.14 kernel and stay with 4.9 for now. 4.14 is not stable.

https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=197689&start=75

This looks like the problem, my Raspbian kernel version is 4.14.30-v7+ (I’m not running an overclocked CPU). Wish I would have seen that thread before updating - and also wish I had a backup of the system prior to the update :frowning:

@“clarksonator@gmail.com” said:
I use my Plex only for music so my experience may be different. I started having issues recently as well and this morning I used rpi-update to update to the slightly newer 4.14.30 kernel that is supposed to resolve some kernel issues (https://github.com/raspberrypi/linux/issues/2446). Based on my demesg I may still have a panic but Plex is working now. I ran:

sudo rpi-update 56026b3e625d8180a0d718df3babcc8f63e16e40

Based on this thread and some links from it, I may be able to just try to do a workaround of switching from ethernet to wifi … at least as a temporary workaround anyway.


#8

Error still happened after switching to WiFi, but I did try the upgrade command specified by @“clarksonator@gmail.com” , and that got me back to a working state. Will do a bit more research next time before updating, and will also make sure I make backups prior to any upgrade (even if it seems safe).


#9

@uglymagoo said:
Don’t use the 4.14 kernel and stay with 4.9 for now. 4.14 is not stable.

https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=197689&start=75

How do you revert to 4.9? I can’t seem to find instructions on how this is accomplished.
Is this command what does it?
sudo rpi-update 56026b3e625d8180a0d718df3babcc8f63e16e40


#10

@DMackG said:
How do you revert to 4.9? I can’t seem to find instructions on how this is accomplished.
Is this command what does it?
sudo rpi-update 56026b3e625d8180a0d718df3babcc8f63e16e40

The previous Debian packages are cached in /var/cache/apt/archives. Look for the package raspberrypi-kernel and reinstall the previous one. The above rpi-update command installs a patched 4.14.x kernel directly from the github raspberry pi linux repository and circumvents the apt repo. That’s the “dirty” solution. You can also remove the commit hash, e.g. just rpi-update. The commit was merged into the master branch afaik and the latest kernel “could” work :#

You can read more about this topic in the official docu:


#11

Thanks much Uglymagoo!


#12

A new kernel package was released by Raspbian. Can you guys please update your Raspbian with apt, install the new raspberrypi-kernel package and report back?


#13

I had this same issue of kernel panic after a few minutes of playback, and I can confirm that it is no longer occurring after upgrading to Linux raspberrypi 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux using the commands sudo apt-get update && sudo apt-get dist-upgrade