[Solved] Airplay stream from Android or iOS to PHT works once then crashes

pht-for-linux

#1

Hi all,

Plex seems like an awesome solution fitting exactly my needs with media! Except for the fact that airplay seems somewhat to be broken for me...

I have a small debian wheezy (7.9 with kernel 3.2.0-4-amd64) server with openmediavault (2.0) on it. CPU is AMD 5350. It runs:
- PMS version 0.9.12.19 with UPNP and Airplay enabled
- PHT version 1.4.1.dev-47a90f01 compiled with the tutorial from yakumo: https://forums.plex.tv/discussion/87255/the-plex-home-theater-debs-thread/p1. I just needed to use jessie-backports to get the correct cmake... + install ubuntu font family. It is mostly used for music.

Everything runs fine (except from a laggy desktop environment) server side and player side. I do not have a monitor always connected to it.
I can play music from PHT, "remoting" PHT, and with UPNP stream.

However: when I try to stream with airplay to PHT from android or iOS, it works fine, but hangs when disconnecting. PHT shows 100 % CPU even if still usable. Only the Airplay service seems to be crashed as I cannot reconnect to PHT with airplay stream.

PHT debug log follows... What concerns me is "PlexTimelineManager::ReportProgress unknown item pipe://1/"

Any help?

Thanks


#2

oops
Appears that my quote for code did not work. Anyway, the full log is here: http://pastebin.com/yZ5ALv5m
The thread is marked as "question", but might go beyond that...

FYI, the problem is not what is explained here http://forums.plex.tv/discussion/120176/plex-home-theater-freezes-and-crashes-when-trying-uncheck-allow-plex-ht-to-receive-airplay-cont or here http://forums.plex.tv/discussion/119142/airplay-audio-to-pht-not-working


#3

Hi,

I somehow solved my problem. Similar behaviour was from a thread with chaps talking about Kodi v12 (Frodo) http://forum.kodi.tv/showthread.php?tid=147725
I seems that my problem would be solved by using libshairport2 instead of libshairport1. I kept PHT compiled as is.

So, dirty but it works:

to allow libshairport2 to work on wheezy (need libc6 >= 2.15, while the stable is 2.13):
apt-get -t sid install libc6 libc6-dev libc6-dbg

install libshairport:
apt-get remove libshairport1
apt-get -t sid install libshairport2

the dirtiest:
ln -s /usr/lib/x86_64-gnu-linux/libshairport.so.2.0.0 /usr/lib/x86_64-gnu-linux/libshairport.so.1.0.0

And voilà, it works.

Cheers

Thread can be closed


#4

Hi there,

If it may help anyone with PHT/Airplay/Wheezy, the final and best solution was to :
- get libshairport2 source with apt-get (build-dep, + get source), get it from jessie or sid
- compile libshairport2 on wheezy
- whether find a way to register the newly build lib objects as libshairport2 (sort of creating a backport...) or link libshairport.so.2.0.0 built to libshairport.so.1.0.0 in /usr/lib/x86_64-gnu-linux/ (or similar)
- get PHT source and compile it (direct install may work...) from: https://forums.plex.tv/discussion/87255/the-plex-home-theater-debs-thread
- ATTENTION: best is not to install libshairport1 as you compiled libshairport2...

Compiling the new library libshairport (1.2.1~git20120510 vs. 1.2.1~git20120110) is better than getting libshairport2 from sid or jessie and same with libc6 (which is needed for libshairport2 to run), but is really not nice.

Good luck to anyone who tries.