Suppress IP in discovery?

server-raspberry-pi

#1

Is it possible to prevent the Plex server sending an IP to the clients via plex.tv?

My server sends it's internal IP as well as it's external which causes a problem as it's remote and the internal ip via a VPN that lands on a pi. The pi only has enough grunt for about 10mbit.

I worked around this by blocking that traffic on the firewall but ideally I'd like my clients (firetv) to always use the external interface to reach the server.

It may be less of an issue once I replace the gen1 pi


#2

@dragon2611 said:
It may be less of an issue once I replace the gen1 pi

Gen 1 pi means you are still using a 2 years old Plex server < 1.0.0 for armv6? Is this true or did you just confuse your RPi?

Is it possible to prevent the Plex server sending an IP to the clients via plex.tv?

My server sends it's internal IP as well as it's external which causes a problem as it's remote and the internal ip via a VPN that lands on a pi. The pi only has enough grunt for about 10mbit.

I worked around this by blocking that traffic on the firewall but ideally I'd like my clients (firetv) to always use the external interface to reach the server.

That's a problem and there is currently no simple off-the-shelf solution available to set the network interface that's used by Plex.

Edit: scatch the next part. A firewall is still your best option. I suppose your routing is not perfect at the moment: you should not route any Plex traffic through your VPN, right? What VPN solution do you use?