Transcoding vs Direct Play

playstation

#1

All of my videos are processed through ffmpeg before being added to PMS with the following commands:

1st Pass:
ffmpeg -i $file -c:v libx264 -level:v 3.1 -b:v 1000k -minrate 800k -maxrate 1000k -bufsize 1835k -c:a aac -strict -2 $file2

2nd Pass:
ffmpeg -i $file2 -c:a copy -c:v copy -movflags faststart $file3

And while I hardly ever see transcoding (unless Auto Quality Adjustment kicks in) on every other device, every single video my brother tries to watch on his PS4 is transcoded (see attached image).

Is there a better set of ffmpeg commands to prevent this?

PS4 is hardwired to the modem (speed test results in pic #2)
PMS is hardwired to the modem (speed test results in pic #3)


#2

I’ve had a similar issue (transcoding H264 to H264 on the playstation 4). I solved it by increasing the H264 level inside the PS4 Plex settings from 4.1(?) to 5.0. Although this might cause some files not to play.

You could try processing your files to a lower H264 level so they will play on the default settings, i’ve never tried this myself though.

Also: anything with softsubs will always transcode for me.


#3

hello
Direct Play
The media file is 100% compatible with the native player on the device on which you wish to play it. The file is sent as-is to the Plex App.

Direct Play requires almost no CPU usage on the Plex Media Server.

Direct Stream
The media is almost compatible with the native client. For example, the audio and video codecs are compatible but the container is not. In this case, the audio/video codecs are direct streamed to the client, and Plex transcodes the container to a format the native player can use.

Direct Stream requires very little CPU usage on the Plex Media Server.

Transcoding
If the video or audio format isn’t compatible, then your Plex Media Server has to convert them to a compatible format. It does this by “transcoding” it. Depending on the situation, only the audio may need to be converted, only the video, or both.

Transcoding audio requires very low to moderate CPU usage on the Plex Media Server. Transcoding video (including burning in subtitles) requires high to extreme CPU usage.


#4

@“walteriswhite9@gmail.com”

Is your post incomplete? I am well aware of the difference between Direct Play/Stream and Transcoding.


#5

@laniax said:
I’ve had a similar issue (transcoding H264 to H264 on the playstation 4). I solved it by increasing the H264 level inside the PS4 Plex settings from 4.1(?) to 5.0. Although this might cause some files not to play.

You could try processing your files to a lower H264 level so they will play on the default settings, i’ve never tried this myself though.

Also: anything with softsubs will always transcode for me.

As you can see from my code, I am processing videos at level 3.1 and still seeing 99% of the videos get transcoded from mp4 to mpegts