Update Plexmediaserver on Raspberry Pi 3

server-raspberry-pi

#1

I am running plex media server on Raspberry Pi 3. And it works great.

I see a message on my web server page that an update is available -- Version 1.8.4.4249 An update is available. Please install manually.

I have tried sudo apt-get update && sudo apt-get upgrade but the plex media server does not seam to upgrade.

Can you please advice me on how I can properly upgrade to the latest?

Thanks


#2

I am also running plex media server on Raspberry Pi 3. It works great.

I am having the exact same issue. I have tried combined command as mentioned by above user...and I have tried separately..

sudo apt-get update
sudo apt-get upgrade
sudo reboot

Nothing seems to upgrade as it should. I have never had this issue before.


#3

@dvbox @batesnd Please give me at least 24 hours after release to prepare the package. Then you can remind me ;) Btw: please try again ;)


#4

Okay. I did as you asked, I completed the update and now my entire library is gone!!! That's really not cool! I spent a lot of time personalizing and getting that up-to-date. I altered images, posters, information and order of thousands of shows. Creating all of the MP4s took me over 6 weeks...now I have no library. I wish I had known that was going to happen after this update, I would have left it alone. Why trash the library?


#5

@batesnd Your library is not gone ;) Please read my post about the change. Obviously, the migration script had a problem with your configuration. Just check and fix your override.conf and everything will be fine.


#6

Forgive me (and thank you for your patience). I am new to this. I am not sure what you mean by "check and fix your override.conf"


#7

@batesnd You had changed the support dir or the user of the plex media server in /etc/default/plexmediaserver. This file is not used anymore on your system. Please read this guide explaining the override.conf file. I suppose the migration scripted f***ed something up and the the settings are wrong. Your old /etc/default/plexmediaserver is still there, it was just renamed to /etc/default/plexmediaserver.prev. So compare this with the override.conf and fix the settings.

Reload the new settings with sudo systemctl daemon-reload and restart plex media server afterwards with sudo systemctl stop plexmediaserver and sudo systemctl start plexmediaserver.


#8

I am running Plex on a raspberry pi 3. Plex Version 1.8.4.4249 was running great.

I then get upgraded to the latest version of Plex (1.9.1.4272) to using:
sudo apt-get update
sudo apt-get dist-upgrade

Afterwards, the I could see plexmediaservice was running, but I was unable to connect.

Following the guide explaining the override.config, I noticed my override.config was missing the following line:
Environment="PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR=/home/pi/Library/Application Support"

Once, I put that line in, restarted plexmediaservice. Plex started working again.

Hope this helps.


#9

@PoloM1 said:
I am running Plex on a raspberry pi 3. Plex Version 1.8.4.4249 was running great.

I then get upgraded to the latest version of Plex (1.9.1.4272) to using:
sudo apt-get update
sudo apt-get dist-upgrade

Afterwards, the I could see plexmediaservice was running, but I was unable to connect.

Following the guide explaining the override.config, I noticed my override.config was missing the following line:
Environment="PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR=/home/pi/Library/Application Support"

Once, I put that line in, restarted plexmediaservice. Plex started working again.

Hope this helps.

Hi,
I having the same problem... I added the line like you said and reboot the system and I still cannot access to dashboard

this is the shh output
service plexmediaserver status
● plexmediaserver.service - Plex Media Server for Linux
Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled)
Drop-In: /etc/systemd/system/plexmediaserver.service.d
└─override.conf
Active: active (running) since Thu 2017-09-21 15:56:53 WEST; 12s ago
Process: 1125 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" || /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" (code=exited, status=0/SUCCESS)
Main PID: 1129 (sh)
CGroup: /system.slice/plexmediaserver.service
├─1129 /bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver "/usr/l...
└─1132 /usr/lib/plexmediaserver/Plex Media Server

Sep 21 15:56:53 pipplware systemd[1]: Started Plex Media Server for Linux.
Sep 21 15:56:57 pipplware systemd[1]: Started Plex Media Server for Linux.


#10

As a point of order override.conf not override.config is what systemd has documented. Some distros may allow variations but override.conf is guaranteed to work through all versions of systemd


#11

@kikoFHM said:
Active: active (running) since Thu 2017-09-21 15:56:53 WEST; 12s ago

12 seconds is a very short time. Please wait at least 2-3 minutes to test the connection to plex. If it's then not up and running please post to contents of /etc/default/plexmediaserver.prev and we will tell you what your override.conf should look like.


#12

@uglymagoo said:

@kikoFHM said:
Active: active (running) since Thu 2017-09-21 15:56:53 WEST; 12s ago

12 seconds is a very short time. Please wait at least 2-3 minutes to test the connection to plex. If it's then not up and running please post to contents of /etc/default/plexmediaserver.prev and we will tell you what your override.conf should look like.

this is my plexmediaserver.prev file

______________

# default script for Plex Media Server
# the number of plugins that can run at the same time
PLEX_MEDIA_SERVER_MAX_PLUGIN_PROCS=6
# ulimit -s $PLEX_MEDIA_SERVER_MAX_STACK_SIZE
PLEX_MEDIA_SERVER_MAX_STACK_SIZE=3000
# where the mediaserver should store the transcodes
PLEX_MEDIA_SERVER_TMPDIR=/tmp
# uncomment to set it to something else
# PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR="${HOME}/Library/Application\ Support"
# the user that PMS should run as, defaults to 'plex'
# note that if you change this you might need to move
# the Application Support directory to not lose your
# media library
PLEX_MEDIA_SERVER_USER=pi

_____________________

and this is my override.conf

#
# Plex Media Server - Systemd service override file
#
# All entries must be systemd compliant (Environrment="var=absolute_value")
#
Environment="PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR=/home/pi/Library/Application Support"
[Service]
# If you wish to change Plex's Username or Group, uncomment the field(s) below and
# change to the correct values
#User=new_plex_username
#Group=new_plex_group
User=pi
Group=pi
_____

Can't put the server back again after the upgrade

Moderator edit: Made code properly visible by using 'Code' paragraph formatting.


#13

"● plexmediaserver.service - Plex Media Server for Linux
Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled)
Drop-In: /etc/systemd/system/plexmediaserver.service.d
└─override.conf
Active: active (running) since Thu 2017-09-21 15:56:53 WEST; 26min ago
Main PID: 1129 (sh)
CGroup: /system.slice/plexmediaserver.service
├─1129 /bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver "/usr/lib/plexmediaserver/Plex Media Server"
└─1132 /usr/lib/plexmediaserver/Plex Media Server

Sep 21 15:56:53 pipplware systemd[1]: Started Plex Media Server for Linux.
Sep 21 15:56:57 pipplware systemd[1]: Started Plex Media Server for Linux.
Sep 21 16:00:54 pipplware systemd[1]: [/etc/systemd/system/plexmediaserver.service.d/override.conf:6] Assignment outside of section. Ignoring.
Sep 21 16:01:07 pipplware systemd[1]: Started Plex Media Server for Linux.
"

running over 26min and still nothing. can't get the plex dashboard with ip:32400/web/index.html
the service is running but the page gaves me "ERR_CONNECTION_REFUSED"


#14

@kikoFHM said:
Sep 21 16:00:54 pipplware systemd[1]: [/etc/systemd/system/plexmediaserver.service.d/override.conf:6] Assignment outside of section. Ignoring.

Please move the line "Environment="PLEX_MEDIA_SERVER_APPLICATIO .... " to the end of the file ;)


#15

If I may clarify?

The [Service] directive must occur first.

While normal to specify Environment variables next, there is no set order however all override declarations must occur after the [Service] declaration statement.


#16

PERFECT !
glad for your help. The server is back again. Thank you all


#17

I apologize, I had a lot of doctor appointments (Disabled Veteran). I just got home. I am reading through the material...but super confused as to what I am supposed to do. I can't even figure out how to access the file I need to inspect to change.


#18

@uglymagoo
I apologize, I had a lot of doctor appointments (Disabled Veteran). I just got home. I am reading through the material, but I am super confused. Now I keep seeing this message if I try to stop my plexmediaserver...
"Warning: Unit file of plexmediaserver.service changed on disk, 'systemctl daemon-reload' recommended.

Basically I can not seem to figure out what to do to fix the lost library. I am begging for help step by step. I am not stupid, but I don't know how to program or look this up without help. When I saw that I needed to create a directory, I typed sudo sh...not knowing what I was doing. Not sure if I changed something I shouldn't have. I am worried I will have to start completely over at this point.


#19

I will take help from anyone at this point. Please.


#20

@batesnd and the rest of the gang, I just pushed a new package revision to my repo with a fixed migration script. This package also makes it very easy to recover from your current problems.

  1. Install the new package with apt-get
  2. move the old settings back in place: sudo mv /etc/default/plexmediaserver.prev /etc/default/plexmediaserver
  3. call the migration script by hand: sudo /usr/lib/plexmediaserver/MigratePlexServerConfig.sh
  4. reload systemd and start plex: sudo systemctl daemon-reload, sudo systemctl stop plexmediaserver, sudo systemctl start plexmediaserver