Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Media Server 1.5.1 and Plex Media Player 1.2.4 or newer are mandatory updates

Chris CChris C Posts: 11,795 Plex Employee

Unlike most updates, Plex Media Server 1.5.1 and Plex Media Player 1.2.4 or newer are mandatory updates. To continue working properly with Plex's integrated cloud services, users will need to upgrade to the latest version (always available on our Downloads page). Plex always tries to avoid making changes that require a mandatory update like this, but occasionally this sort of thing is necessary.

While existing installations of older versions (prior to Plex Media Server 1.5.1) will continue to work in most cases, users are likely to encounter issues when playing new media files or playing on new devices. For this reason, we strongly encourage users on old versions to upgrade their Plex Media Server installation as soon as possible.

Sign In or Register to comment.