If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Port 80 in use by windows ? [FIX]

mail@tomramakers.nlmail@tomramakers.nl Posts: 4Members ✭✭

Hello,

After using plex several years now, i love it...

It worked perfect, still an old plexconnect version but stable.

After the update to windows 10, used win7, plex connect wont start up due to port 80 being used.
With netstat and task manager, found out that the kernel is using it... i dont use other webservers etc.

https://www.dropbox.com/s/38wf5s99p8efwlh/PlexConnect.log?dl=0

I even disabled anti virus, windows firewall etc.

cant get it to work..

pms - 0.9.12.4 1192-9a47d21
windows 10 64 bit

I7 3770K
16Gb

Best Answers

Answers

  • mail@tomramakers.nlmail@tomramakers.nl Posts: 4Members ✭✭

    Here is an image om the taskmanager and netstat

  • mail@tomramakers.nlmail@tomramakers.nl Posts: 4Members ✭✭

    I Disabled this service and plex connect started up!

    Now gonna find out if it can be stopped permanantly.

  • mail@tomramakers.nlmail@tomramakers.nl Posts: 4Members ✭✭

    @dkcp said:
    Just set it to disabled and it won't start. If you wont be using it you can uninstall it.

    Already did it, hadnt had the time to post a reply.!

  • DivvyDivvy Posts: 60Members ✭✭

    Thank you for the solution :D

  • niceblokenicebloke Posts: 3Members, Plex Pass Plex Pass

    Just adding that this worked for me too. Now to find out what that service does and if I'll ever need it :)

  • GTUKIEGTUKIE Posts: 9Members, Plex Pass ✭✭

    This fixes the port 80 errors for me too. Can anyone comment on what setting the World Wide Web Publishing service to disabled is likely to affect (other than fixing Plexconnect). What might not work if this is disabled?

  • wahlman.jwahlman.j Posts: 2,564Members, Plex Pass Plex Pass
    edited September 2015

    Hosting a website or web server. There may be workarounds with reverse proxies etc.

    OSX apps : OpenPlex // UAS installer OpenPlex by Wahlman.j (Source Code), CyberGhost84 (GUI) & Flipman6 (Obj-C)

    iOS Firmware links: Firmware // Firmware Limits OpenPlex app or assistance. Donations appreciated US-$ // EUR

    Click my username and message me if you need Teamviewergif <----Install this for assistance.

    (1) Locally owned PMS Mac 10.9.5 i7-4770k haswell 32gb 1866 ddr3 with e-sata rocket raid 2302 Raid-5 set of (4) 5TB HD (15TB usable) in a 10-bay DAGE1040BL (2) Jailbroken aTV2's on iOS 5.3 (6.1.4) (portable PlexConnect host's) (9) aTV3's on mixed iOS (1) iPad 3, (1) iPad mini 2 retina, (4) iPhone 4s, all jailbroken on 8.1.1 all running latest official Plex for iOS & PlexConnect for iOS. Airbubble.apk (265 initial buffer frames) for android devices or airfloat for iOS devices to airplay aTV audio to Sol Republic Tracks HD V10.

  • ceeveeceevee Posts: 5Members ✭✭

    Thank you for this. PlexConnect was running okay for a long time. Then it stopped working. I did not know that World Wide Web Publishing Service was running, and I don't know what caused it to start running.

    Disabled World Wide Web Publishing Service and now it works like it was for a long time.

  • ScrumpyminisScrumpyminis Posts: 4Members, Plex Pass Plex Pass

    Just wanted to add - thanks for this - saved me before the last time Windows 10 was fresh install on my previously win 7 laptop running pms and plex connect. Just had a new windows update that was installed this morning automatically and guess what - no plex connect running today - but was fine yesterday. Hopefully this is the solution.

    I had previously disabled the world wide web publishing service and was working fine, even went so far as to delete the service completely. - Since the windows update last night - it's reappear (grrrrrr - Microstuft)

  • ndkjni2ndkjni2 Posts: 4Members ✭✭

    How do i find the World Wide Web Publishing-service?
    I can't find it. Could it be because i ave a danish Win10?

  • Visor4Visor4 Posts: 4Members ✭✭

    Stopping the World Wide Web Publishing service didn't fix the problem for me. However, after more Googling I found a fix that did work:

    Locate your PlexConnect installation folder (default is 'PlexConnect-master' under C:\Program Files (x86)\ if using 64-bit Win10) and grant Full Control permissions to the 'Everyone' group. Might be a bit of overkill but it worked for me. :)

  • chyron8472chyron8472 Posts: 258Members, Plex Pass Plex Pass
    edited May 2016

    @ndkjni2 said:
    How do i find the World Wide Web Publishing-service?
    I can't find it. Could it be because i ave a danish Win10?

    Click the Start button, type: services.msc and hit Enter.

    Right-click World Wide Web Publishing Service.
    Click Properties
    Click the button labeled Stop.
    Click the drop down box next to Startup Type (probably says Automatic or Manual), and change it to Disabled.
    Click OK.

    I was having trouble getting PlexConnect to work on my Dad's media server and doing this fixed it.

  • Just a heads up: in my case quitting Skype solved the issue (both port 80 and 443 were unavailable). Cheers

Sign In or Register to comment.