Port 80 in use by windows ? [FIX]

plexconnect

#1

Hello,

After using plex several years now, i love it...

It worked perfect, still an old plexconnect version but stable.

After the update to windows 10, used win7, plex connect wont start up due to port 80 being used.
With netstat and task manager, found out that the kernel is using it... i dont use other webservers etc.

https://www.dropbox.com/s/38wf5s99p8efwlh/PlexConnect.log?dl=0

I even disabled anti virus, windows firewall etc.

cant get it to work..

pms - 0.9.12.4 1192-9a47d21
windows 10 64 bit

I7 3770K
16Gb


#2

Here is an image om the taskmanager and netstat


#3

I Disabled this service and plex connect started up!

Now gonna find out if it can be stopped permanantly.


#4

@mail@tomramakers.nl said:

I Disabled this service and plex connect started up!

Now gonna find out if it can be stopped permanantly.

Just set it to disabled and it won’t start. If you wont be using it you can uninstall it.


#5

Thank god for this solution! Been pulling my hair for days now and I've searched every corner of the web.

THANKS! :D ^:)^


#6

@dkcp said:
Just set it to disabled and it won't start. If you wont be using it you can uninstall it.

Already did it, hadnt had the time to post a reply.!


#7

Thank you for the solution :D


#8

Just adding that this worked for me too. Now to find out what that service does and if I'll ever need it :)


#9

This fixes the port 80 errors for me too. Can anyone comment on what setting the World Wide Web Publishing service to disabled is likely to affect (other than fixing Plexconnect). What might not work if this is disabled?


#10

Hosting a website or web server. There may be workarounds with reverse proxies etc.


#11

Thank you for this. PlexConnect was running okay for a long time. Then it stopped working. I did not know that World Wide Web Publishing Service was running, and I don't know what caused it to start running.

Disabled World Wide Web Publishing Service and now it works like it was for a long time.


#12

Just wanted to add - thanks for this - saved me before the last time Windows 10 was fresh install on my previously win 7 laptop running pms and plex connect. Just had a new windows update that was installed this morning automatically and guess what - no plex connect running today - but was fine yesterday. Hopefully this is the solution.

I had previously disabled the world wide web publishing service and was working fine, even went so far as to delete the service completely. - Since the windows update last night - it's reappear (grrrrrr - Microstuft)


#13

How do i find the World Wide Web Publishing-service?
I can't find it. Could it be because i ave a danish Win10?


#14

Stopping the World Wide Web Publishing service didn't fix the problem for me. However, after more Googling I found a fix that did work:

Locate your PlexConnect installation folder (default is 'PlexConnect-master' under C:\Program Files (x86)\ if using 64-bit Win10) and grant Full Control permissions to the 'Everyone' group. Might be a bit of overkill but it worked for me. :)


#15

@ndkjni2 said:
How do i find the World Wide Web Publishing-service?
I can't find it. Could it be because i ave a danish Win10?

Click the Start button, type: services.msc and hit Enter.

Right-click World Wide Web Publishing Service.
Click Properties
Click the button labeled Stop.
Click the drop down box next to Startup Type (probably says Automatic or Manual), and change it to Disabled.
Click OK.

I was having trouble getting PlexConnect to work on my Dad's media server and doing this fixed it.


#16

Just a heads up: in my case quitting Skype solved the issue (both port 80 and 443 were unavailable). Cheers