Can't update Plex Server any longer

server-raspberry-pi

#1

I'm not sure if this has happened since I upgrade Raspbian from Jessie to Stretch - thought I'd done a Plex update since then.

However, whenever I run apt-get update I now get the following regarding the dev2day...

Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Ign:2 https://dev2day.de/pms stretch InRelease
Err:3 https://dev2day.de/pms stretch Release

Hit:4 http://archive.raspberrypi.org/debian stretch InRelease
Reading package lists... Done
E: The repository 'https://dev2day.de/pms stretch Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Anyone point me to what's gone wrong?

Tom


#2

I suppose you have been temporarily banned from my server for excessive HTTP requests. Just try again in 2 hours :slight_smile:


#3

@uglymagoo said:
I suppose you have been temporarily banned from my server for excessive HTTP requests. Just try again in 2 hours :slight_smile:

I don’t think it’s that as it’s been doing it for a few weeks. I can run the apt-get update having not touched the Pi in 3 weeks and that the above is the response I get back on the first attempt.

Tom


#4

Please post the contents of /etc/apt/sources.list.d/pms.list and also try to manually download the InRelease file from your Pi to make sure your network and dns settings are OK, e.g. wget https://dev2day.de/pms/dists/stretch/InRelease. And did you import my repo key correctly? See Plex Installation.

The repo itself is operational. I just checked again and tested everything on my Pi.


#5

uglymagoo

The result of trying to get the key again is:
root@raspberrypiHDD:/home/pi# wget -O - https://dev2day.de/pms/dev2day-pms.gpg.key | apt-key add -
–2018-04-23 12:56:23-- https://dev2day.de/pms/dev2day-pms.gpg.key
Resolving dev2day.de (dev2day.de)… 2a01:4f8:200:502e::2, 144.76.172.47
Connecting to dev2day.de (dev2day.de)|2a01:4f8:200:502e::2|:443… connected.
ERROR: The certificate of ‘dev2day.de’ is not trusted.
ERROR: The certificate of ‘dev2day.de’ hasn’t got a known issuer.
gpg: no valid OpenPGP data found.

The contents of pms.list is:
deb https://dev2day.de/pms/ stretch main

Previously I have been able to connect, it is installed after all. I am beginning to think that whilst the upgrade from Jessie to Stretch appeared to work fine, it maybe hasn’t after all.

I’ve just connected to another Pi on the same network and the request for the key is working there.

Tom


#6

Please re-install the package ca-certificates

sudo apt-get install --reinstall ca-certificates


#7

You’re a genius! :slight_smile:

Out of interest, I’m guessing it’s the lines about cert not trusted, but how did you figure it needed ca-certificates reinstalling?

Tom


#8

This package contains all the certificates of the certificate authorities, that are trusted by Debian. Take a look at the contents of this package with dpkg -L ca-certificates. This package was damaged, i.e. your local installation was unable to validate that the certificate of dev2day.de was issued by a trusted authority. So it assumed, the server presenting itself as dev2day.de is really a malicious third party. By reinstalling the package, you have restored the ability to check the validity of the certificate of dev2day.de :slight_smile:

And this problem is quite common here in the forum :smiley: