Direct Play on RasPlex causing bufferring and stuttering

rasplex

#1

Hi all,

I've just installed RasPlex on a Pi2 1Gb (so it's the latest version 1.8.0)

I've used plex server on a local Linux box for some years (that too is up to date) and I have iOS clients and Amazon Firestick client. All working, no problems.

I find the Firestick client sometimes problematic. It's mostly fine but just occasionally it can't keep up with playback. There's a slight stutter before it carries on ok. Obviously this uses Wifi as there is no ethernet on this device. In the settings, the "Local Network" bandwidth is set to 20Mbps.

So I thought that I might fire up the old Raspberry (which has ethernet of course) on my gigabit LAN and put the whole bandwidth business to bed. However, once set up, i find all movies buffer immediately, play for a couple of seconds, buffer again, and so on. The setup is "Direct Play", but even when I set it as low as 1Mbps I get the same thing. The only way I can get anything to work smoothly is to turn on "Force Transcoding"...which, to my mind, kinda defeats the object of direct play.

So, if my Wifi firestick is working, is there anything obvious I should be looking at why my ethernet should not be?
(Of course, I can play these movies directly over the network on a PC just fine with, say, VLC).

Thanks
S.


#2

Hi squawk

Sounds like rasplex is trying to reproduce something that a raspberry doesnt support natively
please paste the movie file info so i can have a look at the codecs and bitrate used


#3

Hi,

Thanks for the response. Media info attached.

Cheers,
S.


#4

I was hoping to find you were using an unsupported format that forced rasplex to use software rendered or a buffering problem but it all seems ok

you could be hitting a buffer limit, try increasing it and disabling ffmpeg avio in the advance video preferences
you can also try omxplayer hardware acceleration as mmal can be sometimes choppy

also stupid as it is a slow sd card can result on constant buffering


#5

Hi again,

Many thanks for spending time one this. Very much appreciated.

However, sadly, I don’t think we have made any headway. I tried the below (individually, not together).

  1. Not sure where the buffer you speak of is. I have increased Cache from default 5% to 20%. No difference.
  2. Disabled FFMPEG AVIO…the movie would not move forwards at all…just a freeze frame.
  3. By default both OMXPLAYER and MMAL are both checked. I unchecked MMAL. No difference.
  4. The SD is a Class 10 (10 MB/s minimum write speed). Alas I don’t have any faster ones to test with but I would have thought this should be fine.

A couple of other points I’ve discovered:

  1. I’ve changed my network cable (just in case). No difference.
  2. I’ve tried a bunch of other movies…NO PROBLEMS! Huh? Even 1080p AC3 5.1. Now, frankly that’s just odd.

Thanks
S.


#6

So strange

did you check the logfiles between both files to see if any error is reported?


#7

Did you buy the licenses that you need?? I had the same issue until I loaded the licenses.

http://www.raspberrypi.com/license-keys/


#8

he shouldnt need it for that particular file
it looks like a normal x264 + acc file


#9

Hey guys,

Thanks for the continued responses. Sorry, I haven’t been on here for a couple of weeks.

I’ve been using Plex on Pi since I reported this and with no problems at all. I was unfortunate in that the problem was/is with just that one file (or at least, that one file so far). It was an incredible coincidence that that was the first file we started watching after installation! Everything else has been totally fine. So maybe I’ll just recode it and see if that sorts it.

There is nothing non-standard about my installation, network, nas, pi or plex…so if no-one else is having trouble, it would seem to point to the file or files. That’s my logic anyway :slight_smile:

Cheers,
S.