Disabling TLS 1.0 support for plex.tv

service-announcements

#1

What's happening?

Starting today, we're no longer supporting TLS 1.0 for our plex.tv domain and instead require TLS 1.1 or newer for secure connections. For the vast majority of users, this will have no effect on you at all. Nothing will change. For a small number of Android users, this could potentially affect you.

Am I affected?

Android OS versions older than 5.0 (Lollipop) don't support TLS 1.1 or newer, unfortunately. That means that without action, users on those devices with those older Android OS versions would no longer be able to sign in to their Plex account or otherwise access plex.tv services.

Oh, no, I'm affected! What can I do?!?

Thankfully, all you need to do is make sure that you've updated the Plex app on your Android device. Specifically, you need to be running Plex for Android version 4.23.3.552 or newer (which has already been available on Google Play and Amazon for over a week). That's it!


Can't play any media in Plex Media Player with secure connection