DS112j - Do I really need transcoding?

server-synology

#1

Hey guys,

I have a synology DS112j from which I run my PMS (because the other device doesn't even support plex), the NAS is also used as network drive for photo and file sharing. Meanwhile I have another NAS that handles all the media files and downloading. Those files are then mounted onto the DS112j in order for plex to be able to access them.

This all works fine untill the PMS decides that a file requires transcoding. My question is why?
As soon as a file 'needs' transcoding I get: “This server is not powerful enough to convert video”

I know the CPU in de DS112j is really bad if not incapable of transcoding, but I don't get why transcoding is required in the first place. I used to stream my content from the NAS using a network drive with VLC, which worked fine, so I don't see why plex cannot do this aswell.

Is there any way to get around this problem, by using a different video player for example? If not would building a custom PMS device be a good solution dedicated to transcoding the files only?


#2

depends pretty much on your (Plex) client. for most of the time the Plex client on my Sony Android TV believed (got told) it cannot deal with certain formats (apparently the TV was capable of those but Android didn't have them enabled for apps). based on what the client feels capable of, it'll tell the server to transcode or not.

you can help by e.g. verifying that your server / client are configured to play in original quality whenever possible (at least in your home network). also mind the restrictions of your clients which might restrict original playback.

when you're 100% sure your TV/device can handle the video you could try accessing it via DLNA in your local network -- in most cases this will result in a "direct play"-like playback (at the risk of not playing at all if anything about the media isn't supported by the device.

On my Android TV there's been a major upgrade of the video player used by Plex some days ago which has resolved this issue pretty much for me (no more transcoding with DTS audio, smooth playback of 1080p content -- just some minor struggles left with playback of subtitles)


#3

Thanks for your reply. I figured out what the problem was. I was importing a lot of epsiodes from my old setup and it turns out plex can only play the file when all the metadata for that file has been downloaded. Because it was taking a while to process all the new files I was unable to watch some of the content. However now that it has finished downloading all the metadata everything works fine.