error creating certificate

plexconnect

#1

I downloaded OpenSSL and I am following these instructions: https://github.com/iBaa/PlexConnect/wiki/Install-Guide-Windows-Certificates but I cannot get past the first step.

Here's what outputs:

C:>OpenSSL-Win32\bin\openssl.exe req -new -nodes -newkey rsa:2048 -out C: railers.pem -keyout C: railers.key -x509 -days 7300 -subj "/C=US/CN=trailers.apple.com" -config
req [options] outfile
where options are
-inform arg input format - DER or PEM
-outform arg output format - DER or PEM
-in arg input file
-out arg output file
-text text form of request
-pubkey output public key
-noout do not output REQ
-verify verify signature on REQ
-modulus RSA modulus
-nodes don't encrypt the output key
-engine e use engine e, possibly a hardware device
-subject output the request's subject
-passin private key password source
-key file use the private key contained in file
-keyform arg key file format
-keyout arg file to send the key to
-rand file;file;...
load the file (or the files in the directory) into
the random number generator
-newkey rsa:bits generate a new RSA key of 'bits' in size
-newkey dsa:file generate a new DSA key, parameters taken from CA in 'file'
-newkey ec:file generate a new EC key, parameters taken from CA in 'file'
-[digest] Digest to sign with (md5, sha1, md2, mdc2, md4)
-config file request template file.
-subj arg set or modify request subject
-multivalue-rdn enable support for multivalued RDNs
-new new request.
-batch do not ask anything during request generation
-x509 output a x509 structure instead of a cert. req.
-days number of days a certificate generated by -x509 is valid for.
-set_serial serial number to use for a certificate generated by -x509.
-newhdr output "NEW" in the header lines
-asn1-kludge Output the 'request' in a format that is wrong but some CA's
have been reported as requiring
-extensions .. specify certificate extension section (override value in config file)
-reqexts .. specify request extension section (override value in config file)
-utf8 input characters are UTF8 (default ASCII)
-nameopt arg - various certificate name options
-reqopt arg - various request text options

It's like it doesn't like the command syntax but I don't know enough about the OpenSSL command to know what needs to be changed... thanks in advance for your help!


#2

Nevermind! I figured it out! haha. simple mistake.,


#3

When I did it it seemed fairly automatic... I had to reinstall my certs once, after I reset my ATV3. But that was just a matter of copying it back in with the iPhone Config Utility, I had saved my cert in my Plexconnect Folder.

I don't remember those args when I created mine, seemed simpler. I had openssl already installed so I was somewhat familiar with using it. Did you follow the installation tutorials? Sometimes they link out to other pages, and a step could be missed by not noticing a link. Happened to me during my initial setup. I had to repeat the steps when I moved my Plex server to a Windows 7 machine. Once you've done it a couple of times, it's old hat.


#4

I get the exact same error as described in the first post of this thread. But - since it doesn’t say what the simple mistake actually was, I can not correct it my self… :slight_smile:
Anyone care to point me in the right direction ? :slight_smile:


#5

Mind you, this is on a Mac Mini 4.1 on Mac OS High Sierra


#6

For Mac the recommended way to install PlexConnect is using OpenPlex. It will automate several tasks, including cert generation.


#7

Ok, thanks!
I´ll have a look at that instead then.


#8

I downloaded the three scripts and then ran the installer that became available. Two buttons - ´Install´and ´Exit´ for Open Plex became available. I pressed the obvious install - and waited. It says to be patient on the installer window and also in the guide.
I waited about 40 mins now. Is that patient enough…? :slight_smile:
Or, does it take longer?
No further dialog box has become available.


#9

Ok. 24h - now I’m closing the install. :smile:


#10

I’m trying to reinstall it and saw the note at the bottom:
PLEASE NOTE - The OpenPlex Installer is currently not working…
And they explain how to proceed.


#11

Yes, I saw the same note, and went on to do as recommended to work around this. But as you can see from my other post - that doesn’t seem to work either. Be glad to get OpenPlex to run :smile: