Install IPTV on PMS for Qnap

server-qnap

#1

Hello all,

I want to stream IPTV from Plex, Media Server installed on my Qnap TS253-A from a M3U playlist.
I have downloaded this plugin:https://github.com/Cigaras/IPTV.bundle and added my channels.

The problem is: I cannot find the correct directory on my Qnap. I tried through my Qnap interface, through FTP with Filezila, with SSH...And I did not succeed...

Under Filezila, I have the same repertories than with my QTS interface.
With SSH (terminal with Mac), I cannot find the correct directory....

Could you please help ?

Thank you,
Kevin.


#2

You’re looking for this guide. It explains the Plex install location for each environment, including QNAP.

TL;DR:

  • Run getcfg -f /etc/config/qpkg.conf PlexMediaServer Install_path
  • Whatever path you get back, append /Library/Plex Media Server/Plug-ins
  • Thats the folder to install plug-ins for plex manually

#3

OK great thanks a lot !

But once I am in the correct folder, how do I copy the file “.bundle” from my Mac to the folder ?

I tried this:
scp /‘MAC PATH’/IPTV.bundle admin@192.168.0.7:/share/CACHEDEV1_DATA/.qpkg/PlexMediaServer/Library/Plex\ Media\ Server/Plug-ins/

And I got this “scp ambiguous target”.
I tried to double backslashes, but I got “No such file or directory”


#4

Try putting it in quotes with the back slashes.

scp /'MAC PATH'/IPTV.bundle admin@192.168.0.7:"/share/CACHEDEV1_DATA/.qpkg/PlexMediaServer/Library/Plex\ Media\ Server/Plug-ins/"

#5

If the quotes don’t work, try copying it to anywhere on the device using the web UI; for example, the Web shared folder. Then ssh into the QNAP and move it (mv /share/Web/IPTV.bundle /share/CACHEDEV1_DATA ...)


#6

I tried with the quotes and it seems to resolve the “ambiguous” problem.

I got this answer “/Users/MyName/Downloads/IPTV.bundle not a regular file”.

(it was this command: scp /Users/MyName/Downloads/IPTV.bundle admin@192.168.0.7:"/share/CACHEDEV1_DATA/.qpkg/PlexMediaServer/Library/PlePlex\ Media\ Server/Plug-ins/")


#7

Oh, yeah the .bundle is actually a folder. Try adding the -r flag:

scp -r /Users/MyName/Downloads/IPTV.bundle admin@192.168.0.7:"/share/CACHEDEV1_DATA/.qpkg/PlexMediaServer/Library/PlePlex\ Media\ Server/Plug-ins/"

#8

Thanks a lot, it worked ! My .bundle is copied !

But it seems I still have a problem with my playlist.m3u, as when I launch a channel (.ts in the playlist file), it loads, then stops. I don’t know why…


#9

I don’t know either. I would probably need logs to find out.


#10

After it’s installed, I strongly suggest to take this conversation to the plugin’s support thread!