Locating Plex plugin folder on seagate personal cloud?

server-seagate

#1

Hello,
I have successfully installed plex on my personal cloud, however, I cant seem to locate any of its installed files in the ftp or file system at all. Does anyone know how to access these files so I can locate the plugin folder?
Thanks in advance.


#2

Where did you place these files? Plex Should per default be able to see files on the system as long as you navigate to them in the file seletion box. Do you have any special permission options set on your shares via the Seagate GUI?


#3

Same question here.would like to find out where the plug in folder is located,

Installed plex using app manager in Seagate personal cloud.


#4

I would like to know also love having plex on this nas just wish it was easier to access all the hidden files and folder


#5

Well, unfortunately there is no SSH access in Seagate Personal Cloud devices, so I found the only way to modify files on system level to upload the files as an app package.

So this is what I tried (all happened under Linux):
1. Downloading "Plex Media Server" app from plex.tv
2. Renaming to tar and extracting it
3. Extracting the "content.tar.gz" file
4. Adding the plugins I wanted to the ".\opt\plexmediaserver\Resources\Plug-ins-23623fb" directory
5. Using tar to archive and compress the "content" directory to "content.tar.gz"
6. Using tar to archive the whole directory to "com.plex.plexmediaserver-0.9.16.0.1754-23623fb-armv7.tar"
7. Renaming it to rwb and uploading to device

Unfortunately tho, for an unknown reason, device rejects the package. I tried a lot to make it similar and followed all directory structures in archiving and compressing. Still no luck.

Can developers point me in right direction here? I don't see any signing process nor I found any checksum at the start and the end of the tar file. So I am really out of ideas here. But I am sure you are familiar with the process of creating apps for NasOS as you release a special version for them from time to time.

Thanks


#6

Plex should add an 'Upload Channel' feature to the Web UI. That would solve this issue.


#7

any update here? I cannot get to the plug in folder either


#8

Fast forward. 2018. Still no answer. Wow.


#9

@SvenAndreas - Check the tutorial here: https://forums.plex.tv/discussion/276906/plug-ins-folder-tutorial