Plug-ins Folder Tutorial!

server-seagate

#1

I've been working on this for quite some time and finally got it working. It's a bit involved and requires some terminal use, but I can confirm I have WebTools working and it installs channels just fine. I haven't tested many and of course YMMV.

Part 1: Enable SSH access on your Seagate Personal Cloud (SPC):
1. Enter your device url in a browser with the following extension ?appdev=1. Example: http://192.168.1.100/?appdev=1
2. Select "Services" from the navigation bar to the left.
3. Second from the bottom should now show "SSH Access". Enable it.

Part 2: Find and enter your Plex Media Server Plug-ins folder:
1. Using your terminal, ssh into your SPC using your administrator (or first) account. Example: ssh username@192.168.1.100
2. You'll be asked for your normal password.
3. Go back one level from the default folder using this command: cd ..
4. My path to my plug-ins folder was this /media/internal_1/rainbow/plexmediaserver-x3op672.data/plex_conf/Library/Application Support/Plex Media Server/Plug-ins. I'm assuming yours will be somewhat similar. Remember to use quotes around folder names that have spaces within their names. Alternatively you can escape them.
5. @"dsorear@gmail.com" reported that the permissions on the "Plug-ins" folder needed to be changed using sudo chmod -i which, to my understanding, causes the "Plug-ins" folder to inherit the permissions of the containing folder.

Part 3: Get WebTools (or whatever bundle you want to install):
3. Type this command to install WebTools: sudo wget https://github.com/ukdtom/WebTools.bundle/releases/download/3.0.0/WebTools.bundle.zip
4. After it downloads, type this command: sudo unzip WebTools.bundle.zip
5. To clean up the leftover zip file, type this command: sudo rm WebTools.bundle.zip

Part 4: Restart your SPC and wait a long time for Plex to completely start.
Even after PMS was completely up and running, WebTools took a bit longer to show up under "Channels". You might have to wait, but it will eventually show.

That's it! I installed a few channels via WebTools and they seem to work. I'm sure there are ways to consolidate a few commands but I'm not very good with the terminal. Let me know how it works for you as I may have left a step out and I'll do my best to help.

Edit: I forgot to mention that I haven't updated my firmware that just came out. This works for now but may not with the updated firmware.

Edit 2: Added a possibly helpful step in Part 2.

Edit 3: Updated the firmware to 4.3.15.1. I can still access the Plug-ins directory.

Edit 4: Updated the firmware to 4.3.18.0. And updated the WebTools link to reflect version 3.0.0. It all works just fine.

Edit 5: Added step 5 to Part 2 to include a possible step.


#2

This post is now pinned.
Thanks for making it


#3

I must be missing something but when I follow the instructions, I get as far as part 2 step 3, when I type in cd … I get a message saying command not recognised. What am I doing wrong?


#4

@dracook Not sure what’s going wrong. The only thing I can think of is that you might not have left a space following the “cd”. Could you post a screenshot of your terminal?


#5

@MaestroJAL Hi there - I’m getting that it’s a read-only file system. The last line says “Cannot write to ‘Webtools.bundle.zip’ (Success).” Where am I going wrong? Thank you!


#6

@benlamoureux - Hmm. I’m not totally sure what’s wrong. Have you tried Step 5 of Part 2? If your folder cannot inherit permissions, you may have to simply assign them for the “Plug-ins” folder and/or Webtools. Let me know if it works. I’m not really that good with Terminal commands but I’ll try to help.


#7

Hi, do I terminal from my Mac for this? all I’m getting is no such file or directory on part 2 step 4


#8

Screenshot of my terminal on Mac


#9

@dannyscott63 - It looks like you’re using the example path from my tutorial but your actual path will be slightly different. Try going to the “rainbow” directory and look for your unique “plexmediaserver” folder. It will have a unique set of characters following it. Once you enter that directory, the rest of the tutorial will work. Let me know how you make out.


#10


Ive got this far but still getting the error of no such directory when I carry on.
Apologies, I have managed to get to the last step but now cannot open the zip


#11

@dannyscott63 - Ok, so your unique Plex directory is “plexmediaserver-c752000”. Enter that directory and continue with Part 3. If you can’t install WebTools in that directory, let me know. One step at a time, we’ll get it installed.


#12

I have worked through to “Application Support” and it won’t let me into that dir!

login as: xxxxxxxxx
xxxxxxxx@192.168.1.xx’s password:
Last login: Mon Apr 23 19:15:07 2018 from 192.168.1.xx
[xxxxxxxx@PersonalCloud ~]$ cd …
[xxxxxxxx@PersonalCloud /]$ cd media
[xxxxxxxx@PersonalCloud media]$ cd internal_1
[xxxxxxxx@PersonalCloud internal_1]$ cd rainbow
[xxxxxxxx@PersonalCloud rainbow]$ cd plexmediaserver-xxxxxxxx.data
[xxxxxxxx@PersonalCloud plexmediaserver-xxxxxxxx.data]$ cd plex_conf
[xxxxxxxx@PersonalCloud plex_conf]$ cd Library
[xxxxxxxx@PersonalCloud Library]$ cd Application Support
-bash: cd: Application: No such file or directory
[xxxxxxxx@PersonalCloud Library]$ ls
Application Support
[xxxxxxxx@PersonalCloud Library]$

Help


#13

Cracked it with ssh when you have spaces in a dir you need ‘ ‘

ie cd Application Support becomes cd ‘Application Support’

So as above line needs to become . /media/internal_1/rainbow/plexmediaserver-x3op672.data/plex_conf/Library/‘Application Support’/‘Plex Media Server’/Plug-ins


#14

@Starskyman - Glad you got it to work.


#15

Hi, I’m able to see the WebTools.bundle in the Plug-Ins folder and in the PMS PlugIns directory, but upon clicking the WebTools, it opens a new window that doesn’t do anything. Sometimes there are http/https urls and sometimes it says it’s not working. Any thoughts on why it’s not working?


#16

@Matador956 - WebTools takes awhile to start on these Seagate devices. Once it starts, the urls that you’re seeing are how you directly access the WebTools interface. Copy the url and paste it in your browser. It should then ask for your Plex credentials to continue. Let me know how it works out for you.


#17

#18

I really don’t want to appear stupid here, but I’ve tried every password under the sun for Part 2: Step 2. Which password are we talking? Seagate, Plex, my Windows log-in?! None work. Thanks.


#19

This login info should be the account/password you used when you first set up your Seagate Personal Cloud. Make sure you’re also accessing it with the right screen name. If you don’t, no password will work. Let me know if you still have problems.


#20

I can’t get this to work at all. After enabling SSH i’m in an endless loop. I type out SSH username@192.168.0.10 (replacing username with my username) and it loads right into my cloud like normal. I assuming this is not what it’s supposed to be.