No more Dolby Digital in ATV option in PMS / PlexConnect - Since update 1.5.3.3580

plexconnect

#1

Hi,
Since updating to 1.5.3.3580 of Plex yesterday, the fix does not work anymore for me. (fix : http://forums.plex.tv/discussion/241257/no-more-dolby-digital-in-atv-option-in-pms-plexconnect/p2?)

If I put tvOS, I have no sound at all. If I put back iOs, I'm back with Stereo sound only.

Anyone having the same issue?

THanks


#2

What I’ve found is that Plex changed the tvOS profile so that audio transcoding preference puts EAC3 ahead of AC3. I don’t think that the ATV3 supports EAC3 so, if you are transcoding, you probably have to modify the profile to remove EAC3 from the transcoding targets.


#3

well, I will need some help for that :slight_smile:

The only thing I have change from the default settings if put tvOS instead of iOS.

Not sure how to do the rest you are referring :slight_smile:


#4

Try the following:

  1. Locate your PMS data directory
  2. Create a new Profiles folder
  3. Download the attached file to the newly created Profiles folder
  4. Restart PMS so that it gets aware of the change
    Please test with the “tvOS fix” and let me know if this works.

#5

great! that’s working!

Thanks a lot


#6

Ace! Thank you this has worked for me also :smile:


#7

Great to hear that. But now I need your help. The above solution is not the perfect one and I need sample files to test an alternative. I will send you a PM with my e-mail so that you can send me the files where you had problems via WeTransfer.


#8

Stumbled on this thread in my search for the same problem.
Thanks for the ‘fix’ moody_blue, any update?

I will test the fix tonight, will update tomorrow.


#9

@kevnad @richu75 @dnisbet

Here is a new version of the patch, hopefully without the need to use the tvOS profile (that was designed for AppleTV4 and not AppleTV3). In PlexAPI.py you need to code the following:

xargs['X-Plex-Platform'] = 'iOS'
xargs['X-Plex-Client-Platform'] = 'iOS'
xargs['X-Plex-Client-Profile-Extra'] = 'append-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=ac3,mp3)'

The first two lines are the original ones (that you have changed in previous versions of the “fix” to mention tvOS)
The third line is a new line that you should insert in the PlexAPI.py code, immediatly following the other two

Can you please test it ? Seems Ok on my side, but before asking @roidy to apply it to the main code I would like to have other testers.


#10

Okay. Will remove the previous xml and add the code to the python script. The previous ‘fix’ of changing iOS to tvOS did result in loosing the audio in some of my videos.

Will report back in a few.


#11

It’s working superbly. The problematic videos all have sound now. The atv lists the audio tracks as DCA and AC3. I also tested an episode of top gear (ac3 stereo) and a home movie (aac 2.0).

I need to test the other atv that passes sound thru the HDMI port (the main one uses S/PDIF), but that’ll have to wait until morning. My daughter is asleep already.

But sofar, really helpfull. Thanks!


#12

Thanks. I think that the ATV can’t handle AC3 directly. It simply passes it to the output ports (HDMI and S/PDIF). If the equipment connected there doesn’t know how to handle it, probably it will have no sound.

In my own case I have the S/PDIF port connected to an a/v amplifier, HDMI to TV in mute, and:

  1. AC3 5.1 in Plex (and any transcoded 5.1 signal) is displayed in the amplifier as DOLBY D
  2. AC3 2.0 in Plex is displayed in the amplifier as PLII C
  3. AAC 2.0 in Plex (and any transcoded 2.0 signal) is displayed in the amplifier as STEREO

#13

Seems we have a similar setup. At least my living room setup is.

I tend not to notice to take notice of the media badges in Plex, only the sound format the aTV is reporting. But the A/V does a remarkable job of handling any format it’s fed.

But you made me thinking about the problem. My second setup is in the bedroom, which is another aTV but connected directly to a TV. Maybe the AC3 is causing the problems in that setup as the TV does not (is not able) handle AC3.

But this latest fix should remedy that problem as the iOS profile is still intact.


#14

In that 2nd TV you can disable Dolby Digital in the Apple TV settings and PMS hopefully will transcode audio to stereo


#15

There is a new PlexConnect version in github. After installing it you can remove the following temporary fix (only for those that have applied it):

@moody_blue said:

  1. Locate your PMS data directory
  2. Create a new Profiles folder
  3. Download the attached file to the newly created Profiles folder
  4. Restart PMS so that it gets aware of the change

#16

It’s only the X-Plex-Client-Profile-Extra line in PlexAPI.py right?
I also see a modified XMLConverter, but that just seems a cosmetic fix in the code.

Anyway, good to see roidy still pushing changes to the master branch.


#17

In fact there were 3 changes:

  1. the X-Plex-Client-Profile-Extra line in PlexAPI.py so that AC3 5.1 is transcoded correctly (previously AC3 5.1 was handled correctly only in DirectPlay situations)
  2. Photo rotation: previously you needed to specify in the ATV (PlexConnect settings) to transcode all photos in order to assure that photos were rotated. Now you can use “Photo Transcoder Action = Auto” and PMS will only transcode photos needing rotation. This is a minor improvement, but should help with slow servers. This change was requested years ago by bjornhusberg but was not implemented in the base code until now
  3. For audiophiles that rip vinil discs to ALAC you can end-up with very high bitrates. PlexConnect requested transcoding when bitrate>2M. This limitation has been removed

#18

Well, I’ve run into a problem.

Whenever I need surround sound (on the primairy aTV), I need to edit the PlexAPI and either replace the iOS with tvOS or add your Client-Profile-Extra. But when I do this the second aTV will not play media anymore.

On the second aTV I have a working connection, I can browse libraries and select media and even subs and audiotracks within those videos. But when I select play I only shows the very first frame of that video.

I can see PMS converting the file, cpu usage is consistent with a file being played. Also I can skip ahead in the video (aTV remote for iPhone lets me skip 10 seconds at a time) and then then the TV displays that one frame. But no video playback.

Once I restore the original PlexAPI (with ‘iOS’) script the video displays without any problem.

Any idea? I could build a second PMS/PlexConnect for stereo only and mount the same CIFS shares, but that seems overdone.


#19

Have you disabled Dolby Digital in the 2nd ATV (ATV Audio settings) ? This will have two effects:

  1. For videos that DirectPlay, the 5.1 audio tracks will be invisible
  2. For videos that transcode, audio tracks will be transcoded to MP3, and the ATV will convert it to Stereo

Also you may try the Client-Profile-Extra but, in the end, replace “audioCodec=ac3,mp3” with “audioCodec=ac3,aac”

On rare occasions (it happens to me twice a year) you may have to restore the ATV, parametrize for PlexConnect and reload certificates.


#20

I’ve restored to factory defaults and reloaded the certificate. DD was off in settings.

Seems unrelated to the sound settings, but will try your suggestion. Strangest thing is to see the PMS server trans-coding, I even see the buffer filling on the time line. But I doesn’t play the video.