Plexamp stopped working from Windows 10 machine


#1

I’ve been using Plexamp at work to stream my music collection from home and it’s been awesome! However, recently, I think since the last Plex server update (Version 1.13.1.5063), it has stopped working. I’ve reinstalled and get the same behavior afterwards. Any help would be appreciated. FYI, I have tried Plexamp from my Mac Mini at home and it works fine.


#2

same issue, windows 10, plexamp version 1.0.5


#3

I’ve got the same thing on Linux as of yesterday. Server version 1.13.0.5023, Plexamp version 1.0.5.

Running from terminal shows this:

...
warn: DEVICE: Cannot initialize, no token.
info: [MPD] Started, now we will connect
info: [MPD] Connecting...

Eventually the connection attempt times out.


#4

Ok it seems the above MPD problem was a one-off. Output now stops at

debug: DEVICE: Persisting devices.

With no output when trying to play a song, and just a blank screen like above.

I am however getting ECONNECTIONREFUSED on the player on port 36000


#5

I’ve had an issue like this before on my Windows machines, and I could only fix it by uninstalling the app and then deleting the folder in:
C:\Users\<USER>\AppData\Local\Plexamp

Hope this helps?


#6

@lloyd094 said:
I’ve had an issue like this before on my Windows machines, and I could only fix it by uninstalling the app and then deleting the folder in:
C:\Users\<USER>\AppData\Local\Plexamp

Hope this helps?

Thanks! That worked.


#7

Just tried this on Linux, has not helped. MPD just gets stuck connecting still.


#8

Same issue, deleting local files and reinstalling the app fixes it (could it be a cache issue?). Need to investigate further next time it happens.


#9

Seconded. In my scenario I only needed to delete the folder rather than reinstall the app, and it was working all new.

It’s quite a serious issue as it happened today when I tried connecting from another plex web client to plexamp, which first broke the visualiser (it got stuck on the ‘music tattoo’ one) as I was unable to change it. Disconnecting and playing local files worked fine, however the visualiser would not change, not via keyboard shortcut or menu. After restarting plexamp I was greeted with a blank screen, yet it resumed music playback grom last time. Media keys were unresponsive. Signed out via the tray icon, but MPD still resumed playing the track after closing and re-opening plexamp while still being signed out.


#10

Deleting the application folder worked for me as well. (Win 10)