Plexconnect "Accessing Trailers" issue only with CyberGhost84's "revenant" Theme

plexconnect

#1

I started having issues with using Plex recently. I access a PMS (v 3.14.1) hijacking the "trailers" app on an ATV3 and ATV2 using CyberGhost84's "revenant" Theme.

Plex opens on the ATV, but it is stuck on "Accessing Library" when I try to view my media (e.g. Discover).

If I change to a different theme, iBaa, Falco953, Stoffez, Wahlman.js, it works without a problem.

I see from the OpenPlex dashboard that it says that PIL\Pillow needs to be installed properly. I haven't made any changes and it USED to work properly, so I don't know why it stopped working.

I have started a fresh install of plexconnect, including PIL \ Pillow as well as all the settings, but still the same issue.

PMS/Plexconnect hosted on: 192.168.2.100
PMS Version: 3.14.1

PMS - Custom Server Access URLs: 192.168.2.100

PMS - List of IP addresses and networks that are allowed without auth: 192.168.2.101,192.168.2.102,192.168.2.103

I am logged into the same myplex account on PMS and on atv

Settings.cfg

[PlexConnect]
enable_plexgdm = True
ip_pms = 192.168.178.10
port_pms = 32400
enable_dnsserver = True
port_dnsserver = 53
ip_dnsmaster = 8.8.8.8
prevent_atv_update = True
intercept_atv_icon = True
icon = com.apple.imovietheatre.appletv
enable_plexconnect_autodetect = True
ip_plexconnect = 0.0.0.0
hosttointercept = trailers.apple.com
port_webserver = 80
enable_webserver_ssl = True
port_ssl = 443
certfile = ./assets/certificates/trailers.pem
allow_gzip_atv = False
allow_gzip_pmslocal = False
allow_gzip_pmsremote = True
loglevel = Normal
logpath = .

PlexConnect.log (restart, accessed plex on appletv 3, ip 192.168.2.103)

13:30:05 PlexConnect: started: 13:30:05
13:30:05 PlexConnect: Version: 0.6-RevenantDev-06112017
13:30:05 PlexConnect: Python: 2.7.11 (v2.7.11:6d1b6a68f775, Dec  5 2015, 12:54:16) 
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)]
13:30:05 PlexConnect: Host OS: darwin
13:30:05 PlexConnect: Fanart Support: PIL installed? True
13:30:05 PlexConnect: IP_self: 192.168.2.100
13:30:06 DNSServer: started: 13:30:06
13:30:06 DNSServer: ***
13:30:06 DNSServer: DNSServer: Serving DNS on 192.168.2.100 port 53.
13:30:06 DNSServer: ***
13:30:06 WebServer: started: 13:30:06
13:30:06 WebServer: ***
13:30:06 WebServer: WebServer: Serving HTTP on 192.168.2.100 port 80.
13:30:06 WebServer: ***
13:30:06 WebServer: started: 13:30:06
13:30:06 WebServer: ***
13:30:06 WebServer: WebServer: Serving HTTPS on 192.168.2.100 port 443.
13:30:06 WebServer: ***
13:35:13 PlexAPI: ***
13:35:13 PlexAPI: poke plex.tv - request Plex Media Server list
13:35:13 PlexAPI: ***
13:35:14 PlexAPI: poke LOTUSCreative iMac.OG (471c476cbe3b1dc8d38ae2799a79448254e9de5e) at https://192-168-2-100.4825cf52770e4e44933bbce96dbff8ba.plex.direct:32400
13:35:15 PlexAPI: response LOTUSCreative iMac.OG (471c476cbe3b1dc8d38ae2799a79448254e9de5e) at https://192-168-2-100.4825cf52770e4e44933bbce96dbff8ba.plex.direct:32400
13:35:15 PlexAPI: Servers (local, plex.tv, MyPlex): 2

#2

Anyone lend some help on this?


#3

Looks like pillow is installed, can you access the settings tab from within PlexConnect and try different views using his theme? Something probably is preventing it from working in there, try list view and then figure out which one is the culprit.


#4

Thanks for the feedback. Ended up installing the theme again and voila! it worked all of a sudden. even retained all the preference/settings. Not sure why it suddenly worked, and wish I could leave feedback for anyone that has or may have this problem in the future. For the record, I did install each and every one of the alternate themes and CyberGhost84's "revenant" theme in the hopes that something would catch. Not sure why it did this time.