QNAP TS-451 - Plex VERY Slow

server-qnap

#1

I just purchased a TS-451. I'm running 4 x 4TB HDD's RAID5. I have about 3.5 TB's of video. Everything is loaded and Plex libaries are fully updated. However streaming local AND over the internet is VERY slow. I only have a few days to return this NAS and either need to come up with a solution or go back to hosting on my PC. Any ideas on what to check? I'm desperate. I checked my QNAP and the processes and RAM utlization are very very low. QNAP only using less than 40-30% of RAM and less than 20% of processor. I had Plex previously on a server and the server was like 4x faster.


#2

This QNAP’s entire purpose is Plex and file server. Also when my friends view my QNAP on Plex they get this error:

Playback Error: Shaka1001 (Network)

Please please help!


#3

I would make sure the index file creation is disabled and restart Plex to make sure it is not busy doing that. They can be found on the server settings -> Library page.


#4

I have the QNAP TS-451+ NAS and was happily using it for a long time with my 1080p MKV BluRay rips and various other media items (It was only able to keep up once the hardware transcoding support utilizing the Intel instruction set extensions was added into PLEX - THANK YOU!!). My NAS is connected by hardwired gigabit ethernet to most devices in my home, and I was able to stream to Xbox One consoles, iOS devices over wireless and Chrome browser clients with quick streaming starts, and no buffering / delays while watching. I was also able to watch over LTE from an iPhone away from home without a problem.

Just a couple days ago I was trying to watch some movies after not doing so for a couple months, and now, starting a movie takes a long time, and I hit buffering spinners every couple minutes it seems like. The experience is totally unusable for me now :frowning:

I’m not sure what has changed! I’ve tried restarting my switches and external facing router, restarting all clients as well as the QNAP, and disabling every extraneous service on the QNAP I can find. When these glitches occur, the CPU and RAM monitor on the QNAP show very low utilization (< 10% CPU, < 30% RAM since I got the 8GB model).

I started to look over the logs a bit, but I thought I’d add on to this thread when searching a bit lead me to this post. The logs are rather intimidating, but I’m going to read through the analysis instructions I can find and see if I can narrow this down.

*Update
Forgot to mention - I’ve validated the network is still able to sustain the necessary throughput. Direct copy to PC of the same media file can hit over 100MByte/s (yes, ~800mbps). The QNAP app on iOS can stream the videos at native quality / no transcoding with no problems and a straight file copy can sustain 10MByte/s. Actually, that reminds me of one other thing I’m going to try - installing the codec pack on the QNAP again and trying the transcode process from within the QNAP app on the phone (there are options for picking a resolution and streaming rate when starting).


#5

@briankhud One common reason for this type of problem is a network change that makes PMS think that local clients are remote.

We can help identify the cause if you post logs (before doing that pls restart PMS and reproduce the problem, so that we can see the boot sequence).


#6

Does the 451 work well with multiple streams of 1080p?


#7

Single file copy should be 100MB/Sec not 10MB so may be picking up NW port as 100Mb not 1Gb.


#8

@mkstretch said:
Does the 451 work well with multiple streams of 1080p?

Yes it does, at least when it’s not transcoding right now.

Guys, it’s got to be down to the 4.3.4 update because i’ve been having issues with 1080p MKV’s since the update. before there were no problems. Ive tried just about everything, and i have about 3tb of media to transcode. Are you guys telling me there is no solution here? Yes handbrake but that’s through the goddamn hdmi port on the back and not all of us have a screen just lying around. Yes there is the embedded media managment but that will convert Windows ISO files to MP4. jesus.


#9

Well becoming a PlexPass subscriber will enable HW transcoding which will definitely improve performance.

QTS 4.3.x is NOT the cause of your performance issues. The J1800 in your box has a passmark of 1027 which is LOW.

All that being said, obviously switching to x64 bit code in QTS also required a change in Plex to support it as well.

One possible cause is that something changed in your Plex client where before you were using DirectPlay (streaming) to your Plex client and potentially now you are transcoding which the CPU w/o HW transcoding isn’t strong enough to handle.

The other possible cause is that something got screwed up someplace in your NW configuration/setup (assuming your are using DirectPlay - check server to verify) as you mentioned above in your low throughput and the low bandwidth is causing issues even with DirectPlay.