What is the default SSH user & password?

rasplex

#1

What is the default user and password for SSH when connecting to the RasPlex?

 

Also, should we disable the password - I tried that but still can't connect:

 

 

rasplex Version: 0.1.17
Permission denied (publickey,keyboard-interactive).

#2

username: plexuser

password: rasplex

If that doesn't work, it might be Openelec's default login. In that case, from memory it's:

username: root

password: openelec


#3

What is the default user and password for SSH when connecting to the RasPlex?

Also, should we disable the password - I tried that but still can't connect:

rasplex Version: 0.1.17
Permission denied (publickey,keyboard-interactive).

I don't know that disabling the password is a good idea.

We'll document this better on the wiki (which is launching officially tonight)


#4

I can login with:

username: root

password: admin


#5

The README says:

"Starting with OpenELEC 2.0, SSH is disabled by default but all that is needed is an empty “ssh_enable” file to exist in /storage/.config to enable it."


#6

SSH is enabled by default, username 'root' and password 'rasplex' 


#7

This does not work anymore.

EDIT: ssh-keygen -R [IP_ADDRESS] fixed everything.


#8

This does not work anymore.

I have to disagree.

I'm using RasPlex 9.9.20 and I logged in to its SSH server as user "root" with password "rasplex" less than a minute ago.

Best regards: dlanor


#9

so just to make sure the syntax is:

ssh ipaddress -l root

right?


#10

so just to make sure the syntax is:

ssh ipaddress -l root

right?

works for me, thanks...


#11

username: root

pw: rasplex

Just worked for me on a brand new installation of RasPlex 0.6.0 on an RPi 2 Model B.


#12

username: root
pw: rasplex
 
Just worked for me on a brand new installation of RasPlex 0.6.0 on an RPi 2 Model B.



Yeah! That's what it says at the top of the topic, i.e. 'Answered'!


#13

nope, nope, and nope. None of these passwords work. I have a Pi 3 (b) and the latest build 1.2


#14

@NVader2000 said:
nope, nope, and nope. None of these passwords work. I have a Pi 3 (b) and the latest build 1.2

If you have the latest 1.2 build you must be referring to PMP, not Rasplex/OpenPHT.
For Plex Media Player the username & password is (root & plex)


#15

Hello,
I had the same problem, it seems that with the current version of raspberry - libreelec - plexmediaplayer the ssh-keygen proccess doesn't finish when it configured the ssh.
The symptom is this response when you try to connec with SSH:
ssh root@192.168.10.164
ssh: connect to host 192.168.10.164 port 22: Connection refused

To solve this first you need to get access to a command line on the raspberrpi, the easiest way is to mount the SD in another computer and edit the cmdline.txt file adding textmode on the same line where ssh is found.
I saw that file when I mounted the SD on a Mac, when I tried on a windows it didn't work but might be my windows.

When you turn on the raspberry you'll see a commandline from there you can generate a new key but you should put it in the place it expects.

Execute:
systemctl status sshd
One of the lines will mention something about an error opening a file with a text similar to this:
/storage/.cache/ssh/ssh_host_ed25519_key
Write down this text somewhere ( the one that appears on your screen ) because you'll need it on the following step.
exit from the report pressing ESC : q
Execute:
ssh-keygen
when it asks for a file write the concrete text that we mentioned earlier
when it asks for a phasphrase just press enter
enter again
Now execute:
systemctl start sshd
And finally to check that everything goes well you can execute:
systemctl status sshd
It should say SUCCESS on the third line.
Now you can try to connect using the user root and the password plex

From here you can execute plexmediaplayer writting plexmediaplayer on the prommpt.
If you solved this problem you can mount again the SD and delete the word textmode to return to normal usage.


#16

@jordisala said:
Hello,
I had the same problem, it seems that with the current version of raspberry - libreelec - plexmediaplayer the ssh-keygen proccess doesn't finish when it configured the ssh.
The symptom is this response when you try to connec with SSH:
ssh root@192.168.10.164
ssh: connect to host 192.168.10.164 port 22: Connection refused

To solve this first you need to get access to a command line on the raspberrpi, the easiest way is to mount the SD in another computer and edit the cmdline.txt file adding textmode on the same line where ssh is found.
I saw that file when I mounted the SD on a Mac, when I tried on a windows it didn't work but might be my windows.

When you turn on the raspberry you'll see a commandline from there you can generate a new key but you should put it in the place it expects.

Execute:
systemctl status sshd
One of the lines will mention something about an error opening a file with a text similar to this:
/storage/.cache/ssh/ssh_host_ed25519_key
Write down this text somewhere ( the one that appears on your screen ) because you'll need it on the following step.
exit from the report pressing ESC : q
Execute:
ssh-keygen
when it asks for a file write the concrete text that we mentioned earlier
when it asks for a phasphrase just press enter
enter again
Now execute:
systemctl start sshd
And finally to check that everything goes well you can execute:
systemctl status sshd
It should say SUCCESS on the third line.
Now you can try to connect using the user root and the password plex

From here you can execute plexmediaplayer writting plexmediaplayer on the prommpt.
If you solved this problem you can mount again the SD and delete the word textmode to return to normal usage.

This belongs in the Plex Media Player subforum, not in Rasplex/OpenPHT. This is a different client.


#17

For The Official Plex Media Player Embedded. This was for the Raspberry PI

Username: root
Password: plex

Plex Media Player for Embedded Platforms
1.2.2.596-d1355001
December 21, 2016


#18

@TATUMTOT said:
For The Official Plex Media Player Embedded. This was for the Raspberry PI

Username: root
Password: plex

Plex Media Player for Embedded Platforms
1.2.2.596-d1355001
December 21, 2016

Your information may very well be correct for that particular software.
But this is NOT a subforum for the "Official Plex Media Player" aka "PMP"

This subforum deals ONLY with the third-party Plex client "RasPlex",
which is the Raspberry Pi implementation of "Open Plex Home Theater" aka "OpenPHT".

Correct SSH login for RasPlex is (as stated several times above):
Username: root
Password: rasplex

Best regards: dlanor