Why am I seeing stories in French with my location set in english speaking Canada?

news

#1

Just because I'm Canadian doesn't mean I'm bilingual. Can I manage sources or remove french news somehow? It's really the big issue stopping me from using the news feature at this point.


#2

I have the same issue with getting French news when I’m in English Canada.

Plex staff, can this be fixed?


#3

Decided to give this feature another look and this is super annoying for me as well. Probably 70% of the feed is French and from mostly one source. Why can’t we turn off specific sources?


#4

I ended up blocking those French sources. But, I shouldn’t have to do this as they shouldn’t appear in the first place.


#5

There should really be a language preference for news. I’m guessing it picks the languages you see based on the country?