If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[Fixed]TrueHD with Atmos not playing correctly.

ouldsmobileouldsmobile Posts: 16Members, Plex Pass Plex Pass
edited January 2016 in OpenPHT

Anyone else had any luck with Atmos videos? Now, I don't expect the Atmos part to work as I don't have any Atmos hardware but it should send out the TrueHD stream correctly. Kodi seems to be able to do it correctly on the video I tried, same everything, just bounced back and forth between Kodi and OpenPHT. I noticed some patches in the lib/ffmpeg/patches folder that refer to Atmos/TrueHD fixes, not sure if something needs to be done manually to apply them or if they get applied during the build. Just wondering if this is working for others or what. I am running on Arch Linux using the AUR pkgbuild 1.5.0.502-1. It's about the only issue I am currently experiencing, which will become worse once more movies will likely be including Atmos as it gains popularity.

Answers

  • dopefish3ddopefish3d Posts: 128Members, Plex Pass Plex Pass

    I have a few Atmos blurays (the new Mad Max!) i've ripped, and OpenPHT (on OSX) correctly decoded and output the audio as multichannel LPCM. OSX can't bitstream TrueHD so OpenPHT just converts it live.

  • ouldsmobileouldsmobile Posts: 16Members, Plex Pass Plex Pass

    I was trying to Bitstream actually. Maybe I will switch to LPCM for TrueHD content for the time being and see if that helps.

  • andrema2andrema2 Posts: 35Members, Plex Pass Plex Pass

    And to use the LPCM is just uncheck the DTS and Dolby capable receiver and let only the LPCM enable ?

    Thanks

  • ouldsmobileouldsmobile Posts: 16Members, Plex Pass Plex Pass

    @andrema2 said:
    And to use the LPCM is just uncheck the DTS and Dolby capable receiver and let only the LPCM enable ?

    Thanks

    Yes you just uncheck the ones you don't want to bitstream and then it should send out the LPCM signal instead.

  • andrema2andrema2 Posts: 35Members, Plex Pass Plex Pass

    Ok. In my case, I have a Denon X3200W receiver, although I did what you mentioned the information the receiver is receiving for sound is multi channel plus Dolby Digital for a DTS-HD when only LPCM is checked.

    If I check DTS and AC3, then the receiver shows DTS as input format.

    I'm doing something wrong or this is how it should work ?

    Thanks

  • ouldsmobileouldsmobile Posts: 16Members, Plex Pass Plex Pass

    I pretty sure it basically works like this, if you have for example say only Dolby Digital, DTS and LPCM checked the receiver should show the DTS and Dolby Digital displays for those two formats. Any other formats i.e. DTS-HD and TrueHD would show as LPCM on the receiver. I don't have a Denon so it may be different slightly.

  • ouldsmobileouldsmobile Posts: 16Members, Plex Pass Plex Pass

    I fixed my original issue. I modified the arch PKGBUILD as so:

    • -DUSE_INTERNAL_FFMPEG='FALSE'
    • -DUSE_INTERNAL_FFMPEG='TRUE'

    Once I recompiled, TrueHD with Atmos is working like a charm. :-)

  • in2survivein2survive Posts: 43Members, Plex Pass Plex Pass

    @ouldsmobile can you shed some light where you made these changes? I downloaded and installed the windows version of openPHT, which is great, but does not support Atmos. I have Denon AVR S910-W, which is Atmos capable, but the only way I get it to play Atmos (or trueHD) is via PHT.

    It would be great if you could provide me a step by step guide... if possible!! :-)

    Thanks!

  • ouldsmobileouldsmobile Posts: 16Members, Plex Pass Plex Pass

    @in2survive I was using an Arch Linux build of OpenPHT which I compiled myself using the tools provided by Arch. I am not sure how you would accomplish the same in Windows, sorry. Also, I don't have an Atmos system. I was just trying to get the TrueHD stream to work correctly. It was having issues with movies that were TrueHD w/Atmos.

  • in2survivein2survive Posts: 43Members, Plex Pass Plex Pass
    edited July 2016

    Oh well, thanks anyways @ouldsmobile. I guess I can still use the old PHT for the handful Atmos movies I have. Hopefully openPHT will support it too eventually.

  • KwibooKwiboo Posts: 193Members, Plex Pass Plex Pass

    @in2survive check your passthrough output device option, there are two output device options in OpenPHT compared to just one in PHT.

  • in2survivein2survive Posts: 43Members, Plex Pass Plex Pass

    I have both setup to WASAPI:Denon... and i just realize that even DTS isn't working. See attached...
    Any suggestion is welcomed!

  • in2survivein2survive Posts: 43Members, Plex Pass Plex Pass
    edited July 2016

    Very interesting... I changed the above setup from 7.1 to 5.1 and both DTS and Atmos now work! Reality is that I have 5.1.2 (2 speakers on the celling). Hum, I'm wondering if that was my fault to begin with... Anyhow, I'm good now!

  • dsdavdcomaudsdavdcomau Posts: 1Members, Plex Pass

    Hi Plex members.

    I have the audio working in atmos from local server files, but when I stream from my main server (remotely shared from another location) it does not send atmos (passthrough)only multipcm. Any thoughts,

  • PoukpalaovaPoukpalaova Posts: 13Members, Plex Pass Plex Pass

    @dsdavdcomau said:
    Hi Plex members.

    I have the audio working in atmos from local server files, but when I stream from my main server (remotely shared from another location) it does not send atmos (passthrough)only multipcm. Any thoughts,

    Probably a limitation of the bandwith/internet upload.

Sign In or Register to comment.